glassfish
  1. glassfish
  2. GLASSFISH-17551

Cannot access paas console after enabling secure admin

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 4.0
    • Fix Version/s: None
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      promoted build b08, windows xp

      Description

      I cannot access paas console after enabling secure admin. Steps to reproduce:

      1. I deployed ConferencePlanner via paas console on promoted build b08 - all working fine.
      2. Enabled secure admin and restart domain.
      3. Access pass console again at http://localhost:8080/paas-console/ - initial screen is displayed.
      Click Login and the following error is displayed:

      HTTP Status 500 - Internal Server Error

      type Exception report

      messageInternal Server Error

      descriptionThe server encountered an internal error (Internal Server Error) that prevented it from fulfilling this request.

      exception

      javax.servlet.ServletException: REST Request 'http://localhost:4848/management/domain/applications/list-applications' failed with response code '302'.

      root cause

      java.lang.RuntimeException: REST Request 'http://localhost:4848/management/domain/applications/list-applications' failed with response code '302'.

      root cause

      java.lang.RuntimeException: REST Request 'http://localhost:4848/management/domain/applications/list-applications' failed with response code '302'.

      note The full stack traces of the exception and its root causes are available in the GlassFish Server Open Source Edition 4.0 logs.

      I'll attach server.log. In order to get paas console working again, disable secure admin.

        Activity

        Anissa Lam added a comment -

        Paas console is for 4.0, the trunk.
        Thus exclude from 3.x release.

        Anissa Lam added a comment -

        PaaS console will not be delivered for 4.0. Won't fix.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            lidiam
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: