glassfish
  1. glassfish
  2. GLASSFISH-17577

[IBM JDK7]All the appclient related test cases failed on AIX against IBM JDK1.7

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1.2_b07
    • Fix Version/s: 3.1.2_b08
    • Component/s: naming
    • Labels:
      None
    • Environment:

      Description

      build: GF 3.1.2 b07
      OS: AIX
      jdk: IBM JDK1.7

      SQE appclient related test cases passed on AIX against IBM JDK1.6, but all failed against IBM JDK1.7.

      Steps to reproduce the bug:
      1.Checkout SQE workspace:
      cvs co appserver-sqe/bootstrap.xml
      (CVSROOT=:pserver:cvsguest@sunsw.us.oracle.com:/m/jws)
      cd appserver-sqe
      ant -f bootstrap.xml co-smoke-test
      2. install GF V3.1.2 on AIX, start domain domain1
      3. Set the following env. variables
      S1AS_HOME <GF installation dir> (example: /export/hudson/workspace/glassfishv3/glassfish
      SPS_HOME <workspace dir> (example: /export/hudson/workspace/appserver-sqe)
      ANT_HOME <ant 1.7.1 dir>
      JAVA_HOME <java dir point to IBM jdk1.7>
      > 4. cd appserver-sqe/pe/ejb/mdb/basic, run "ant all", the test failed and the following exceptions displayed:
      runclient-common:
      [echo] Executing appclient at /export/hudson/workspace/alex-aix-smoke/appserver-sqe/pe/ejb/mdb/basic
      [echo] Nov 02, 2011 9:05:45 AM org.glassfish.appclient.client.acc.AppclientCommandArguments warnAboutPasswordUsage
      [echo] WARNING: ACC013: The -password option is deprecated and will likely be removed in a future release. Please use -passwordfile or let the app client container prompt for the username and/or password if they are needed to access a remote resource.
      [echo] WS HOME appserver-sqe
      [echo] In main before calling init
      [echo] basicJMS2EJB initTopic failed: unexpected NamingException
      [echo] javax.naming.NamingException: Lookup failed for 'java:comp/env/jms/basicTopic' in SerialContext[myEnv=

      {java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.url.pkgs=com.sun.enterprise.naming, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl}

      [Root exception is javax.naming.CommunicationException: Communication exception for SerialContext[myEnv=

      {java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.url.pkgs=com.sun.enterprise.naming, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, com.sun.enterprise.naming.logicalName=java:comp/env/jms/basicTopic}

      [Root exception is java.rmi.RemoteException: CORBA UNKNOWN 1330446338 Maybe; nested exception is:
      [echo] org.omg.CORBA.UNKNOWN: ---------BEGIN server-side stack trace---------
      [echo] org.omg.CORBA.UNKNOWN: WARNING: IOP00010002: Unknown user exception thrown by the server - exception: java.lang.IllegalArgumentException; message: null vmcid: OMG minor code: 2 completed: Maybe
      [echo] at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      [echo] at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:80)
      [echo] at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:57)
      [echo] at java.lang.reflect.Constructor.newInstance(Constructor.java:539)
      [echo] at com.sun.corba.ee.spi.orbutil.logex.corba.CorbaExtension.makeException(CorbaExtension.java:248)
      [echo] at com.sun.corba.ee.spi.orbutil.logex.corba.CorbaExtension.makeException(CorbaExtension.java:95)
      [echo] at com.sun.corba.ee.spi.orbutil.logex.WrapperGenerator.handleFullLogging(WrapperGenerator.java:387)
      [echo] at com.sun.corba.ee.spi.orbutil.logex.WrapperGenerator.access$400(WrapperGenerator.java:107)
      [echo] at com.sun.corba.ee.spi.orbutil.logex.WrapperGenerator$2.invoke(WrapperGenerator.java:511)
      [echo] at com.sun.corba.ee.spi.orbutil.proxy.CompositeInvocationHandlerImpl.invoke(CompositeInvocationHandlerImpl.java:99)
      [echo] at $Proxy184.runtimeexception(Unknown Source)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.convertThrowableToSystemException(CorbaMessageMediatorImpl.java:1843)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handleThrowableDuringServerDispatch(CorbaMessageMediatorImpl.java:1793)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handleThrowableDuringServerDispatch(CorbaMessageMediatorImpl.java:1758)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImpl.dispatch(CorbaServerRequestDispatcherImpl.java:255)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handleRequestRequest(CorbaMessageMediatorImpl.java:1624)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handleRequest(CorbaMessageMediatorImpl.java:1486)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handleInput(CorbaMessageMediatorImpl.java:990)
      [echo] at com.sun.corba.ee.impl.protocol.giopmsgheaders.RequestMessage_1_2.callback(RequestMessage_1_2.java:214)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handleRequest(CorbaMessageMediatorImpl.java:742)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.dispatch(CorbaMessageMediatorImpl.java:539)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.doWork(CorbaMessageMediatorImpl.java:2324)
      [echo] at com.sun.corba.ee.impl.orbutil.threadpool.ThreadPoolImpl$WorkerThread.performWork(ThreadPoolImpl.java:497)
      [echo] at com.sun.corba.ee.impl.orbutil.threadpool.ThreadPoolImpl$WorkerThread.run(ThreadPoolImpl.java:540)
      [echo] Caused by: java.lang.IllegalArgumentException
      [echo] at java.nio.Buffer.position(Buffer.java:247)
      [echo] at sun.nio.cs.UTF16_Decoder.decodeLoop(UTF16_Decoder.java:186)
      [echo] at java.nio.charset.CharsetDecoder.decode(CharsetDecoder.java:561)
      [echo] at java.nio.charset.CharsetDecoder.decode(CharsetDecoder.java:783)
      [echo] at com.sun.corba.ee.impl.encoding.CodeSetConversion$JavaBTCConverter.getChars(CodeSetConversion.java:413)
      [echo] at com.sun.corba.ee.impl.encoding.CodeSetConversion$UTF16BTCConverter.getChars(CodeSetConversion.java:559)
      [echo] at com.sun.corba.ee.impl.encoding.CDRInputStream_1_0.getConvertedChars(CDRInputStream_1_0.java:2325)
      [echo] at com.sun.corba.ee.impl.encoding.CDRInputStream_1_2.read_wstring(CDRInputStream_1_2.java:171)
      [echo] at com.sun.corba.ee.impl.encoding.CDRInputStream_1_0.read_value(CDRInputStream_1_0.java:1082)
      [echo] at com.sun.corba.ee.impl.encoding.CDRInputObject.read_value(CDRInputObject.java:531)
      [echo] at com.sun.corba.ee.impl.presentation.rmi.DynamicMethodMarshallerImpl$14.read(DynamicMethodMarshallerImpl.java:384)
      [echo] at com.sun.corba.ee.impl.presentation.rmi.DynamicMethodMarshallerImpl.readArguments(DynamicMethodMarshallerImpl.java:451)
      [echo] at com.sun.corba.ee.impl.presentation.rmi.ReflectiveTie._invoke(ReflectiveTie.java:172)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImpl.dispatchToServant(CorbaServerRequestDispatcherImpl.java:528)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImpl.dispatch(CorbaServerRequestDispatcherImpl.java:199)
      [echo] ... 9 more
      [echo]
      [echo] ---------END server-side stack trace--------- vmcid: OMG minor code: 2 completed: Maybe]]
      [echo] at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:518)
      [echo] at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:455)
      [echo] at javax.naming.InitialContext.lookup(InitialContext.java:422)
      [echo] at com.sun.s1peqe.ejb.mdb.basic.BasicJMS2EJBClient.initTopic(BasicJMS2EJBClient.java:63)
      [echo] at com.sun.s1peqe.ejb.mdb.basic.BasicJMS2EJBClient.init(BasicJMS2EJBClient.java:52)
      [echo] at com.sun.s1peqe.ejb.mdb.basic.BasicJMS2EJBClient.main(BasicJMS2EJBClient.java:315)
      [echo] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [echo] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
      [echo] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
      [echo] at java.lang.reflect.Method.invoke(Method.java:613)
      [echo] at org.glassfish.appclient.client.acc.AppClientContainer.launch(AppClientContainer.java:438)
      [echo] at org.glassfish.appclient.client.AppClientFacade.launch(AppClientFacade.java:182)
      [echo] at org.glassfish.appclient.client.AppClientGroupFacade.main(AppClientGroupFacade.java:65)
      [echo] Caused by: javax.naming.CommunicationException: Communication exception for SerialContext[myEnv=

      {java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.url.pkgs=com.sun.enterprise.naming, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, com.sun.enterprise.naming.logicalName=java:comp/env/jms/basicTopic}

      [Root exception is java.rmi.RemoteException: CORBA UNKNOWN 1330446338 Maybe; nested exception is:
      [echo] org.omg.CORBA.UNKNOWN: ---------BEGIN server-side stack trace---------
      [echo] org.omg.CORBA.UNKNOWN: WARNING: IOP00010002: Unknown user exception thrown by the server - exception: java.lang.IllegalArgumentException; message: null vmcid: OMG minor code: 2 completed: Maybe
      [echo] at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      [echo] at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:80)
      [echo] at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:57)
      [echo] at java.lang.reflect.Constructor.newInstance(Constructor.java:539)
      [echo] at com.sun.corba.ee.spi.orbutil.logex.corba.CorbaExtension.makeException(CorbaExtension.java:248)
      [echo] at com.sun.corba.ee.spi.orbutil.logex.corba.CorbaExtension.makeException(CorbaExtension.java:95)
      [echo] at com.sun.corba.ee.spi.orbutil.logex.WrapperGenerator.handleFullLogging(WrapperGenerator.java:387)
      [echo] at com.sun.corba.ee.spi.orbutil.logex.WrapperGenerator.access$400(WrapperGenerator.java:107)
      [echo] at com.sun.corba.ee.spi.orbutil.logex.WrapperGenerator$2.invoke(WrapperGenerator.java:511)
      [echo] at com.sun.corba.ee.spi.orbutil.proxy.CompositeInvocationHandlerImpl.invoke(CompositeInvocationHandlerImpl.java:99)
      [echo] at $Proxy184.runtimeexception(Unknown Source)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.convertThrowableToSystemException(CorbaMessageMediatorImpl.java:1843)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handleThrowableDuringServerDispatch(CorbaMessageMediatorImpl.java:1793)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handleThrowableDuringServerDispatch(CorbaMessageMediatorImpl.java:1758)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImpl.dispatch(CorbaServerRequestDispatcherImpl.java:255)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handleRequestRequest(CorbaMessageMediatorImpl.java:1624)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handleRequest(CorbaMessageMediatorImpl.java:1486)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handleInput(CorbaMessageMediatorImpl.java:990)
      [echo] at com.sun.corba.ee.impl.protocol.giopmsgheaders.RequestMessage_1_2.callback(RequestMessage_1_2.java:214)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handleRequest(CorbaMessageMediatorImpl.java:742)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.dispatch(CorbaMessageMediatorImpl.java:539)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.doWork(CorbaMessageMediatorImpl.java:2324)
      [echo] at com.sun.corba.ee.impl.orbutil.threadpool.ThreadPoolImpl$WorkerThread.performWork(ThreadPoolImpl.java:497)
      [echo] at com.sun.corba.ee.impl.orbutil.threadpool.ThreadPoolImpl$WorkerThread.run(ThreadPoolImpl.java:540)
      [echo] Caused by: java.lang.IllegalArgumentException
      [echo] at java.nio.Buffer.position(Buffer.java:247)
      [echo] at sun.nio.cs.UTF16_Decoder.decodeLoop(UTF16_Decoder.java:186)
      [echo] at java.nio.charset.CharsetDecoder.decode(CharsetDecoder.java:561)
      [echo] at java.nio.charset.CharsetDecoder.decode(CharsetDecoder.java:783)
      [echo] at com.sun.corba.ee.impl.encoding.CodeSetConversion$JavaBTCConverter.getChars(CodeSetConversion.java:413)
      [echo] at com.sun.corba.ee.impl.encoding.CodeSetConversion$UTF16BTCConverter.getChars(CodeSetConversion.java:559)
      [echo] at com.sun.corba.ee.impl.encoding.CDRInputStream_1_0.getConvertedChars(CDRInputStream_1_0.java:2325)
      [echo] at com.sun.corba.ee.impl.encoding.CDRInputStream_1_2.read_wstring(CDRInputStream_1_2.java:171)
      [echo] at com.sun.corba.ee.impl.encoding.CDRInputStream_1_0.read_value(CDRInputStream_1_0.java:1082)
      [echo] at com.sun.corba.ee.impl.encoding.CDRInputObject.read_value(CDRInputObject.java:531)
      [echo] at com.sun.corba.ee.impl.presentation.rmi.DynamicMethodMarshallerImpl$14.read(DynamicMethodMarshallerImpl.java:384)
      [echo] at com.sun.corba.ee.impl.presentation.rmi.DynamicMethodMarshallerImpl.readArguments(DynamicMethodMarshallerImpl.java:451)
      [echo] at com.sun.corba.ee.impl.presentation.rmi.ReflectiveTie._invoke(ReflectiveTie.java:172)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImpl.dispatchToServant(CorbaServerRequestDispatcherImpl.java:528)
      [echo] at com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImpl.dispatch(CorbaServerRequestDispatcherImpl.java:199)
      [echo] ... 9 more
      [echo]

      There are some exceptions in the server.log, please see attached server.log for more details.

        Activity

        Sanjeeb Sahoo added a comment -

        I am pretty sure this bug was fixed in 3.1.2 otherwise we would not have been able to certify 3.1.2 on Aix. So, I am not sure what has changed since then. Pl open a new bug. If you want me to investigate this bug, please prove that it was not fixed in 3.1.2. Use the AIX version that's certified to be used with 3.1.2.

        Sanjeeb Sahoo added a comment - - edited

        I could not use appserver-sqe test suite. cvs checkout is still running for last 2+ hours. So, I went ahead and wrote my own appclient->remoteEjb test case. I confirm that a simple appclient->remoteEjb scenario is NOT working using glassfish-3.1.2-aix.zip as I downloaded from glassfish.org download page. I am getting the exact same error reported by the submitter. I am using the same version of IBM JDK used by the submitter of this bug, except that I am using on Linux, but that does not matter. I get the same error as reported by the submitter.

        Where is the confusion and what have we so far fixed then? Actually, there was another naming bug that needed cropped up when we used IBM JDK 7. The attached server.log had the following exception and that made Cheng assign the issue to me as you can see from his earlier comment [1]. He did that because I had once fixed GLASSFISH-16882 to address a similar stack trace:

        [#|2011-11-02T09:07:09.460-0700|SEVERE|glassfish3.1.2|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=117;_ThreadName=Thread-10;|Caused by: |#]

        [#|2011-11-02T09:07:09.461-0700|SEVERE|glassfish3.1.2|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=117;_ThreadName=Thread-10;|java.lang.NoSuchFieldException: icfb|#]

        [#|2011-11-02T09:07:09.462-0700|SEVERE|glassfish3.1.2|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=117;_ThreadName=Thread-10;| at java.lang.Class.getDeclaredFieldImpl(Native Method)|#]

        [#|2011-11-02T09:07:09.463-0700|SEVERE|glassfish3.1.2|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=117;_ThreadName=Thread-10;| at java.lang.Class.getDeclaredField(Class.java:533)|#]

        [#|2011-11-02T09:07:09.464-0700|SEVERE|glassfish3.1.2|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=117;_ThreadName=Thread-10;| at com.sun.enterprise.naming.GlassFishNamingBuilder.resetInitialContextFactoryBuilder(GlassFishNamingBuilder.java:215)|#]

        [#|2011-11-02T09:07:09.464-0700|SEVERE|glassfish3.1.2|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=117;_ThreadName=Thread-10;| ... 12 more|#]

        It was a valid issue and has been fixed by me and forward ported to trunk as well. But, unfortunately, that does not address everything that's reported here. The remaining issue has to be investigated by a COSNaming engineer (Harsad Vilekar may be?). All in all, we have work to do make things work on IBM JDK 7. What was not told to us that GF 3.1.2 was not certified on IBM-JDK7; it was only certified on IBM-JDK6.

        [1] http://java.net/jira/browse/GLASSFISH-17577?focusedCommentId=324750&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#action_324750

        guojun.shan added a comment -

        we need help from CORBA team. re-assign to Harshad.

        Harshad Vilekar added a comment -

        I could duplicate the exception using a very simple HelloWorld remote EJB test, with IBM AIX JDK7. The part of the stack trace of interest is:
        ================================================
        [echo] Caused by: java.lang.IllegalArgumentException
        [echo] at java.nio.Buffer.position(Buffer.java:247)
        [echo] at sun.nio.cs.UTF16_Decoder.decodeLoop(UTF16_Decoder.java:186)
        [echo] at java.nio.charset.CharsetDecoder.decode(CharsetDecoder.java:561)
        [echo] at
        java.nio.charset.CharsetDecoder.decode(CharsetDecoder.java:783)
        [echo] at
        com.sun.corba.ee.impl.encoding.CodeSetConversion$JavaBTCConverter.getChars(Cod
        eSetConversion.java:413)
        ================================================

        Note the part of the JDK code in the stack trace. Exact same test works fine with IBM AIX JDK6. This looks like a regression in IBM AIX JDK7.

        The issue is worked around in the Corba code by reconstructing the ByteBuffer, and then passing it to the JDK CharsetDecoder.

        Requesting QA review of the fix.
        The Corba patch is attached. To apply the patch:
        --------------------
        Install GlassFish 3.1.2 update 6

        cd $GF_INSTALL_DIR/glassfish3/glassfish/modules
        jar xvf patch-GLASSFISH-17577.zip
        jar uvf glassfish-corba-orb.jar com/sun/corba/ee/impl/encoding
        \rm -rf com/sun/corba/

        Restart GlassFish
        --------------------
        Please test the attached patch and update the bug report with the results.

        Harshad Vilekar added a comment -

        Fixed committed. GlassFish 3.1.2 svn revision 14819.

        glassfish-corba source gf-corba-v3-mirror~gfv31-master, hg revision 708, build 3.1.2-b001.

        Please regression test all remote EJB related functionality with IBM AIX JDK7.


          People

          • Assignee:
            Harshad Vilekar
            Reporter:
            sonialiu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: