glassfish
  1. glassfish
  2. GLASSFISH-17649

create-domain is failing to start the embedded DAS for domain customization

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0
    • Fix Version/s: 4.0
    • Component/s: admin
    • Labels:
      None

      Description

      create-domain is producing the following error message:

      java.lang.NoClassDefFoundError: org/glassfish/grizzly/config/dom/NetworkConfig

      The stack trace for this is:

      at java.lang.Class.getDeclaredMethods0(Native Method)
      at java.lang.Class.privateGetDeclaredMethods(Class.java:2427)
      at java.lang.Class.privateGetPublicMethods(Class.java:2547)
      at java.lang.Class.getMethods(Class.java:1410)
      at sun.misc.ProxyGenerator.generateClassFile(ProxyGenerator.java:409)
      at sun.misc.ProxyGenerator.generateProxyClass(ProxyGenerator.java:306)
      at java.lang.reflect.Proxy.getProxyClass(Proxy.java:501)
      at java.lang.reflect.Proxy.newProxyInstance(Proxy.java:581)
      at org.glassfish.config.support.TranslatedConfigView.getProxy(TranslatedConfigView.java:136)
      at org.glassfish.config.support.GlassFishConfigBean.createProxy(GlassFishConfigBean.java:98)
      at org.jvnet.hk2.config.Dom.createProxy(Dom.java:866)
      at org.jvnet.hk2.config.ConfigModel$CollectionNode$1.get(ConfigModel.java:430)
      at org.jvnet.hk2.config.ConfigBean$2.get(ConfigBean.java:203)
      at java.util.AbstractList$Itr.next(AbstractList.java:345)
      at com.sun.enterprise.config.serverbeans.Server$Duck.getConfig(Server.java:407)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.jvnet.hk2.config.Dom.invokeDuckMethod(Dom.java:948)
      at org.jvnet.hk2.config.Dom.invoke(Dom.java:901)
      at org.glassfish.config.support.TranslatedConfigView.invoke(TranslatedConfigView.java:119)
      at $Proxy16.getConfig(Unknown Source)
      at org.glassfish.config.support.DomainXml.decorate(DomainXml.java:149)
      at org.glassfish.config.support.DomainXml.run(DomainXml.java:140)
      at com.sun.enterprise.module.common_impl.AbstractModulesRegistryImpl.populateConfig(AbstractModulesRegistryImpl.java:190)
      at com.sun.enterprise.module.common_impl.AbstractModulesRegistryImpl.createHabitat(AbstractModulesRegistryImpl.java:169)
      at com.sun.enterprise.module.bootstrap.Main.createHabitat(Main.java:425)
      at com.sun.enterprise.glassfish.bootstrap.StaticGlassFishRuntime.newGlassFish(StaticGlassFishRuntime.java:104)
      at org.glassfish.internal.embedded.Server.<init>(Server.java:272)
      at org.glassfish.internal.embedded.Server.<init>(Server.java:66)
      at org.glassfish.internal.embedded.Server$Builder.build(Server.java:176)
      at com.sun.enterprise.admin.servermgmt.cli.CreateDomainCommand.modifyInitialDomainXml(CreateDomainCommand.java:782)
      at com.sun.enterprise.admin.servermgmt.cli.CreateDomainCommand.createTheDomain(CreateDomainCommand.java:565)
      at com.sun.enterprise.admin.servermgmt.cli.CreateDomainCommand.executeCommand(CreateDomainCommand.java:359)
      at com.sun.enterprise.admin.cli.CLICommand.execute(CLICommand.java:264)
      at com.sun.enterprise.admin.cli.AsadminMain.executeCommand(AsadminMain.java:299)
      at com.sun.enterprise.admin.cli.AsadminMain.main(AsadminMain.java:238)
      Caused by: java.lang.ClassNotFoundException: org.glassfish.grizzly.config.dom.NetworkConfig
      at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
      at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
      ... 38 more

        Activity

        Tom Mueller added a comment -

        The root cause of this problem is that the various Grizzly JAR files, including grizzly-config.jar (which contains NetworkConfig.class) are being merged into a nucleus-grizzly-all.jar file within nucleus. Since that JAR file isn't in the classpath for any other JAR file, it is not being picked up by the create-domain command running within asadmin.

        Tom Mueller added a comment -

        Fixed on the trunk in revision 51652.


          People

          • Assignee:
            Tom Mueller
            Reporter:
            Tom Mueller
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: