glassfish
  1. glassfish
  2. GLASSFISH-17711

There is an error when create backup named with Japanese characters

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.2_dev
    • Fix Version/s: 3.1.2_dev, 4.0
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Server OS: OEL 6 x64 w/JDK1.6.0_29 32bit
      Bundle: ogs-3.1.2-b09-unix-ml.sh
      Server Locale: fr_FR.UTF-8

      Description

      There is an error when create backup named with Japanese characters

      To reproduce:
      1. Go to Domain -> Backup -> Backup Settings, and click on New button.
      2. In Name filed type Japanese characters, and click on OK to save.
      3. Click on newly created backup.

      There is an error, attached screen shot for your reference.

        Activity

        srinik76 added a comment -

        Save is failing in edit because the name is not encoded. The fix is

        Index: backupConfigEdit.jsf
        ===================================================================
        — backupConfigEdit.jsf (revision 3297)
        +++ backupConfigEdit.jsf (working copy)
        @@ -60,7 +60,7 @@
        setPageSessionAttribute(key="selfPage" value="#

        {request.contextPath}

        /dasrecovery/backupConfigEdit.jsf?name=#

        {pageSession.encodedName}&cancelTo=#{pageSession.cancelTo}");
        setPageSessionAttribute(key="childType" value="backup-config");
        setPageSessionAttribute(key="parentUrl", value="#{sessionScope.REST_URL}/configs/config/server-config/backup-configs");
        - setPageSessionAttribute(key="selfUrl", value="#{pageSession.parentUrl}/#{pageSession.childType}/#{pageSession.Name}");
        + setPageSessionAttribute(key="selfUrl", value="#{pageSession.parentUrl}/#{pageSession.childType}/#{pageSession.encodedName}

        ");
        setPageSessionAttribute(key="rest-api" value="true");
        gf.getEntityAttrs(endpoint="#

        {pageSession.selfUrl}

        ", valueMap="#

        {pageSession.valueMap}

        ");

        srinik76 added a comment -
        • What is the impact on the customer of the bug?
          How likely is it that a customer will see the bug and how serious is the bug?
          Is it a regression? Does it meet other bug fix criteria (security, performance, etc.)?

        When the user creates backup name with japanese character it fails during edit option and editing is not allowed

        • What is the cost/risk of fixing the bug?
          How risky is the fix? How much work is the fix? Is the fix complicated?

        Fix not complicated.

        • Is there an impact on documentation or message strings?
          No.
        • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
          Manual testing
        • Which is the targeted build of 3.1.2 for this fix?
          3.1.2_b16
        srinik76 added a comment - - edited

        checked into 3.1.2 branch

        Sending das-recovery/gui/src/main/resources/backupConfigEdit.jsf
        Transmitting file data .
        Committed revision 3413.

        Checked into trunk

        Sending resources/backupConfigEdit.jsf
        Transmitting file data .
        Committed revision 3414.


          People

          • Assignee:
            srinik76
            Reporter:
            sunny-gui
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: