glassfish
  1. glassfish
  2. GLASSFISH-17762

JROCKIT: Exception while loading the app : EJB Container initialization error.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 3.1.2_b09
    • Fix Version/s: None
    • Component/s: ejb_container
    • Labels:
      None

      Description

      OEL 5 machines with JRockit JDK 1.6.0_26. Created a cluster with two instances, one instance per a machine.

      After domain and cluster were started or stopped/started, tried to deploy ejb apps, for example stateless-simple.ear. In some cases saw such errors during a deployment:
      =========================================================
      Application deployed with name stateless-simple.
      WARNING: Command _deploy did not complete successfully on server instance my-in1: remote failure: Failed to load the applicat
      ion on instance my-in1. The application will not run properly. Please fix your application and redeploy.
      Exception while loading the app : EJB Container initialization error. Please see server.log for more details.
      =================================================

      or
      ===============================================================
      remote failure: Error occurred during deployment: Exception while preparing the app : Aborting, Failed to start container org.glassfish.ejb.startup.EjbContainerStarter. Please see server.log for more details.
      Aborting, Failed to start container org.glassfish.ejb.startup.EjbContainerStarter
      Command deploy failed.
      ========================================================

      When I've tried to deploy richAccess to the cluster with three instances, one instance per a machine, I saw such error more often. Usually, second deployment would be OK.

        Activity

        Cheng Fang added a comment - - edited

        Could be the same issue as http://java.net/jira/browse/GLASSFISH-17775 (Sometimes after start-instance or start-cluster for some instances ejb app was not available (404 error))

        easarina added a comment -

        Installed on OEL 5 machines GF 3.1.2 b12 with jrockit 1.6.0_29-b11. Still saw this problem sometimes.

        sb110099 added a comment -

        Upgrading the bug to P2, as it needs some evaluation and attention for 3.1.2 certification with JRockit .

        – Sudipa

        shreedhar_ganapathy added a comment -

        Could you please attach latest server logs so we can see if it is indeed related to 17775 or another issue?

        easarina added a comment -

        OEL 6 GF build 14, JRockit JDK 1.6.0_29. Three instances in a cluster , one instance per a machine. Made a fresh installation, started instances and tried to deploy stateless-simple.ear, the deployment to one instance failed. I've attached a full server.log file

        marina vatkina added a comment -

        It is a duplicate of 17775 - see

        Caused by: java.lang.NullPointerException
        at com.sun.logging.LogDomains$1.initResourceBundle(LogDomains.java:429)
        at com.sun.logging.LogDomains$1.<init>(LogDomains.java:356)
        at com.sun.logging.LogDomains.getLogger(LogDomains.java:353)
        at org.glassfish.enterprise.iiop.api.GlassFishORBHelper.<clinit>(GlassFishORBHelper.java:85)

        in the log


          People

          • Assignee:
            Cheng Fang
            Reporter:
            easarina
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: