glassfish
  1. glassfish
  2. GLASSFISH-17763

Sometimes domain doesn't start: The server exited prematurely with exit code 1.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1.2_b09
    • Fix Version/s: None
    • Component/s: other
    • Labels:
      None

      Description

      OEL 5, JRockit JDK 1.6.0_26. Sometimes domain doesn't start, but creates such error message:

      =========================================================
      The server exited prematurely with exit code 1.
      Before it died, it produced the following output:

      Launching GlassFish on Felix platform
      Completed shutdown of GlassFish runtime
      [WARN ][jrockit] MaxPermSize=192m ignored: Not a valid option for JRockit
      [WARN ][jrockit] NewRatio=2 ignored: Not a valid option for JRockit
      =============================================================

      Usually, next attempt to start the domain would be successful.

      More often I saw this error, when I've restarted several times domain after richAccess deployment. But in general, this problem happened randomly.

        Issue Links

          Activity

          easarina added a comment -

          I want to add that now on OEL 6 with b14 each start of cluster creates this issue and many start-instance, start-local-instance create this issue also, so it is hard to start these three instances.

          Sanjeeb Sahoo added a comment -

          Vijay,

          This bug has again been reopened. Could you investigate further?

          Thanks,
          Sahoo

          vijay_oracle added a comment -

          Hi elina,

          I am not able to reproduce this on my environment. Can you please share your environment so that i can have a detailed look at the logs ?

          • Vijay C
          vijay_oracle added a comment -

          This is a duplicate of GLASSFISH-17775 . Fix available in b15. Please test it against this build.

          vijay_oracle added a comment -

          Duplicate of ASSFISH-17775. Fix available from b15.


            People

            • Assignee:
              vijay_oracle
              Reporter:
              easarina
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: