glassfish
  1. glassfish
  2. GLASSFISH-17775

JROCKIT: Sometimes after start-instance or start-cluster for some instances ejb app was not available (404 error)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1.2_b10
    • Fix Version/s: 3.1.2_b15
    • Component/s: logging
    • Labels:
      None

      Description

      OEL 5 machines, JRockit 1.6.0_26 JDK. Created a cluster with three instances, one instance per a machine. Deployed richAccess, restarted a cluster and find out that richAccess was not available for all instances, i.e. for some instances was seen 404 error. Then I've made a lot of experiments, i.e. stopped/started instances many times using different start commands, as start-cluster, start-instance, start-local-instance. I would say that, if instance is started using start-instance command, then in most cases richAccess would not be available. If to use start-local-instance, it would be available. For example, I've started one instance, using start-local-instance and two instances, using start-instance, richAccess was available only through the instance that used start-local-instance. I saw that issue for other app, for example stateless-simple, but for richAccess the issue was seen more often than for sateless-simple. I've attached rich richAccess, I did not see any errors in server.logs when richAccess was not available. But when this problem happened in the correspondent log file from instance start, I saw such messages:

      ===========================================
      [#|2011-11-18T16:55:13.445-0800|SEVERE|glassfish3.1.2|javax.enterprise.system.core.com.sun.enterprise.v3.server|_ThreadID=10;_ThreadName=Thread-2;|Cannot start container ejb
      org.jvnet.hk2.component.ComponentException: injection failed on org.glassfish.ejb.startup.EjbContainerStarter.ejbContainerUtilImpl with interface com.sun.ejb.containers.EjbContainerUtil
      =============================================

      I've attached such log file.

        Issue Links

          Activity

          Harshad Vilekar added a comment -

          > Caused by: java.lang.NullPointerException
          > at com.sun.logging.LogDomains$1.initResourceBundle(LogDomains.java:429)

          Reassigning to logging to review why getLogger is returning null on JRockit for following:

          LogDomains.getLogger(GlassFishORBHelper.class, LogDomains.CORBA_LOGGER);

          naman_mehta added a comment -

          I tried to reproduce the issue but couldn't make it. It is working fine for me as I followed steps mentioned in config.sh file.

          Used JRockit:
          java version "1.6.0_29"
          Java(TM) SE Runtime Environment (build 1.6.0_29-b11)
          Oracle JRockit(R) (build R28.2.0-79-146777-1.6.0_29-20111005-1807-linux-ia32, compiled mode)

          Tried to reporoduce on Ubuntu 11.10.

          Steps I followed:
          1. Setup latest 3.1.2
          2. Setup JRockit and use to start GF
          3. Created 2 instances cluster
          4. Run all the steps from config.sh
          5. Deployment is going fine every time
          6. Restart of instance is also going fine

          But as per the error it's throwing NPE at LogDomains.java:429 so I verified logger for null before using the same. So in future it won't give NPE in LogDomains.

          Please try the same on your machine with latest 3.1.2 nightly. Let me know it's still reproducible or not.

          easarina added a comment -

          I've saw this issue recently. I.e. I've installed build 14 started domain, cluster and then tried to open richAccess home page through my three instances. It did not work (because of this issue), until I've restarted instances many times.

          Before it happened, on the same machines, with the same bits I did the same installation configuration (I'm using scripts, so the configuration was the same) and did not see that issue. But saw an issue that was described in the bug: http://java.net/jira/browse/GLASSFISH-17762

          easarina added a comment -

          Also, my advice, try OEL 6

          naman_mehta added a comment -

          I made some changes related to NPE yesterday only. Now it should not throw NPE in LogDomains.

          So you can try with build b15-12_19_2011.


            People

            • Assignee:
              naman_mehta
              Reporter:
              easarina
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: