1. glassfish
  2. GLASSFISH-17839

Applications page performance issues related to large number of deployments.


    • Type: Improvement Improvement
    • Status: Open
    • Priority: Critical Critical
    • Resolution: Unresolved
    • Affects Version/s: 3.1.1
    • Fix Version/s: future release
    • Component/s: admin_gui
    • Labels:


      This was brought up in the forum discussion:
      However, the following discussion in the email wasn't captured in the forum.

      On 11/24/2011 05:56 PM, Anissa Lam wrote:
      > Hi Bernhard,
      > On 11/24/11 3:51 AM, Bernhard Thalmayr wrote:
      >> A 'DAS' (domain administration server) corresponsds to one 'domain'
      >> The applications will be deployed into the domain repository (hosted
      >> by the 'DAS') and an application reference will exist for every
      >> instance the application should be available.
      >> The admin-console you become somewhat messy (nearly unusable) if you
      >> have 100 web-apps deployed (you may need to use the CLI instead).
      > Can you elaborate on the above statement ? Is it performance, UI, layout
      > of pages or workflow that makes you feel that way ? We strive to improve
      > user experience on the console and your feedback and suggestion will be
      > greatly appreciated.

      Thanks for your attention Anissa.

      For every application deployed the console tries to determine the state f it on every server. This can take a very long time.

      You just get the hint 'long running process detected' (or similar).

      Currently I have about 25 application deployed and IMHO it's already almost usable. Personally I don't mind to much because I'm using the CLI anyway, but the developers are always using the console and they are complaining a lot.

      Although I'm using GF 3.1.1 I still have issues with 'running out of file handles' due to REST-calls not cleaning up the sockets correctly - similar ( This error is very nasty and makes the console almost unusable if you can not tweak the FD limits at the OS level.
      (Of course I set the 'linger' stuff ... but this does not help at all)


      Think this is probably due to the time for detecting the enabled status or each application and its application-ref.
      May need to asynchronously update the status when they are available, instead of waiting for everything before displaying the page.



          • Assignee:
            Anissa Lam
          • Votes:
            0 Vote for this issue
            0 Start watching this issue


            • Created: