glassfish
  1. glassfish
  2. GLASSFISH-17856

java.lang.NoClassDefFoundError: org/eclipse/persistence/sdo/helper/SDOHelperContext

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: 3.1.2
    • Fix Version/s: None
    • Component/s: packaging
    • Labels:
      None
    • Environment:

      Linux, GlassFish Server Open Source Edition 3.1.2-SNAPSHOT (12)

      Description

      1)Download and install latest glassfish 3.1.2 nightly build.
      2)Start the server
      3)Enable SDO
      asadmin create-jvm-options --target server -Dcom.sun.xml.ws.spi.db.BindingContextFactory=com.sun.xml.ws.db.sdo.SDOContextFactory
      4)Restart the glassfish
      5)Now deploy the attached simple webservice app.
      6)Check the server log.

        Activity

        Sreekanth added a comment -

        Exception stacktrace:
        =====================

        [#|2011-11-30T19:26:48.421+0530|WARNING|glassfish3.1.2|javax.enterprise.webservices.org.glassfish.webservices|_ThreadID=20;_ThreadName=Thread-2;|Deployment failed
        java.lang.NoClassDefFoundError: org/eclipse/persistence/sdo/helper/SDOHelperContext
        at com.sun.xml.ws.db.sdo.SDOContextWrapper.<init>(SDOContextWrapper.java:78)
        at com.sun.xml.ws.db.sdo.SDOContextFactory.newContext(SDOContextFactory.java:19)
        at com.sun.xml.ws.spi.db.BindingContextFactory.create(BindingContextFactory.java:190)
        at com.sun.xml.ws.model.AbstractSEIModelImpl$1.run(AbstractSEIModelImpl.java:212)
        at com.sun.xml.ws.model.AbstractSEIModelImpl$1.run(AbstractSEIModelImpl.java:185)
        at java.security.AccessController.doPrivileged(Native Method)
        at com.sun.xml.ws.model.AbstractSEIModelImpl.createJAXBContext(AbstractSEIModelImpl.java:185)
        at com.sun.xml.ws.model.AbstractSEIModelImpl.postProcess(AbstractSEIModelImpl.java:110)
        at com.sun.xml.ws.model.RuntimeModeler.buildRuntimeModel(RuntimeModeler.java:320)
        at com.sun.xml.ws.db.DatabindingImpl.<init>(DatabindingImpl.java:99)
        at com.sun.xml.ws.db.DatabindingProviderImpl.create(DatabindingProviderImpl.java:74)
        at com.sun.xml.ws.db.DatabindingProviderImpl.create(DatabindingProviderImpl.java:58)
        at com.sun.xml.ws.db.DatabindingFactoryImpl.createRuntime(DatabindingFactoryImpl.java:130)
        at com.sun.xml.ws.server.EndpointFactory.createSEIModel(EndpointFactory.java:433)
        at com.sun.xml.ws.server.EndpointFactory.create(EndpointFactory.java:268)
        at com.sun.xml.ws.server.EndpointFactory.createEndpoint(EndpointFactory.java:145)
        at com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:574)
        at com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:557)
        at com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:629)
        at org.glassfish.webservices.WSServletContextListener.registerEndpoint(WSServletContextListener.java:282)
        at org.glassfish.webservices.WSServletContextListener.contextInitialized(WSServletContextListener.java:102)
        at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:4750)
        at com.sun.enterprise.web.WebModule.contextListenerStart(WebModule.java:550)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:5366)
        at com.sun.enterprise.web.WebModule.start(WebModule.java:498)
        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:917)
        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:901)
        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:733)
        at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:2010)
        at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:1661)
        at com.sun.enterprise.web.WebApplication.start(WebApplication.java:109)
        at org.glassfish.internal.data.EngineRef.start(EngineRef.java:130)
        at org.glassfish.internal.data.ModuleInfo.start(ModuleInfo.java:269)
        at org.glassfish.internal.data.ApplicationInfo.start(ApplicationInfo.java:301)
        at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:462)
        at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:240)
        at org.glassfish.webservices.metroglue.MetroContainer.deployWsTxServices(MetroContainer.java:225)
        at org.glassfish.webservices.metroglue.MetroContainer.deployWsTxServices(MetroContainer.java:174)
        at org.glassfish.webservices.metroglue.MetroContainer.onDeployed(MetroContainer.java:161)
        at org.glassfish.webservices.WebServiceDeploymentNotifierImpl.notifyDeployed(WebServiceDeploymentNotifierImpl.java:66)
        at org.glassfish.webservices.deployment.WebServicesDeploymentMBean.deploy(WebServicesDeploymentMBean.java:302)
        at org.glassfish.webservices.WebServicesDeployer.prepare(WebServicesDeployer.java:189)
        at com.sun.enterprise.v3.server.ApplicationLifecycle.prepareModule(ApplicationLifecycle.java:872)
        at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:410)
        at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:240)
        at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:389)
        at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:353)
        at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:363)
        at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1085)
        at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1200(CommandRunnerImpl.java:95)
        at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1291)
        at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1259)
        at org.glassfish.deployment.admin.ReDeployCommand.execute(ReDeployCommand.java:126)
        at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:348)
        at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:363)
        at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1085)
        at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1200(CommandRunnerImpl.java:95)
        at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1291)
        at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1259)
        at com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:461)
        at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:212)
        at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:179)
        at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:117)
        at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:238)
        at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:833)
        at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:730)
        at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1031)
        at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:228)
        at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
        at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
        at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
        at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
        at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
        at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
        at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
        at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
        at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
        at java.lang.Thread.run(Thread.java:662)
        Caused by: java.lang.ClassNotFoundException: org.eclipse.persistence.sdo.helper.SDOHelperContext not found by org.glassfish.metro.webservices-osgi [6]
        at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:787)
        at org.apache.felix.framework.ModuleImpl.access$400(ModuleImpl.java:71)
        at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1768)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
        ... 78 more

        #]
        Martin Grebac added a comment -

        g! lb eclipselink
        START LEVEL 3
        ID|State |Level|Name
        17|Resolved | 1|EclipseLink ASM (2.3.1.v20111018-r10243)
        62|Resolved | 1|EclipseLink Core (2.3.1.v20111018-r10243)
        66|Resolved | 1|EclipseLink MOXy (2.3.1.v20111018-r10243)
        89|Resolved | 1|EclipseLink JPA (2.3.1.v20111018-r10243)
        131|Resolved | 1|EclipseLink Oracle Extensions (2.3.1.v20111018-r10243)
        144|Installed | 1|Jersey Eclipse MOXy support (1.11.0.b01)
        147|Installed | 1|EclipseLink SDO (2.3.1.v20111018-r10243)
        173|Resolved | 1|EclipseLink ANTLR (2.3.1.v20111018-r10243)
        223|Installed | 1|EclipseLink JPA ModelGen (2.3.1.v20111018-r10243)
        g! start 147
        org.osgi.framework.BundleException: Unresolved constraint in bundle org.eclipse.persistence.sdo [147]: Unable to resolve 147.0: missing requirement [147.0] package; (&(package=commonj.sdo)(version>=2.1.1)) [caused by: Unable to resolve 85.0: missing requirement [85.0] package; (&(package=javax.xml.transform)(version>=1.3.0))]

        Sreekanth added a comment -

        Updating it as blocker issue since we are not able to test SDO Support

        Mitesh Meswani added a comment -

        As Martin pointed out above, the root cause of the issue is a wrong import statement in commonj.sdo.jar This bumdle is owned by EclipseLink. The responsible engineer is working on a fix. Will be integrated into GlassFish as soon as EclipseLink publishes the required fix.

        Mitesh Meswani added a comment -

        $ svn commit -m "Fix for issue 17856. Update to SDO API bundle with corrected import" pom
        .xml
        Sending pom.xml
        Transmitting file data .
        Committed revision 51449.

        Sreekanth added a comment -

        Still as issue.Checked with both promoted and nightly latest builds.Attaching the server log with latest nightly build.

        Mitesh Meswani added a comment -

        The issue seen in latest server.log is same as that in http://java.net/jira/browse/GLASSFISH-18029. Lets track it with 18029. Closing this as duplicate


          People

          • Assignee:
            Mitesh Meswani
            Reporter:
            Sreekanth
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: