glassfish
  1. glassfish
  2. GLASSFISH-17861

Installer doesn't set environment variables correctly on Windows

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1.1_b12
    • Fix Version/s: 3.1.2_b14
    • Component/s: installation
    • Labels:
      None
    • Environment:

      Windows

      Description

      I install the open source product, open a command prompt window, cd to the c:\glassfish3\glassfish\bin directory, type asadmin start-domain, and get the following error message:

      The system cannot find the path specified.

      The same thing happens if I try executing from c:\glassfish3\bin.

      I literally cannot even get started. This does not happen on a SunRay.

      I've been advised to set AS_JAVA to C:\Program Files\Java\jre6 and to add C:\Program Files\Java\jdk1.6.0_25\bin to the PATH. Neither works. But I shouldn't HAVE to set anything.

        Activity

        scatari added a comment -

        How was this installed? Through a executable installer OR an exploded zip file?

        Rebecca Parks added a comment -

        I downloaded the latest-glassfish-windows.exe file, then used the Windows "Run" feature to execute it.

        scatari added a comment -

        The machine does not have a JDK installed and the JRE was used for installer. Custom option does provide a way to choose custom jdk path.

        scatari added a comment -

        Reducing the priority as the installation clearly shows the errors during domain creation because of lack of JDK and the domain can be created after the installation manually.

        Rebecca Parks added a comment -

        I don't think the installation "clearly shows the errors." It does NOT give explicit instructions for a workaround. It does NOT tell the user to set AS_JAVA in the asenv.conf file to C:\Program Files\Java\jre6 and whatever else one must do to get a working server.

        But the installation shouldn't have to give workaround instructions. It should search for a JDK or JRE and set variables accordingly if it finds one. If it doesn't find one, it should point to the JRE that it installs.

        scatari added a comment -

          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            Rebecca Parks
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved: