glassfish
  1. glassfish
  2. GLASSFISH-17877

Native : Deployment of multiple apps fails in Native mode.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 4.0
    • Fix Version/s: None
    • Component/s: service-orchestration
    • Labels:
      None
    • Environment:

      NA

      Description

      Steps to Reproduce
      ====================
      1) Download glassfish 4.0 build 12 and extract.
      2) Follow the steps for Native Mode for creating ims-config-native and create-template and copying the lb.zip etc.
      3) Now deploy any app. Ex: Conference_Planner
      4) Deployment is success and able to access the deployed app through load balancer URL.
      5) Now deploy second app . Ex: basic_db_paas_sample (or) basic_paas_sample .
      6) Deployment fails with the following error :
      emote failure: Error occurred during deployment: Exception while invoking the lifecycle interceptor : Failure while deploying application [ basic_db_paas_sample ], rolled back all operations. Refer root cause – org.glassfish.paas.orchestrator.PaaSDeploymentException: Failure while provisioning services. Please see server.log for more details

      7) If i reverse the order of deployed apps (i.e first basic_db and then conference planner) also the second app deployment fails.

      server.log shows the following exception :
      =============================================
      [#|2011-12-01T13:02:06.671+0530|SEVERE|44.0|javax.enterprise.system.core.com.sun.enterprise.v3.server|_ThreadID=12;_ThreadName=Thread-2;|Failure while deploying application [ basic_db_paas_sample ], rolled back all operations. Refer root cause – org.glassfish.paas.orchestrator.PaaSDeploymentException: Failure while provisioning services
      org.glassfish.deployment.common.DeploymentException: Failure while deploying application [ basic_db_paas_sample ], rolled back all operations. Refer root cause – org.glassfish.paas.orchestrator.PaaSDeploymentException: Failure while provisioning services
      at org.glassfish.paas.orchestrator.state.ProvisioningState.handle(ProvisioningState.java:84)
      at org.glassfish.paas.orchestrator.ServiceOrchestratorImpl.orchestrateTask(ServiceOrchestratorImpl.java:194)
      at org.glassfish.paas.orchestrator.ServiceOrchestratorImpl.provisionServicesForApplication(ServiceOrchestratorImpl.java:253)
      at org.glassfish.paas.orchestrator.ServiceOrchestratorImpl.preDeploy(ServiceOrchestratorImpl.java:502)
      at org.glassfish.paas.orchestrator.ApplicationLifecycleInterceptorImpl$1.run(ApplicationLifecycleInterceptorImpl.java:102)
      at org.glassfish.api.admin.AdminCommandLock.runWithSuspendedLock(AdminCommandLock.java:610)
      at org.glassfish.paas.orchestrator.ApplicationLifecycleInterceptorImpl.before(ApplicationLifecycleInterceptorImpl.java:95)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.notifyLifecycleInterceptorsBefore(ApplicationLifecycle.java:570)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:421)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:249)
      at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:411)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:351)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:366)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1076)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1200(CommandRunnerImpl.java:98)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1309)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1277)
      at com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:479)
      at com.sun.enterprise.v3.admin.AdminAdapter.onMissingResource(AdminAdapter.java:223)
      at org.glassfish.grizzly.http.server.StaticHttpHandler.service(StaticHttpHandler.java:183)
      at com.sun.enterprise.v3.server.HK2Dispatcher.dispatch(HK2Dispatcher.java:113)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:236)
      at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:163)
      at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:161)
      at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:286)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:223)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:155)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:134)
      at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:78)
      at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:829)
      at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:103)
      at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:111)
      at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
      at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:131)
      at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:508)
      at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:488)
      at java.lang.Thread.run(Thread.java:662)

      #]

      =============================================

        Activity

        Hong Zhang added a comment -

        assign to jagadish for initial evaluation

        Tom Mueller added a comment -

        Since cloud support has been removed from Java EE 7, this issue has been closed. This issue can be reopened if desired for future Java EE work.


          People

          • Assignee:
            Jagadish
            Reporter:
            shariffking
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: