Issue Details (XML | Word | Printable)

Key: GLASSFISH-17941
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Byron Nevins
Reporter: easarina
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

ping-node-dcom failed for the updated node.

Created: 08/Dec/11 09:13 PM   Updated: 09/Dec/11 04:43 AM   Resolved: 09/Dec/11 04:04 AM
Component/s: distributed management
Affects Version/s: 3.1.2_b12
Fix Version/s: 3.1.2_b14, 4.0_b14

Time Tracking:
Not Specified

Tags:
Participants: Byron Nevins and easarina


 Description  « Hide

Win 2008 GF build 12. Create one node (node2) using create-node-dcom (did not use --installdir) and created another node, using create-node-config (did not use --installdir) then run update-node-dcom against that config node (node3).

After that executed ping-node-dcom against these nodes. ping-node-dcom was executed successfully against node2, but failed against node3.
========================================================================
C:\export>asadmin --user admin --passwordfile password.txt ping-node-dcom node2
Successfully made DCOM connection to node node2 (bigapp-oblade-1)
Command ping-node-dcom executed successfully.

C:\export>asadmin --user admin --passwordfile password.txt ping-node-dcom node3
remote failure: Failed to validate DCOM connection to node node3 (bigapp-oblade-
1)
Could not connect to host bigapp-oblade-1 using DCOM.
Command ping-node-dcom failed.

===================================================================

I believe the problem happened because node3 did not have the install-dir:
----------------------------------------------------------------------------

<node node-host="bigapp-oblade-1" name="node2" windows-domain="bigapp-oblade-1" type="DCOM" install-dir="${com.sun.aas.productRoot}">
<ssh-connector ssh-port="135">
<ssh-auth password="Ch@ng3m3"></ssh-auth>
</ssh-connector>
</node>
<node node-host="bigapp-oblade-1" name="node3" type="DCOM">
<ssh-connector ssh-port="135">
<ssh-auth password="Ch@ng3m3"></ssh-auth>
</ssh-connector>
</node>
-----------------------------------------------------------------



Byron Nevins added a comment - 09/Dec/11 03:17 AM

This is a feature, not a bug. We prevented you from creating a garbage DCOM node. If the install-dir is not setup correctly then there is zero chance of DCOM working. So we prevent you from doing that. If you insist – then you can use the force option.

In my case I see this:

d:\gf\branches\3.1.2\cluster\admin>asadmin update-node-dcom --nodehost bigapp-oblade-2 -W \pw -w hudson xxx2
remote failure: Warning: some parameters appear to be invalid.
Node not updated. To force an update of the node with these parameters rerun the command using the --force option.
com.sun.enterprise.util.cluster.windows.process.WindowsException: The network name cannot be found.

The installdir is ALWAYS populated – the default is the DAS' install-dir. In my case it is d:\glassfish3 and the remote is on c:\glassfish3.

SAMBA correctly told me that it couldn't find the network name. Drive D is the network name it was looking for.

This is not a valid bug.


easarina added a comment - 09/Dec/11 03:22 AM

I did not see any warning or error messages just created a config node and updated it to dcom node. And then ping doesn't work.


Byron Nevins added a comment - 09/Dec/11 03:28 AM

What commands, exactly, are you running?
Please provide the exact commands.


Byron Nevins added a comment - 09/Dec/11 03:30 AM

You said you saw no error or warning yet you said:

C:\export>asadmin --user admin --passwordfile password.txt ping-node-dcom node3
remote failure: Failed to validate DCOM connection to node node3 (bigapp-oblade-
1)
Could not connect to host bigapp-oblade-1 using DCOM.
Command ping-node-dcom failed.

======
This isn't a error message?!?


easarina added a comment - 09/Dec/11 03:34 AM

C:\export>asadmin start-domain
Waiting for domain1 to start ...........
Successfully started the domain : domain1
domain Location: C:\export\glassfish3\glassfish\domains\domain1
Log File: C:\export\glassfish3\glassfish\domains\domain1\logs\server.log
Admin Port: 4848
Command start-domain executed successfully.

C:\export>asadmin create-node-config node1
Command create-node-config executed successfully.

C:\export>asadmin --passwordfile password1.txt update-node-dcom --nodehost locahost node1
Command update-node-dcom executed successfully.

C:\export>asadmin --passwordfile password1.txt ping-node-dcom node1
remote failure: Failed to validate DCOM connection to node node1 (localhost)
Could not connect to host localhost using DCOM.
Command ping-node-dcom failed.


Byron Nevins added a comment - 09/Dec/11 03:40 AM

I think I see what you mean now. I assumed you didn't give the password for the remote machine like the other bug. We can all save time if you simply give me the exact commands you ran for every bug you file.


Byron Nevins added a comment - 09/Dec/11 04:03 AM

Now I detect the problem:

d:\gf\branches\3.1.2\cluster\admin>asadmin ping-node-dcom node99
remote failure: Failed to validate DCOM connection to node node99 (bigapp-oblade-3)
The configuration for the node is invalid. There is no value for the installdir. Try running update-node-dcom and specify the install directory for
GlassFish.

FIXED!


Byron Nevins added a comment - 09/Dec/11 04:04 AM

d:\gf\branches\3.1.2\cluster>svn commit d:\gf\trunk\main\nucleus\cluster d:\gf\branches\3.1.2\cluster
Sending D:\gf\branches\3.1.2\cluster\admin\src\main\java\com\sun\enterprise\v3\admin\cluster\LocalStrings.properties
Sending D:\gf\branches\3.1.2\cluster\admin\src\main\java\com\sun\enterprise\v3\admin\cluster\NodeUtils.java
Sending D:\gf\trunk\main\nucleus\cluster\admin\src\main\java\com\sun\enterprise\v3\admin\cluster\LocalStrings.properties
Sending D:\gf\trunk\main\nucleus\cluster\admin\src\main\java\com\sun\enterprise\v3\admin\cluster\NodeUtils.java
Transmitting file data ....
Committed revision 51400.