glassfish
  1. glassfish
  2. GLASSFISH-17968

Exceptions in server.log when launching app client application

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Works as designed
    • Affects Version/s: 3.1.2_dev
    • Fix Version/s: None
    • Component/s: standalone_client
    • Labels:
      None
    • Environment:

      ogs-3.1.2-b14-12_08_2011.zip

      Description

      After deploying and launching an app client application, I see the following exceptions in server.log (attached):

      [#|2011-12-09T17:47:30.145-0800|SEVERE|glassfish3.1.2|javax.enterprise.system.co
      ntainer.appclient.org.glassfish.appclient.server.core.jws|_ThreadID=31;_ThreadNa
      me=Thread-2;|Adapter[/___JWSappclient/___system] s1as/javadb/lib/derby.jar
      java.io.IOException: An established connection was aborted by the software in yo
      ur host machine
      at sun.nio.ch.SocketDispatcher.write0(Native Method)
      at sun.nio.ch.SocketDispatcher.write(SocketDispatcher.java:33)
      at sun.nio.ch.IOUtil.writeFromNativeBuffer(IOUtil.java:72)
      at sun.nio.ch.IOUtil.write(IOUtil.java:43)
      at sun.nio.ch.SocketChannelImpl.write(SocketChannelImpl.java:334)
      at com.sun.grizzly.util.OutputWriter.flushChannel(OutputWriter.java:108)
      at com.sun.grizzly.util.OutputWriter.flushChannel(OutputWriter.java:76)
      at com.sun.grizzly.http.SocketChannelOutputBuffer.flushChannel(SocketCha
      nnelOutputBuffer.java:331)
      at com.sun.grizzly.http.SocketChannelOutputBuffer.flushBuffer(SocketChan
      nelOutputBuffer.java:403)
      at com.sun.grizzly.http.SocketChannelOutputBuffer.realWriteBytes(SocketC
      hannelOutputBuffer.java:287)
      at com.sun.grizzly.tcp.http11.InternalOutputBuffer$OutputStreamOutputBuf
      fer.doWrite(InternalOutputBuffer.java:891)
      at com.sun.grizzly.tcp.http11.filters.IdentityOutputFilter.doWrite(Ident
      ityOutputFilter.java:159)
      at com.sun.grizzly.tcp.http11.InternalOutputBuffer.doWrite(InternalOutpu
      tBuffer.java:658)
      at com.sun.grizzly.tcp.Response.doWrite(Response.java:685)
      at com.sun.grizzly.tcp.StaticResourcesAdapter.service(StaticResourcesAda
      pter.java:238)
      at org.glassfish.appclient.server.core.jws.RestrictedContentAdapter.proc
      essContent(RestrictedContentAdapter.java:267)
      at org.glassfish.appclient.server.core.jws.RestrictedContentAdapter.serv
      iceContent(RestrictedContentAdapter.java:227)
      at org.glassfish.appclient.server.core.jws.AppClientHTTPAdapter.service(
      AppClientHTTPAdapter.java:158)
      at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java
      :179)
      at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java
      :117)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(Container
      Mapper.java:238)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:8
      49)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:746)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1045)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFil
      ter.java:228)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultPro
      tocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.jav
      a:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.jav
      a:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java
      :79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextT
      ask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.
      java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadP
      ool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool
      .java:513)
      at java.lang.Thread.run(Thread.java:662)

      #]

      Originally listed wrong exception.

        Activity

        lidiam added a comment -

        Attaching application.

        Tim Quinn added a comment -

        I am taking ownership of this, because from the stack trace Lidia posted it happens during a Java Web Start launch.

        Lidia, is that how you are launching this? Are you launching from the admin console or some other way?

        Does the launch fail? I have seen similar sorts of errors in the past but the application launch works for me. (I think there is some subtle thing in Grizzly exposed by the way Java Web Start on the client requests JAR downloads, but I have never seen this cause the launch to fail. It just creates lots of log output in server.log.)

        Tim Quinn added a comment -

        I am closing this as "works as designed" – not because we want those logging messages but because the Java Web Start launch does succeed despite the logging...at least that's the case in my testing with a very recent 3.1.2 build.

        Please re-open this if the Java Web Start launch of the app client is not actually working.


          People

          • Assignee:
            Tim Quinn
            Reporter:
            lidiam
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: