glassfish
  1. glassfish
  2. GLASSFISH-18075

Solaris 11. Remote commands - failed: /home/hudson/workspace/Cluster/glassfish3/glassfish/lib/nadmin: No such file or directory

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1.2_dev
    • Fix Version/s: None
    • Component/s: admin
    • Labels:
      None

      Description

      Two Solaris 11 machines, jdk 1.6.0_30, 3.1.2 build 15.

      Installed build on both machines. Then executed the follow commands:
      start-domain
      change-admin-password
      enable-secure-admin
      stop-domain
      start-domain

      Then from DAS machine asqe-sblade-1 I've executed such commands:
      asadmin --user admin create-cluster c1
      Enter admin password for user "admin">
      Command create-cluster executed successfully.
      asadmin --user admin create-node-ssh --nodehost asqe-sblade-2 node2
      Enter admin password for user "admin">
      Command create-node-ssh executed successfully.
      asadmin --user admin create-instance --node node2 --cluster c1 in1
      Enter admin password for user "admin">
      Command failed on node node2 (asqe-sblade-2): bash: /home/hudson/workspace/Cluster/glassfish3/glassfish/lib/nadmin: No such file or directory
      Command create-instance completed with warnings.

      hudson@asqe-sblade-1:~/workspace/Cluster/glassfish3/glassfish/bin$ asadmin --user admin create-cluster c2
      Enter admin password for user "admin">
      Command create-cluster executed successfully.

      Then from asqe-sblade-2:

      asadmin --user admin --host asqe-sblade-1 create-local-instance --node node2 --cluster c2 in3
      Enter admin password for user "admin">
      Rendezvoused with DAS on asqe-sblade-1:4848.
      Port Assignments for server instance in3:
      JMX_SYSTEM_CONNECTOR_PORT=28687
      JMS_PROVIDER_PORT=27677
      HTTP_LISTENER_PORT=28081
      ASADMIN_LISTENER_PORT=24849
      JAVA_DEBUGGER_PORT=29010
      IIOP_SSL_LISTENER_PORT=23821
      IIOP_LISTENER_PORT=23701
      OSGI_SHELL_TELNET_PORT=26667
      HTTP_SSL_LISTENER_PORT=28182
      IIOP_SSL_MUTUALAUTH_PORT=23921
      Command create-local-instance executed successfully.

      Again from DAS on asqe-sblade-1:

      asadmin --user admin start-cluster c2
      Enter admin password for user "admin">
      remote failure: in3: Could not start instance in3 on node node2 (asqe-sblade-2).

      Command failed on node node2 (asqe-sblade-2): bash: /home/hudson/workspace/Cluster/glassfish3/glassfish/lib/nadmin: No such file or directory

      To complete this operation run the following command locally on host asqe-sblade-2 from the GlassFish install location /home/hudson/workspace/Cluster/glassfish3:

      lib/nadmin start-local-instance --node node2 --sync normal in3

      The command start-instance failed for: in3
      Command start-cluster failed.

      asadmin --user admin start-instance in3
      Enter admin password for user "admin">
      remote failure: Could not start instance in3 on node node2 (asqe-sblade-2).

      Command failed on node node2 (asqe-sblade-2): bash: /home/hudson/workspace/Cluster/glassfish3/glassfish/lib/nadmin: No such file or directory

      To complete this operation run the following command locally on host asqe-sblade-2 from the GlassFish install location /home/hudson/workspace/Cluster/glassfish3:

      lib/nadmin start-local-instance --node node2 --sync normal in3
      Command start-instance failed.

      ==========================================================================

      So all remote commands: start-instance, start-cluster, create-instance - failed.

        Activity

        Tom Mueller added a comment -

        There was no --installdir option provided to the create-node-ssh command. Was glassfish actually installed in the /home/hudson/workspace/Cluster/glassfish3 directory on asqe-sblade-2?

        If not, then this is the expected behavior.

        easarina added a comment -

        Yes, GF on asqe-sblade-2 and on asqe-sblade-1 was installed at the same location: /home/hudson/workspace/Cluster/glassfish3.

        I saw in /home/hudson/workspace/Cluster/glassfish3/lib/ only asadmin, not nadmin.

        Also I've executed on that machines the regular cli automated test, that I've executed successfully on othe machines against 3.1.2, but here it totally failed, because the remote commands failed.

        Tom Mueller added a comment -

        How was the GlassFish software installed on asqe-sblade-2? Via unzip or an installer? Or via "asadmin install-node"?

        Tom Mueller added a comment -

        Hold the phone. "nadmin" only is referenced by the GlassFish trunk code (4.0). It is not referenced by 3.1.2.
        Is the DAS install on asqe-sblade-1 really 3.1.2?

        easarina added a comment -

        I've unzipped bits on both machines. DAS was on asqe=sblade-1

        hudson@asqe-sblade-1:~/workspace/Cluster/glassfish3/glassfish/bin$ ./asadmin version --verbose
        Version = GlassFish Server Open Source Edition 3.1.2-b15 (build 15), JRE version 1.6.0_30
        Command version executed successfully.
        hudson@asqe-sblade-1:~/workspace/Cluster/glassfish3/glassfish/bin$

        hudson@asqe-sblade-2:~/workspace/Cluster/glassfish3/glassfish/bin$ ./asadmin version --verbose
        Version string could not be obtained from Server [localhost:4848] for some reason.
        (Turn debugging on e.g. by setting AS_DEBUG=true in your environment, to see the details).
        Using locally retrieved version string from version class.
        Version = GlassFish Server Open Source Edition 3.1.2-b15 (build 15)
        asadmin Java Runtime Environment version: 1.6.0_30
        Command version executed successfully.

        This is my first execution against b15, I will run the tests against b15 on other platforms.

        Tom Mueller added a comment -

        Is it possible that the domain was started using just "asadmin" expecting to find the one that you installed, but the PATH was actually pointing to a trunk build?

        easarina added a comment -

        For the automated test I'm using full paths and the test puts my GF bin dir in a path. But for manual executions I did not have anything in a path and I've used ./asadmin from my bin directory.

        And when it can not find a path (bash: /home/hudson/workspace/Cluster/glassfish3/glassfish/lib/nadmin: No such file or directory) it refers to my installation path.

        Tom Mueller added a comment -

        The only way to get a reference to "lib/nadmin" is if you are running trunk code in the DAS.

        Can you please try to recreate this issue, making sure that you use only 3.1.2 software?

        I'm going to resolve this as "Cannot Reproduce" until you are able to reproduce this issue using only 3.1.2 software. Please include the complete sequence of commands, including those that are used to install the software, and where the installation files are downloaded from as well as the command that is used to start the domain.

        If you are able to reproduce it, please reopen the issue.


          People

          • Assignee:
            Tom Mueller
            Reporter:
            easarina
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: