glassfish
  1. glassfish
  2. GLASSFISH-18111

create-ssl fails for protocol admin-listener in default-config or any of copied default-config

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.2_b16
    • Fix Version/s: 4.0_b84_RC1
    • Component/s: admin_gui
    • Labels:
      None

      Description

      Running asadmin command

      ./asadmin create-ssl --type network-listener --target default-config --certname c1 admin-listener

      fails with following error

      remote failure: Network Listener named admin-listener to which this ssl element is being added already has an ssl element.
      Command create-ssl failed.

      Tried to debug createSsl.java found that even though admin-listener protocol does not have any listeners assigned to it, it takes admin-listener listener as the assigned listener for this protocol and it fails. This logic needs to be redesigned.

        Issue Links

          Activity

          Ryan Lubke added a comment -

          Sending nucleus/admin/util/src/main/java/com/sun/enterprise/admin/commands/CreateSsl.java
          Sending nucleus/admin/util/src/main/java/com/sun/enterprise/admin/commands/DeleteSsl.java
          Sending nucleus/admin/util/src/main/java/com/sun/enterprise/admin/commands/LocalStrings.properties
          Adding nucleus/admin/util/src/main/java/com/sun/enterprise/admin/commands/ProtocolSslConfigHandler.java
          Transmitting file data ....
          Committed revision 61181.

          Anissa Lam added a comment -

          With the fix that Ryan committed above, and the fix from Jason for GLASSFISH-20215, console will need to make the change to specify the '--type protocol' to create the SSL based on protocol name.

          • What is the impact on the customer of the bug?
            user cannot go to the protocol page to create/edit SSL element.
          • How likely is it that a customer will see the bug and how serious is the bug? It is likely that they see the bug.
            User will see this if they go to protocol page instead of the Network Listener that reference this protocol to edit the SSL.
          • Is it a regression? Does it meet other bug fix criteria (security, performance, etc.)?
            Not a regression. This bug was not fixed in previous release.
          • What CTS failures are caused by this bug?
            CTS doesn't include console
          • How risky is the fix? How much work is the fix? Is the fix complicated?
            very low risk, add the --type protocol to the payload if it is from the protocol page.
          • Is there an impact on documentation or message strings?
            No.
          • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
            Go to default-config-> Network Config > protocol> admin-listener-1 -> SSL tab and see that the SSL can be created.
          • Which is the targeted build of 4.0 for this fix?
            84
          Tom Mueller added a comment -

          Approved for 4.0

          Anissa Lam added a comment -

          Date: 2013-04-10 05:45:22 UTC
          Link:

          Log Message:
          ------------
          GLASSFISH-18111; add the type for protocol when creating ssl from protocol screen.

          Revisions:
          ----------
          61283

          Modified Paths:
          ---------------
          trunk/main/appserver/admingui/common/src/main/resources/shared/sslPrepare.inc
          trunk/main/appserver/admingui/common/src/main/resources/shared/sslButtons.inc
          trunk/main/appserver/admingui/web/src/main/resources/grizzly/ssl.layout

          Anissa Lam added a comment -

          Additional change made to not create the <ssl> element without user's action.

          Date: 2013-04-10 21:31:05 UTC
          Link:

          Log Message:
          ------------
          GLASSFISH-18111; in addition to adding the --type protocol for creating SSL under protocol, the code now don't automatically create the <ssl> when user just browse to the screen. It will be created only when user press OK button if it doesn't exist yet.
          The cert name field is changed to a required field to match the CLI .

          change request approved, and tested all SSL screens under admin-service, IIOP, Network Listener and Protocol.

          Revisions:
          ----------
          61356

          Modified Paths:
          ---------------
          trunk/main/appserver/admingui/common/src/main/resources/shared/sslPrepare.inc
          trunk/main/appserver/admingui/common/src/main/resources/configuration/jmxSSLEdit.jsf
          trunk/main/appserver/admingui/corba/src/main/resources/sslEdit.jsf
          trunk/main/appserver/admingui/common/src/main/resources/shared/sslAttrs.inc
          trunk/main/appserver/admingui/common/src/main/java/org/glassfish/admingui/common/handlers/UtilHandlers.java
          trunk/main/appserver/admingui/common/src/main/resources/shared/sslButtons.inc
          trunk/main/appserver/admingui/web/src/main/resources/grizzly/ssl.layout


            People

            • Assignee:
              Anissa Lam
              Reporter:
              srinik76
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: