glassfish
  1. glassfish
  2. GLASSFISH-18116

Command stop-domain failed. Unable to shutdown glassfish cleanly

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1.2_b17
    • Fix Version/s: None
    • Component/s: admin
    • Labels:
      None

      Description

      When I say asadmin stop-domain domain1, I see this:

      asadmin stop-domain domain1
      Waiting for the domain to stop ..........................................................
      Timed out (60 seconds) waiting for the domain to stop.
      Command stop-domain failed.
      
      When I check the processes runnning, Glassfish is still running.
      sreekanth@Spidy:/space/Sreekanth/servers/glassfish3/glassfish$ ps -eaf | grep java
      1000     11660     1  8 22:27 pts/0    00:00:15 /space/Sreekanth/java/jdk1.6.0_30/bin/java -cp /space/Sreekanth/servers/glassfish3/glassfish/modules/glassfish.jar -XX:+UnlockDiagnosticVMOptions -XX:MaxPermSize=192m 
      -XX:NewRatio=2 -Xmx512m -client -javaagent:/space/Sreekanth/servers/glassfish3/glassfish/lib/monitor/flashlight-agent.jar -Dosgi.shell.telnet.maxconn=1 -Dfelix.fileinstall.disableConfigSave=false 
      -Djdbc.drivers=org.apache.derby.jdbc.ClientDriver -Dfelix.fileinstall.dir=/space/Sreekanth/servers/glassfish3/glassfish/modules/autostart/ 
      -Djavax.net.ssl.keyStore=/space/Sreekanth/servers/glassfish3/glassfish/domains/domain1/config/keystore.jks 
      -Dosgi.shell.telnet.port=6666 
      -Djava.security.policy=/space/Sreekanth/servers/glassfish3/glassfish/domains/domain1/config/server.policy 
      -Djava.awt.headless=true -Dfelix.fileinstall.log.level=2 -Dfelix.fileinstall.poll=5000 
      -Dcom.sun.aas.instanceRoot=/space/Sreekanth/servers/glassfish3/glassfish/domains/domain1 
      -Dosgi.shell.telnet.ip=127.0.0.1 -Dcom.sun.enterprise.config.config_environment_factory_class=com.sun.enterprise.config.serverbeans.AppserverConfigEnvironmentFactory 
      -Djava.endorsed.dirs=/space/Sreekanth/servers/glassfish3/glassfish/modules/endorsed:/space/Sreekanth/servers/glassfish3/glassfish/lib/endorsed 
      -Dcom.sun.aas.installRoot=/space/Sreekanth/servers/glassfish3/glassfish 
      -Dfelix.fileinstall.bundles.startTransient=true 
      -Djava.ext.dirs=/space/Sreekanth/java/jdk1.6.0_30/lib/ext:/space/Sreekanth/java/jdk1.6.0_30/jre/lib/ext:/space/Sreekanth/servers/glassfish3/glassfish/domains/domain1/lib/ext 
      -Dfelix.fileinstall.bundles.new.start=true 
      -Djavax.net.ssl.trustStore=/space/Sreekanth/servers/glassfish3/glassfish/domains/domain1/config/cacerts.jks -Dcom.sun.enterprise.security.httpsOutboundKeyAlias=s1as 
      -Djava.security.auth.login.config=/space/Sreekanth/servers/glassfish3/glassfish/domains/domain1/config/login.conf 
      -DANTLR_USE_DIRECT_CLASS_LOADING=true -Dgosh.args=--nointeractive 
      -Djava.library.path=/space/Sreekanth/servers/glassfish3/glassfish/lib:/space/Sreekanth/java/jdk1.6.0_30/jre/lib/amd64/server:/space/Sreekanth/java/jdk1.6.0_30/jre/lib/amd64:/space/Sreekanth/java/jdk1.6.0_30/lib/amd64:/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib com.sun.enterprise.glassfish.bootstrap.ASMain -domainname domain1 -asadmin-args 
      --host,,,localhost,,,--port,,,4848,,,--secure=false,,,--terse=false,,,--echo=false,,,--interactive=true,,,start-domain,,,--verbose=false,,,--debug=false,,,--domaindir,,,/space/Sreekanth/servers/glassfish3/glassfish/domains,,,domain1 
      -instancename server -verbose false -debug false 
      -asadmin-classpath /space/Sreekanth/servers/glassfish3/glassfish/modules/admin-cli.jar 
      -asadmin-classname com.sun.enterprise.admin.cli.AsadminMain -upgrade false -type DAS 
      -domaindir /space/Sreekanth/servers/glassfish3/glassfish/domains/domain1 -read-stdin true
      1000     14368 10529  0 22:30 pts/0    00:00:00 grep --color=auto java
      

        Activity

        Tom Mueller added a comment -

        It sounds like you are describing a scenario where the IP address of the host changes while the server is running. I'm not sure that is even a supported scenario.

        Tim Quinn added a comment -

        I have seen this (or a similar) problem when I have created a domain while connected via VPN and therefore the temporarily-assigned VPN host name gets baked into the configuration. If I disconnect from VPN and then start the domain and try to use it I begin to see such problems.

        I do not see how we could change this behavior of GlassFish. I assume the logic which creates the domain gets the hostname from (ultimately) the OS. If that hostname becomes invalid due to changes in the network configuration I don't see that as a problem GlassFish should be expected to solve.

        Having said that, maybe the documentation or release notes could say something about this.

        Sreekanth added a comment -

        I just observed the same behaviour with tomcat server as well when I am connected to Oracle Network through VPN.

        When one of my script tried to shutdown tomcat,it just stopped after this line.
        Jan 20, 2012 10:57:58 PM org.apache.coyote.http11.Http11BaseProtocol pause
        INFO: Pausing Coyote HTTP/1.1 on http-8080

        Is there any code that both Tomcat and Glassfish share commonly?I am using tomcat 5.5.31. Once I disconnect from VPN, everything works fine.

        Tom Mueller added a comment -

        Please provide details regarding the sequence of start/stop vs. network connects.
        For example, what network were you connected to when the server was started.
        What was your network connection when the server stopped?
        How did the IP address of your host change during the lifecycle of the server?

        GF and Tomcat do share some code, however, probably not in the area that is related
        to network connections.

        Sreekanth added a comment -

        For example, what network were you connected to when the server was started.
        > Connected to Oracle VPN
        What was your network connection when the server stopped?
        >Still in Oracle VPN
        How did the IP address of your host change during the lifecycle of the server?
        >No changes.I am always connected to VPN through out the process.

        There were no disconnections from the period I started the server and stopped the server.Everything while I was connected to VPN


          People

          • Assignee:
            Tom Mueller
            Reporter:
            Sreekanth
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: