glassfish
  1. glassfish
  2. GLASSFISH-18125

Cannot access admin console on clean install with no password.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1.1_b12
    • Fix Version/s: 3.1.2_b17
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Windows 7 Professional SP1 x64
      JRE 1.7.0_02-b13
      JDK 1.7.0_02
      GF 3.1.1 b12 from EE SDK installer

      Description

      After install I had to run the asadmin create domain from the command prompt due to the identified problem of AS_JAVA variable pointing to the wrong place. During this I set the admin login as "admin" without a password. The command worked correctly and the server starts without problem.

      When I attempt to browse to the admin gui I get the following in the server.log:

      SEVERE: The log message is null.
      java.lang.RuntimeException: Cannot find annotation org.glassfish.config.support.Create with value _register-instance on method public abstract com.sun.enterprise.config.serverbeans.Server com.sun.enterprise.config.serverbeans.Servers.getServer(java.lang.String)
      ...

      and a host of further errors which are included in the attached log file.

      I am then dropped at the login page for the admin gui, and using "admin" and no password will not allow me to access.

      This is a fresh install after trying and failing to install various other options & packages. Previous versions were uninstalled and the glassfish directory deleted.

        Issue Links

          Activity

          GeoffC added a comment - - edited

          I've moved to JRE6u30 and do not experience this issue.
          Unfortunately not, after a restart this has come back again.

          Anissa Lam added a comment -

          There are a number of issues reported when using jdk7_02. The root cause is fixed by Tom for fixing GLASSFISH-18133.
          Looking at the exception reported, this issues is whats reported in GLASSFISH-18133.

          I am marking this resolved. You can try with 1/8 nightly build or wait for promoted build 17. If you still see the issue with these 2 builds, please reopen.


            People

            • Assignee:
              Anissa Lam
              Reporter:
              GeoffC
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: