glassfish
  1. glassfish
  2. GLASSFISH-18136

Blocking: RuntimeException modifying EJB Timer Service

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1.2_dev
    • Fix Version/s: 3.1.2_dev
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      ogs-3.1.2-b16.zip

      Description

      Saving of EJB Timer Service page causes RuntimeException on the screen. Steps to reproduce:

      1. Create a cluster.
      2. Go to cluster configuration, EJB Container -> EJB Timer Settings.
      3. Hit Save, no need to enter anything, and the RuntimeException is displayed. DAS server.log contains the following:

      [#|2012-01-05T16:52:57.096-0800|WARNING|glassfish3.1.2|javax.enterprise.resource.webcontainer.jsf.lifecycle|_ThreadID=112;_ThreadName=Thread-2;|java.lang.RuntimeException while attempting to process a 'command' event for 'saveButton'.
      java.lang.RuntimeException: java.lang.RuntimeException while attempting to process a 'command' event for 'saveButton'.
      ...
      Caused by: java.lang.ClassCastException: java.lang.String cannot be cast to java.util.Map
      at org.glassfish.admingui.common.util.RestUtil.parseResponse(RestUtil.java:310)

      This is a regression and it is blocking testing of listing ejb timers.

        Issue Links

          Activity

          Anissa Lam added a comment -

          This is dup. of GLASSFISH-18107.

          lidiam added a comment -

          Verified in build ogs-3.1.2-b17.zip.


            People

            • Assignee:
              Anissa Lam
              Reporter:
              lidiam
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: