glassfish
  1. glassfish
  2. GLASSFISH-18151

Unable to user WS-Atomic Transactions on Glass Fish 3.1.1

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1.1
    • Fix Version/s: None
    • Component/s: web_services
    • Labels:
      None
    • Environment:

      Windows

      Description

      While trying to work with WS-Atomic Transactions
      Web Service Invocation was failed with the following error

      INFO: the effective transaction attribute for operation' addRegion' is : enabled(true),required(true), version(WSAT10).
      INFO: WS-AT activityId:[B@1e0c23
      INFO: WSAT4575: WS-AT transaction id is '4D2-313332363035303736343530302D30' and time to live is '899' for transaction 'suspendedTransaction' on thread Thread[http-thread-pool-27623(5),5,grizzly-kernel]
      INFO: WSAT4575: WS-AT transaction id is '4D2-313332363035303736343530302D30' and time to live is '899' for transaction 'suspendedTransaction' on thread Thread[http-thread-pool-27623(5),5,grizzly-kernel]
      INFO: WSAT4568: Client-side outbound application message after adding transaction context for 'suspendedTransaction'
      INFO: WSAT4577: About to suspend transaction 'JavaEETransactionImpl: txId=9 nonXAResource=null jtsTx=null localTxStatus=0 syncs=[]' on thread 'Thread[http-thread-pool-27623(5),5,grizzly-kernel]'
      INFO: WSAT4578: Suspended transaction 'JavaEETransactionImpl: txId=9 nonXAResource=null jtsTx=null localTxStatus=0 syncs=[]' on thread 'Thread[http-thread-pool-27623(5),5,grizzly-kernel]'
      INFO: the effective transaction attribute for operation' addRegion' is : enabled(true),required(true), version(WSAT10).
      INFO: processRequest HeaderList:[com.sun.xml.ws.message.stream.StreamHeader11@fe1155] TransactionalAttribute:com.sun.xml.ws.tx.at.tube.TransactionalAttribute@23e602 isEnabled:true
      INFO: in processingIncomingTransaction builder:com.sun.xml.ws.tx.coord.v10.CoordinationContextBuilderImpl@d1b041
      SEVERE: caught throwable
      java.lang.NoClassDefFoundError: Could not initialize class com.sun.xml.ws.tx.coord.v10.client.RegistrationProxyBuilderImpl
      at com.sun.xml.ws.tx.coord.v10.WSCBuilderFactoryImpl.newRegistrationProxyBuilder(WSCBuilderFactoryImpl.java:56)
      at com.sun.xml.ws.tx.at.tube.WSATServerHelper.register(WSATServerHelper.java:152)
      at com.sun.xml.ws.tx.at.tube.WSATServerHelper.processIncomingTransaction(WSATServerHelper.java:130)
      at com.sun.xml.ws.tx.at.tube.WSATServerHelper.doHandleRequest(WSATServerHelper.java:85)
      at com.sun.xml.ws.tx.at.tube.WSATServerTube.processRequest(WSATServerTube.java:123)
      at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:641)
      at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:600)
      at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:585)
      at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:482)
      at com.sun.xml.ws.server.WSEndpointImpl$2.process(WSEndpointImpl.java:314)
      at com.sun.xml.ws.transport.http.HttpAdapter$HttpToolkit.handle(HttpAdapter.java:608)
      at com.sun.xml.ws.transport.http.HttpAdapter.handle(HttpAdapter.java:259)
      at com.sun.xml.ws.transport.http.servlet.ServletAdapter.invokeAsync(ServletAdapter.java:213)
      at com.sun.xml.ws.transport.http.servlet.WSServletDelegate.doGet(WSServletDelegate.java:159)
      at com.sun.xml.ws.transport.http.servlet.WSServletDelegate.doPost(WSServletDelegate.java:194)
      at com.sun.xml.ws.transport.http.servlet.WSServlet.doPost(WSServlet.java:80)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:754)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
      at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1539)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:281)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:655)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:595)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:98)
      at com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.java:91)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:162)
      at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:330)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:231)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:174)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:828)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:725)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1019)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:662)

      INFO: WSAT4569: Client-side inbound message received
      INFO: WSAT4570: Suspended transaction 'JavaEETransactionImpl: txId=9 nonXAResource=null jtsTx=null localTxStatus=0 syncs=[]' will be resumed on thread 'Thread[http-thread-pool-27623(5),5,grizzly-kernel]'
      INFO: WSAT4571: Suspended transaction 'JavaEETransactionImpl: txId=9 nonXAResource=null jtsTx=null localTxStatus=0 syncs=[]' resumed on thread 'Thread[http-thread-pool-27623(5),5,grizzly-kernel]'
      WARNING: StandardWrapperValve[ResourceServlet]: PWC1406: Servlet.service() for servlet ResourceServlet threw exception
      com.sun.xml.ws.client.ClientTransportException: The server sent HTTP status code 500: Internal Server Error
      at com.sun.xml.ws.transport.http.client.HttpTransportPipe.checkStatusCode(HttpTransportPipe.java:303)
      at com.sun.xml.ws.transport.http.client.HttpTransportPipe.createResponsePacket(HttpTransportPipe.java:260)
      at com.sun.xml.ws.transport.http.client.HttpTransportPipe.process(HttpTransportPipe.java:218)
      at com.sun.xml.ws.transport.http.client.HttpTransportPipe.processRequest(HttpTransportPipe.java:137)
      at com.sun.xml.ws.transport.DeferredTransportPipe.processRequest(DeferredTransportPipe.java:110)
      at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:641)
      at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:600)
      at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:585)
      at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:482)
      at com.sun.xml.ws.api.pipe.helper.AbstractTubeImpl.process(AbstractTubeImpl.java:116)
      at com.sun.enterprise.security.webservices.ClientSecurityPipe.processSecureRequest(ClientSecurityPipe.java:196)
      at com.sun.enterprise.security.webservices.ClientSecurityPipe.process(ClientSecurityPipe.java:184)
      at com.sun.xml.ws.api.pipe.helper.PipeAdapter.processRequest(PipeAdapter.java:119)
      at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:641)
      at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:600)
      at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:585)
      at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:482)
      at com.sun.xml.ws.client.Stub.process(Stub.java:323)
      at com.sun.xml.ws.client.sei.SEIStub.doProcess(SEIStub.java:161)
      at com.sun.xml.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:113)
      at com.sun.xml.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:93)
      at com.sun.xml.ws.client.sei.SEIStub.invoke(SEIStub.java:144)
      at $Proxy210.addRegion(Unknown Source)
      at com.wsw.servlet.ResourceServlet.processRequest(ResourceServlet.java:74)
      at com.wsw.servlet.ResourceServlet.doGet(ResourceServlet.java:180)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:734)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
      at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1539)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:281)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:655)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:595)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:98)
      at com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.java:91)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:162)
      at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:330)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:231)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:174)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:828)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:725)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1019)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:662)

        Activity

        arjavdesai added a comment -

        Narayana,

        I tried again with single setup environment and as had mentioned first time while resolving the issue, it works fine for me with your test service and application. All I had to do was comment the DS operation code and change port for wsdl on client application to default one.

        narayanapadmanabhuni added a comment -

        Hi,

        Sorry to bother you again. I am some how able to get rid of the previous error. But now I am facing the below error could you please help me in resolving this.

        SEVERE: ws.error_next_pipe
        javax.xml.ws.WebServiceException: javax.xml.ws.WebServiceException: Sending fault. Context refused registerResponseType is null (this may be due to request timeout)
        at com.sun.xml.ws.tx.at.tube.WSATServerHelper.processIncomingTransaction(WSATServerHelper.java:138)
        at com.sun.xml.ws.tx.at.tube.WSATServerHelper.doHandleRequest(WSATServerHelper.java:85)
        at com.sun.xml.ws.tx.at.tube.WSATServerTube.processRequest(WSATServerTube.java:123)
        at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:641)
        at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:600)
        at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:585)
        at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:482)
        at com.sun.xml.ws.api.pipe.helper.AbstractTubeImpl.process(AbstractTubeImpl.java:116)
        at com.sun.enterprise.security.webservices.CommonServerSecurityPipe.processRequest(CommonServerSecurityPipe.java:212)
        at com.sun.enterprise.security.webservices.CommonServerSecurityPipe.process(CommonServerSecurityPipe.java:144)
        at com.sun.xml.ws.api.pipe.helper.PipeAdapter.processRequest(PipeAdapter.java:119)
        at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:641)
        at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:600)
        at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:585)
        at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:482)
        at com.sun.xml.ws.server.WSEndpointImpl$2.process(WSEndpointImpl.java:314)
        at com.sun.xml.ws.transport.http.HttpAdapter$HttpToolkit.handle(HttpAdapter.java:608)
        at com.sun.xml.ws.transport.http.HttpAdapter.handle(HttpAdapter.java:259)
        at com.sun.xml.ws.transport.http.servlet.ServletAdapter.handle(ServletAdapter.java:162)
        at org.glassfish.webservices.JAXWSServlet.doPost(JAXWSServlet.java:145)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:754)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
        at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1539)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:281)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
        at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:655)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:595)
        at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:98)
        at com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.java:91)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:162)
        at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:330)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:231)
        at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:174)
        at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:828)
        at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:725)
        at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1019)
        at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
        at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
        at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
        at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
        at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
        at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
        at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
        at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
        at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
        at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
        at java.lang.Thread.run(Thread.java:662)
        Caused by: javax.xml.ws.WebServiceException: Sending fault. Context refused registerResponseType is null (this may be due to request timeout)
        at com.sun.xml.ws.tx.at.tube.WSATServerHelper.register(WSATServerHelper.java:170)
        at com.sun.xml.ws.tx.at.tube.WSATServerHelper.processIncomingTransaction(WSATServerHelper.java:130)
        ... 46 more

        INFO: WSAT4569: Client-side inbound message received
        INFO: WSAT4570: Suspended transaction 'JavaEETransactionImpl: txId=6 nonXAResource=null jtsTx=com.sun.jts.jta.TransactionImpl@b70c0fdf localTxStatus=0 syncs=[]' will be resumed on thread 'Thread[http-thread-pool-8080(2),5,grizzly-kernel]'
        INFO: WSAT4571: Suspended transaction 'JavaEETransactionImpl: txId=6 nonXAResource=null jtsTx=com.sun.jts.jta.TransactionImpl@b70c0fdf localTxStatus=0 syncs=[]' resumed on thread 'Thread[http-thread-pool-8080(2),5,grizzly-kernel]'
        INFO: end
        INFO: rollback
        INFO: end() xid=null, flags=67108864
        INFO: rollback() xid=null
        INFO: rollback() xid=null ignoring primary branch
        INFO: rollback xid:null
        INFO: WSAT4553: Rollback called for Address '<?xml version="1.0" encoding="UTF-8" standalone="yes"?><EndpointReference xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing"><Address>http://Sriman-PC:8080/__wstx-services/ParticipantPortType</Address><ReferenceParameters><wsat-wsat:txId xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">4D2-3444322D333133333332333733363330333233303336333533343333333232443330</wsat-wsat:txId><wsat-wsat:routing xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">none</wsat-wsat:routing></ReferenceParameters></EndpointReference>' and Xid 'null'
        INFO: WSAT4592: About to send abort for durable participant with Xid 'null' on Thread 'Thread[http-thread-pool-8080(2),5,grizzly-kernel]'
        INFO: WSAT4594: Durable participant XAResource placed in cache for Xid 'null' for rollback.
        INFO: WSAT4603: Successfully created participant port 'com.sun.xml.ws.tx.at.v10.client.ParticipantProxyBuilderImpl$ParticipantProxyImpl hashcode:11631489 to(EndpointReference):<?xml version="1.0" encoding="UTF-8" standalone="yes"?><EndpointReference xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing"><Address>http://Sriman-PC:8080/__wstx-services/ParticipantPortType</Address><ReferenceParameters><wsat-wsat:txId xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">4D2-3444322D333133333332333733363330333233303336333533343333333232443330</wsat-wsat:txId><wsat-wsat:routing xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">none</wsat-wsat:routing></ReferenceParameters></EndpointReference> port:Metro/2.1.1-b09 (branches/2.1-6834; 2011-07-16T17:14:48+0000) JAXWS-RI/2.2.5-promoted-b04 JAXWS/2.2: Stub for http://Sriman-PC:8080/__wstx-services/ParticipantPortType' for Xid 'null'
        INFO: WSAT4602: Durable participant port placed in cache for Xid 'null'
        INFO: rollback parameters:com.sun.xml.ws.tx.at.v10.types.Notification@16c7216
        INFO: getWSATTid tid:4D2-313332373630323036353433322D30
        INFO: WSAT4593: Abort sent for durable participant with Xid 'null' on Thread 'Thread[http-thread-pool-8080(2),5,grizzly-kernel]'
        INFO: WSAT4555: Rollback waiting for reply for Address '<?xml version="1.0" encoding="UTF-8" standalone="yes"?><EndpointReference xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing"><Address>http://Sriman-PC:8080/__wstx-services/ParticipantPortType</Address><ReferenceParameters><wsat-wsat:txId xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">4D2-3444322D333133333332333733363330333233303336333533343333333232443330</wsat-wsat:txId><wsat-wsat:routing xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">none</wsat-wsat:routing></ReferenceParameters></EndpointReference>' and Xid 'null'
        INFO: getCoordinatorPortType replytocoordinatorPort:com.sun.xml.ws.tx.at.v10.client.CoordinatorProxyBuilderImpl$CoordinatorProxyImpl@9cb4f4for wsReplyTo/from:<?xml version="1.0" encoding="UTF-8"?><EndpointReference xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing"><Address xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing">http://Sriman-PC:8080/__wstx-services/CoordinatorPortType</Address><ReferenceParameters xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing"><wsat-wsat:txId xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat" xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing">4A5453-07000000F6A9311B5372696D616E2D50432C7365727665722C50313030-5372696D616E2D50432C7365727665722C503130302C01</wsat-wsat:txId><wsat-wsat:branchQual xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat" xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing">Sriman-PC&#044;server&#044;P100&#044;</wsat-wsat:branchQual><wsat-wsat:routing xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat" xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing">none</wsat-wsat:routing></ReferenceParameters></EndpointReference> and replyTo/from:<?xml version="1.0" encoding="UTF-8" standalone="yes"?><EndpointReference xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing"><Address>http://Sriman-PC:8080/__wstx-services/CoordinatorPortType</Address><ReferenceParameters><wsat-wsat:txId xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">4A5453-07000000F6A9311B5372696D616E2D50432C7365727665722C50313030-5372696D616E2D50432C7365727665722C503130302C01</wsat-wsat:txId><wsat-wsat:branchQual xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">Sriman-PC&#044;server&#044;P100&#044;</wsat-wsat:branchQual><wsat-wsat:routing xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">none</wsat-wsat:routing></ReferenceParameters></EndpointReference>
        INFO: getParentReference xid:com.sun.xml.ws.tx.at.internal.XidImpl@3444
        INFO: rollback abortedOperation complete for tid:4D2-313332373630323036353433322D30
        WARNING: GRIZZLY0023: Interrupting idle Thread: http-thread-pool-8080(1).
        INFO: WSAT4556: Rollback finished waiting for reply for Address '<?xml version="1.0" encoding="UTF-8" standalone="yes"?><EndpointReference xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing"><Address>http://Sriman-PC:8080/__wstx-services/ParticipantPortType</Address><ReferenceParameters><wsat-wsat:txId xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">4D2-3444322D333133333332333733363330333233303336333533343333333232443330</wsat-wsat:txId><wsat-wsat:routing xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">none</wsat-wsat:routing></ReferenceParameters></EndpointReference>' and Xid 'null'
        INFO: WSAT4557: Rollback received reply status of 'ACTIVE' for Address '<?xml version="1.0" encoding="UTF-8" standalone="yes"?><EndpointReference xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing"><Address>http://Sriman-PC:8080/__wstx-services/ParticipantPortType</Address><ReferenceParameters><wsat-wsat:txId xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">4D2-3444322D333133333332333733363330333233303336333533343333333232443330</wsat-wsat:txId><wsat-wsat:routing xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">none</wsat-wsat:routing></ReferenceParameters></EndpointReference>' and Xid 'null'
        SEVERE: WSAT4558: Failed state of 'ACTIVE' during WS-AT XAResource rollback for Address '<?xml version="1.0" encoding="UTF-8" standalone="yes"?><EndpointReference xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing"><Address>http://Sriman-PC:8080/__wstx-services/ParticipantPortType</Address><ReferenceParameters><wsat-wsat:txId xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">4D2-3444322D333133333332333733363330333233303336333533343333333232443330</wsat-wsat:txId><wsat-wsat:routing xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">none</wsat-wsat:routing></ReferenceParameters></EndpointReference>' and Xid 'null' . This may be due to a timeout waiting for a response.
        INFO: WSAT4583: Durable participant port removed from cache for Xid 'WSATXAResource: xidnull status:ACTIVE epr:<?xml version="1.0" encoding="UTF-8" standalone="yes"?><EndpointReference xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing"><Address>http://Sriman-PC:8080/__wstx-services/ParticipantPortType</Address><ReferenceParameters><wsat-wsat:txId xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">4D2-3444322D333133333332333733363330333233303336333533343333333232443330</wsat-wsat:txId><wsat-wsat:routing xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">none</wsat-wsat:routing></ReferenceParameters></EndpointReference> isRemovedFromMap:false'
        WARNING: JTS5068: Unexpected error occurred in rollback
        javax.transaction.xa.XAException: Failed state during rollback of WS-AT XAResource:WSATXAResource: xidnull status:ACTIVE epr:<?xml version="1.0" encoding="UTF-8" standalone="yes"?><EndpointReference xmlns="http://schemas.xmlsoap.org/ws/2004/08/addressing"><Address>http://Sriman-PC:8080/__wstx-services/ParticipantPortType</Address><ReferenceParameters><wsat-wsat:txId xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">4D2-3444322D333133333332333733363330333233303336333533343333333232443330</wsat-wsat:txId><wsat-wsat:routing xmlns:ns2="http://schemas.xmlsoap.org/ws/2004/10/wscoor" xmlns:wsat-wsat="http://com.sun.xml.ws.tx.at/ws/2008/10/wsat">none</wsat-wsat:routing></ReferenceParameters></EndpointReference> isRemovedFromMap:false
        at com.sun.xml.ws.tx.at.WSATXAResource.newFailedStateXAExceptionForMethodNameAndErrorcode(WSATXAResource.java:168)
        at com.sun.xml.ws.tx.at.WSATXAResource.rollback(WSATXAResource.java:279)
        at com.sun.xml.ws.tx.at.internal.BranchRecord$RegisteredResource.rollback(BranchRecord.java:493)
        at com.sun.xml.ws.tx.at.internal.BranchRecord.rollback(BranchRecord.java:174)
        at com.sun.xml.ws.tx.at.internal.WSATGatewayRM.rollback(WSATGatewayRM.java:351)

        Thanks in Advance

        arjavdesai added a comment -

        Narayana,

        Sorry for the delay in respone but it works fine for me on default port. I am reopening this as it still didn't work for me on non-default port which was the main issue to start with.

        Arjav

        Joe Di Pol added a comment -

        Too late to consider for 3.1.2. Tagging.

        Sreekanth added a comment -

        Hi ,
        I am unable to reproduce this.I used the same application attached to this issue.Here is what I did.

        1)Downloaded and installed gf3.1.1
        2)Deleted the default domain

         asadmin delete-domain domain1

        3)Created new domain

         asadmin create-domain --user admin --portbase 11000 domain1

        4)Started the domain

        asadmin start-domain domain1

        5)Added a system property to overcome this issue GLASSFISH-14583

        asadmin --port 11048 --user admin --passwordfile password.txt --echo=true create-jvm-options -Dhttp.keepAlive=false

        6)Now restarted the domain

        asadmin stop-domain doamin1

        7)Changed the port number in wsdl reference in client java program and also removed the previously generated client sources.
        8)Now deployed one simple webservice application.This is needed as ws-tx endpoints will be deployed when first endpoints are deployed
        9)Deploy the WebserviceExtensions project from Nb
        10)Clean,build ,deploy and ran the WebservicesExtensionWeb from Nb


          People

          • Assignee:
            arjavdesai
            Reporter:
            narayanapadmanabhuni
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: