glassfish
  1. glassfish
  2. GLASSFISH-18172

Installer failure with JRockit JDK - java.lang.NoClassDefFoundError: org/openinstaller/provider/conf/ConfigControl

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 3.1.2_b17
    • Fix Version/s: None
    • Component/s: installation
    • Labels:
      None
    • Environment:

      Oracle Enterprise Linux 6, JRockit JDK 1.6.0_29, GF 3.1.2 build17. Firefox 3.6.x browser.

      Description

      The following scenario works with SunJDK 1.6.0_30. The problem is only seen with JRockit JDK 1.6.0_29.
      In trying to do a silent install (from a Hudson job) that executes our Smoke test, as
      o machine$ latest-glassfish-unix.sh -s silentInstallFile -s -j $JAVA_HOME

      the following error is displayed:
      Extracting the installer archive...
      Extracting the installer runtime...
      Extracting the installer resources...
      Extracting the installer metadata...

      Welcome to GlassFish installer

      Using the user defined JAVA_HOME : /export/hudson/tools/jr-jdk1.6.0_29
      Entering setup...
      java.lang.NoClassDefFoundError: org/openinstaller/provider/conf/ConfigControl
      at org.openinstaller.core.Orchestrator.main(Orchestrator.java:468)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.openinstaller.core.EngineBootstrap.main(EngineBootstrap.java:208)
      SEVERE INTERNAL ERROR: org/openinstaller/provider/conf/ConfigControl

      I can provide the link to the internal Test Hudson job.

        Issue Links

          Activity

          Alex Pineda added a comment -

          One more thing. This method of installation and scenario worked with GF 3.1.2 build 16.

          scatari added a comment -

          I think this is a dup of a bug that I filed earlier http://java.net/jira/browse/GLASSFISH-18171. Please verify that this doesn't happen on B16.

          Alex Pineda added a comment -

          As commented earlier and before the bug was marked as a dup. The problem was not seen on GF 3.1.2 build16.

          Alex Pineda added a comment -

          Verified fix in build18. Issue is resolved.


            People

            • Assignee:
              scatari
              Reporter:
              Alex Pineda
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: