glassfish
  1. glassfish
  2. GLASSFISH-18191

SDK6u4: Unable to access AdminConsole on clean install with no password using JDK1.7.0_02. Works with JDK1.6.0_30

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1.1_b12
    • Fix Version/s: None
    • Component/s: rest-interface
    • Labels:
      None
    • Environment:

      Windows 7 with 64bit OS. SDK6u4 (GF3.1.1 build12, JDK1.7.0_02 x64bit). Firefox browser 3.6..25. Default install (default ports and no admin password).

      Description

      The following scenario works with JDK1.6.0_30. Reported a similar symptom in GF3.1.2 as issue http://java.net/jira/browse/GLASSFISH-18148. This issue was closed as duplicate of http://java.net/jira/browse/GLASSFISH-18133 which defined the problem as being JDK related in how it determines the targetMethod.

      The issue in GF3.1.1 is seen after installing SDK6u4 (GF3.1.1 build12 with JDK1.7.0_02) and attempting to access the AdminConsole. Specific to http://localhost:4848. The installation is done with all default values (ports and no password), but when attempting to login, the Admin Console username/password login screen is displayed and since no password was set, unable to login. In the server log the following is reported:

      [#|2012-01-13T08:57:21.753-0800|SEVERE|glassfish3.1.1|org.glassfish.admin.rest.g
      enerator.ASMClassWriter|_ThreadID=94;_ThreadName=Thread-2;|The log message is nu
      ll.java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
      at org.glassfish.admin.rest.generator.ASMClassWriter.defineClass(ASMClas
      sWriter.java:471)
      at org.glassfish.admin.rest.generator.ASMClassWriter.done(ASMClassWriter
      .java:294)
      at org.glassfish.admin.rest.generator.ResourcesGeneratorBase.generateCom
      mandResourceClass(ResourcesGeneratorBase.java:357)
      at org.glassfish.admin.rest.generator.ResourcesGeneratorBase.generateCom
      mandResources(ResourcesGeneratorBase.java:301)
      at org.glassfish.admin.rest.generator.ResourcesGeneratorBase.generateSin
      gle(ResourcesGeneratorBase.java:100)
      at org.glassfish.admin.rest.LazyJerseyInit.generateASM(LazyJerseyInit.ja
      va:311)
      at org.glassfish.admin.rest.LazyJerseyInit.getResourcesConfigForManageme
      nt(LazyJerseyInit.java:255)
      at org.glassfish.admin.rest.adapter.RestManagementAdapter.getResourcesCo
      nfig(RestManagementAdapter.java:62)
      at org.glassfish.admin.rest.adapter.RestAdapter.exposeContext(RestAdapte
      r.java:455)
      at org.glassfish.admin.rest.adapter.RestAdapter.service(RestAdapter.java
      :177)
      at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java
      :168)
      at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java
      :117)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(Container
      Mapper.java:238)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:8
      28)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:725)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1019)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFil
      ter.java:225)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultPro
      tocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.jav
      a:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.jav
      a:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java
      :79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextT
      ask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.
      java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadP
      ool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool
      .java:513)
      at java.lang.Thread.run(Thread.java:722)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.GeneratedMethodAccessor19.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:601)
      at org.glassfish.admin.rest.generator.ASMClassWriter.defineClass(ASMClas
      sWriter.java:452)
      ... 26 more
      Caused by: java.lang.LinkageError: loader (instance of org/apache/felix/framewo
      rk/ModuleImpl$ModuleClassLoaderJava5): attempted duplicate class definition for
      name: "org/glassfish/admin/rest/resources/generatedASM/Domain_gmsAnnounceAfterS
      topClusterCommandResource"
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:791)
      ... 30 more

      #]

      [#|2012-01-13T08:57:21.753-0800|SEVERE|glassfish3.1.1|javax.enterprise.system.st
      d.com.sun.enterprise.server.logging|_ThreadID=94;_ThreadName=Thread-2;|java.lang
      .RuntimeException: java.lang.reflect.InvocationTargetException
      at org.glassfish.admin.rest.generator.ASMClassWriter.defineClass(ASMClas
      sWriter.java:471)
      at org.glassfish.admin.rest.generator.ASMClassWriter.done(ASMClassWriter
      .java:294)
      at org.glassfish.admin.rest.generator.ResourcesGeneratorBase.generateCom
      mandResourceClass(ResourcesGeneratorBase.java:357)
      at org.glassfish.admin.rest.generator.ResourcesGeneratorBase.generateCom
      mandResources(ResourcesGeneratorBase.java:301)
      at org.glassfish.admin.rest.generator.ResourcesGeneratorBase.generateSin
      gle(ResourcesGeneratorBase.java:100)
      at org.glassfish.admin.rest.LazyJerseyInit.generateASM(LazyJerseyInit.ja
      va:311)
      at org.glassfish.admin.rest.LazyJerseyInit.getResourcesConfigForManageme
      nt(LazyJerseyInit.java:255)
      at org.glassfish.admin.rest.adapter.RestManagementAdapter.getResourcesCo
      nfig(RestManagementAdapter.java:62)
      at org.glassfish.admin.rest.adapter.RestAdapter.exposeContext(RestAdapte
      r.java:455)
      at org.glassfish.admin.rest.adapter.RestAdapter.service(RestAdapter.java
      :177)
      at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java
      :168)
      at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java
      :117)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(Container
      Mapper.java:238)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:8
      28)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:725)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1019)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFil
      ter.java:225)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultPro
      tocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.jav
      a:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.jav
      a:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java
      :79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextT
      ask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.
      java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadP
      ool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool
      .java:513)
      at java.lang.Thread.run(Thread.java:722)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.GeneratedMethodAccessor19.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:601)
      at org.glassfish.admin.rest.generator.ASMClassWriter.defineClass(ASMClas
      sWriter.java:452)
      ... 26 more
      Caused by: java.lang.LinkageError: loader (instance of org/apache/felix/framewo
      rk/ModuleImpl$ModuleClassLoaderJava5): attempted duplicate class definition for
      name: "org/glassfish/admin/rest/resources/generatedASM/Domain_gmsAnnounceAfterS
      topClusterCommandResource"
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:791)
      ... 30 more

      #]

      Attached is the server log which has the details.

      1. server.log
        824 kB
        Alex Pineda
      2. server.log_2012-01-12T17-58-11
        1.91 MB
        Alex Pineda
      3. server.log_2012-01-13T08-57-21
        1.91 MB
        Alex Pineda

        Activity

        Jason Lee added a comment -

        Sounds good. Thanks.

        Alex Pineda added a comment -

        Please go ahead and close this JIRA issue. I reported it over a year ago and I have not seen this issue in recent SDK6 or SDK7 builds. If I do, I will re-open the bug. Close it for now.

        Jason Lee added a comment -

        Is this issue still a problem? Can this JIRA be closed?

        Jason Lee added a comment - - edited

        Since this issue is no longer seen in 3.1.2, it seems that back-porting the fix for GLASSFISH-18133, which fixed this issue in 3.1.2, may be the appropriate step here. The question, then, is who does that work, the GlassFish team (which would mean Tom, I would guess, as the assignee for 18133) or Sustaining?

        Alex Pineda added a comment -

        Attaching server log from the Windows 2008 system. I can make the system available for debug. Please contact me directly.


          People

          • Assignee:
            Jason Lee
            Reporter:
            Alex Pineda
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: