Issue Details (XML | Word | Printable)

Key: GLASSFISH-18250
Type: Bug Bug
Status: Resolved Resolved
Resolution: Won't Fix
Priority: Minor Minor
Assignee: Anissa Lam
Reporter: lidiam
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

Cannot launch app client application in Chrome

Created: 25/Jan/12 03:01 AM   Updated: 26/Jan/12 01:33 PM   Resolved: 25/Jan/12 06:45 PM
Component/s: admin_gui
Affects Version/s: 3.1.2_b18
Fix Version/s: None

Time Tracking:
Not Specified

File Attachments: 1. JPEG File appclient-error.JPG (113 kB) 25/Jan/12 03:01 AM - lidiam
2. Text File server.log.txt (12 kB) 25/Jan/12 03:01 AM - lidiam
3. Java Archive File showArgsGUI-client.jar (29 kB) 25/Jan/12 03:01 AM - lidiam

Image Attachments:

1. runningOnChrome.png
(18 kB)
Environment:

ogs-3.1.2-b18.zip on OEL 6, Chrome 16.0.912.75 m on windows xp, JDK 1.6.0_30


Tags: 312_qa
Participants: andriy.zhdanov, Anissa Lam and lidiam


 Description  « Hide

When accessing app client application from Google Chrome I get "unable to launch application" error with the following exception on the browser side:

java.io.IOException: Server returned HTTP response code: 502 for URL: http://jed-asqe-41:28080/___JWSappclient/___app/showArgsGUI-client/___dyn/___main.jnlp?arg=hey
at sun.reflect.GeneratedConstructorAccessor1.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection$6.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at sun.net.www.protocol.http.HttpURLConnection.getChainedException(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
at com.sun.deploy.net.BasicHttpRequest.doRequest(Unknown Source)
at com.sun.deploy.net.BasicHttpRequest.doRequest(Unknown Source)
at com.sun.deploy.net.BasicHttpRequest.doGetRequest(Unknown Source)
at com.sun.deploy.net.DownloadEngine.actionDownload(Unknown Source)
at com.sun.deploy.net.DownloadEngine.getCacheEntry(Unknown Source)
at com.sun.deploy.net.DownloadEngine.getCacheEntry(Unknown Source)
at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(Unknown Source)
at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(Unknown Source)
at com.sun.deploy.net.DownloadEngine.getResource(Unknown Source)
at com.sun.deploy.net.DownloadEngine.getResource(Unknown Source)
at com.sun.javaws.Launcher.updateFinalLaunchDesc(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.launch(Unknown Source)
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: Server returned HTTP response code: 502 for URL: http://jed-asqe-41:28080/___JWSappclient/___app/showArgsGUI-client/___dyn/___main.jnlp?arg=hey
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
at java.net.HttpURLConnection.getResponseCode(Unknown Source)
... 18 more

The same application works fine in Firefox 9. I'm attaching server.log from instance where the application was deployed.



Anissa Lam added a comment - 25/Jan/12 07:03 AM

I am using Chrome 14.0.835.202 on Mac, I cannot reproduce the problem.
runs fine for me.
I am downgrading to P4 as this seems to be single user env. related, and submitter also said there is workaround by using other browser.


Anissa Lam added a comment - 25/Jan/12 06:45 PM

Although it works for me on my Mac, this seems to be a known problem in chrome.

http://www.google.com/support/forum/p/Chrome/thread?tid=0e66a911b9807e74&hl=en
The Best answer there says:
"Doesn't look like this is getting fixed. It's been a known bug since April last year. The Chrome browser doesn't appear to detect the Java Webstart mime type. As a CTO I'm now steering people away from using Google Chrome and recommending Firefox."

nothing GUI can do. closing as won't fix.


andriy.zhdanov added a comment - 26/Jan/12 01:33 PM

Just for information, Chrome on Ubuntu has similar issue in my case, http://localhost:8080/showArgsGUI-client?arg=first just downloads jnlp file, but does not launch an application (even though sample http://docs.oracle.com/javase/tutorialJWS/uiswing/painting/ex6/SwingPaintDemo3.jnlp is launched), however http://localhost:8080/___JWSappclient/___app/showArgsGUI-client/___dyn/___main.jnlp?arg=hey works fine.

So in the case, the problem is just that first url does not have .jnlp extension, this is clearly different than reported problem.