glassfish
  1. glassfish
  2. GLASSFISH-18254

"version" command returns Open Source Edition when running Oracle GlassFish Server

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1.2_b19
    • Fix Version/s: 3.1.2_b20
    • Component/s: admin
    • Labels:
      None

      Description

      Installed Orcale GlassFish Server promoted build 19, version returns this is open source edition.

      Here is whats returned
      %asadmin version
      Version = GlassFish Server Open Source Edition 3.1.2-b19 (build 19)
      Command version executed successfully.

      I checked today's nightly (1/25 )build, it also says Open Source Edition.

        Activity

        Joe Di Pol added a comment - - edited

        I just tried B19, and I see it too:

        $ ./asadmin version
        Authentication failed with password from login store: /export/home/dipol/.asadminpass
        Enter admin password for user "admin"> 
        Version = GlassFish Server Open Source Edition 3.1.2-b19 (build 19)
        Command version executed successfully.
        

        If I get the local version it works correctly:

        $ ./asadmin version --local
        Using locally retrieved version string from version class.
        Version = Oracle GlassFish Server 3.1.2 (build 19)
        Command version executed successfully.
        

        And I just verified that both cases work correctly in 3.1.1

        Tom Mueller added a comment - - edited

        This behavior is due to the GlassFishBranding class not being able to find the "BrandingVersion" resource bundle. It does the following:

        vRes = (PropertyResourceBundle) PropertyResourceBundle.getBundle("BrandingVersion");
        

        however, a MissingResourceException is thrown, even though the BrandingVersion.properties file exists within the branding-fragment.jar file that is shipped with OGS.

        The reason that the bundle is not found is a mismatch in the OSGi data between the branding.jar file and the branding-fragment.jar file.

        The branding-fragement.jar file has:

        Fragment-Host: org.glassfish.branding

        but the bundle symbolic name of the branding.jar file has been changed to org.glassfish.main.core.branding in the 3.1.2 release.

        The Fragment-Host (defined in osgi.bundle) has to be changed to match that of branding.jar.

        Tom Mueller added a comment -
        • What is the impact on the customer of the bug?

        How likely is it that a customer will see the bug and how serious is the bug?
        Is it a regression? Does it meet other bug fix criteria (security, performance, etc.)?

        This is a regression. The customer will see the bug if running the version command, and the wrong version will show up in the console.

        • What is the cost/risk of fixing the bug?

        How risky is the fix? How much work is the fix? Is the fix complicated?

        Minimal. Just a change to the osgi.bundle file.

        • Is there an impact on documentation or message strings?

        No.

        • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?

        Just run the version command with the server running.

        • Which is the targeted build of 3.1.2 for this fix?

        20.

        Note: this doesn't have to be fixed in the trunk because the trunk uses a different versioning mechanism that doesn't involve the user of a JAR file.

        Tom Mueller added a comment -

        Fixed on the 3.1.2 branch (value-add) in revision 3657.


          People

          • Assignee:
            Tom Mueller
            Reporter:
            Anissa Lam
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: