glassfish
  1. glassfish
  2. GLASSFISH-18289

Restart of DAS produces NullPointerException in server.log after logging changes

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1.2_b19
    • Fix Version/s: None
    • Component/s: configuration
    • Labels:
      None
    • Environment:

      ogs-3.1.2-b19.zip, DAS on OEL 6 with JRockit 1.6.0_29

      Description

      After making changes to server-config, Logger Settings, the following error message is written to server.log with each DAS restart:

      [#|2012-01-30T14:01:28.271-0800|SEVERE|glassfish3.1.2|null|_ThreadID=48;_ThreadName=Thread-4;|Config Listener notification got interrupted
      java.util.concurrent.ExecutionException: java.lang.NullPointerException
      at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:232)
      at java.util.concurrent.FutureTask.get(FutureTask.java:91)
      at org.jvnet.hk2.config.Transactions$ConfigListenerNotifier$1.call(Transactions.java:290)
      at org.jvnet.hk2.config.Transactions$ConfigListenerNotifier$1.call(Transactions.java:269)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:139)
      at org.jvnet.hk2.config.Transactions$Notifier$1$1.run(Transactions.java:169)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:139)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)

      This exception is printed regardless if restart is done from Admin Console or CLI, however, it seems to be triggered from Admin Console. Steps to reproduce:

      1. Go to server-config, Logger Settings and modify File Rotation Time Limit, to e.g. 30.
      2. Go to server and click Restart button. Note exception printed in server.log.
      3. Consequent restarts of DAS produce the same exception.

      This is not happening if logging changes are done from command line:

      1. Once the exception is no longer printed in server.log use CLI to modify File Rotation Time Limit as follows:

      in1/config# asadmin set-log-attributes --target server com.sun.enterprise.server.logging.GFFileHandler.rotationTimelimitInMinutes=20
      Enter admin password for user "admin">
      com.sun.enterprise.server.logging.GFFileHandler.rotationTimelimitInMinutes logging attribute set with value 20.
      These logging attributes are set for server.
      Command set-log-attributes executed successfully.

      2. Restart DAS from command line and note that the exception is NOT printed to server.log.

      3. Go to Admin Console, verify logging settings and Restart server from there. The exception is again printed to server.log.

      By the way, the exception should not be printed by null logger.

        Activity

        Anissa Lam added a comment -

        I followed the direction and I cannot reproduce on my Mac and on Solaris x86. I have also tried with secure-admin enabled and disabled.
        Can you consistently reproduce this on this machine ? If so, can you try to see if you can reproduce this on another machine ?

        Console called the REST API ":4848management/domain/restart" to perform the restart. Also since the NPE is not from console, I am transferring the bug to configuration for evaluation. I believe thats the component for hk2. If not, please reassign.

        Tom Mueller added a comment -

        I cannot reproduce this either using the latest build (b20). Please try again with b20 and reopen the bug if you still see the issue.

        This problem may be related to issue GLASSFISH-18233 which has been fixed on the trunk but not in 3.1.2.


          People

          • Assignee:
            Tom Mueller
            Reporter:
            lidiam
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: