glassfish
  1. glassfish
  2. GLASSFISH-18291

Unlocalized error message in the create admin-realm user page

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.2_b19
    • Fix Version/s: 3.1.2_b21
    • Component/s: l10n
    • Labels:
      None
    • Environment:

      Server OS: OEL 6 x64 w/JDK 1.6.0_30 64-Bit
      Bundle: ogs-3.1.2-b20_01_29_2012-ml.zip
      Server Locale: ja_JP.UTF-8
      Browser Locale: it_IT

      Description

      There are unlocalized error message in the create admin-realm user page

      To reproduce:
      1. In Admin Console, go to Configuration > Security > Realms > admin-realm > Manage users, and click on New button.
      2. Provide any user ID and keep password filed as empty and then click on OK button.

      There are unlocalized error message said, "The new password for the admin user is empty. This is not allowed when secure-admin is enabled."

      Attached screen shot for your reference.

        Activity

        Hide
        Anissa Lam added a comment -

        Is your server running in English locale ? Those are error msg from the backend, and it will be in the locale that the server is running on.

        Show
        Anissa Lam added a comment - Is your server running in English locale ? Those are error msg from the backend, and it will be in the locale that the server is running on.
        Hide
        sunny-gui added a comment -

        Hi, as I mentioned at Environment, I set server locale as ja_JP.UTF-8 and set browser language as it_IT.

        Show
        sunny-gui added a comment - Hi, as I mentioned at Environment, I set server locale as ja_JP.UTF-8 and set browser language as it_IT.
        Hide
        gmurr added a comment -

        fixed in 3.1.2 b21

        Show
        gmurr added a comment - fixed in 3.1.2 b21
        Hide
        sunny-gui added a comment -

        Verified and fixed in build 21 with the bundle "ogs-3.1.2-b21-unix-ml.sh" in OEL 6 x64 w/JDK1.6.0_30 32-Bit, so close this issue.

        Show
        sunny-gui added a comment - Verified and fixed in build 21 with the bundle "ogs-3.1.2-b21-unix-ml.sh" in OEL 6 x64 w/JDK1.6.0_30 32-Bit, so close this issue.

          People

          • Assignee:
            gmurr
            Reporter:
            sunny-gui
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: