glassfish
  1. glassfish
  2. GLASSFISH-18295

javaee6u4_ri-3.1.2-b20.zip, domain fails to start

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.2_b20
    • Fix Version/s: 3.1.2_b21, 4.0
    • Component/s: OSGi
    • Labels:
      None

      Description

      From the CTS team:

      I downloaded javaee6u4_ri-3.1.2-b20.zip unzipped it and it fails to start.

      # /ri/glassfish3/glassfish/bin/asadmin start-domain
      Waiting for domain1 to start ........Error starting domain domain1.
      The server exited prematurely with exit code 1.
      Before it died, it produced the following output:
      
      Launching GlassFish on Felix platform
      Completed shutdown of GlassFish runtime
      Exception in thread "main" java.lang.reflect.InvocationTargetException
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at 
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
              at 
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:597)
              at 
      com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97)
              at 
      com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55)
      Caused by: com.sun.enterprise.module.ResolveError: Failed to start 
      Bundle Id [212]       State [INSTALLED]       
      [org.glassfish.main.core.logging(Appserver Logging Classes):3.1.2.b20]
              at 
      org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:177)
              at 
      org.jvnet.hk2.osgiadapter.OSGiModuleImpl$2$1$1.loadClass(OSGiModuleImpl.java:344)
              at 
      com.sun.hk2.component.LazyInhabitant.loadClass(LazyInhabitant.java:124)
              at 
      com.sun.hk2.component.LazyInhabitant.fetch(LazyInhabitant.java:111)
              at 
      com.sun.hk2.component.EventPublishingInhabitant.get(EventPublishingInhabitant.java:135)
              at 
      com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:78)
              at 
      com.sun.enterprise.v3.server.AppServerStartup.run(AppServerStartup.java:229)
              at 
      com.sun.enterprise.v3.server.AppServerStartup.doStart(AppServerStartup.java:145)
              at 
      com.sun.enterprise.v3.server.AppServerStartup.start(AppServerStartup.java:136)
              at 
      com.sun.enterprise.glassfish.bootstrap.GlassFishImpl.start(GlassFishImpl.java:79)
              at 
      com.sun.enterprise.glassfish.bootstrap.GlassFishDecorator.start(GlassFishDecorator.java:63)
              at 
      com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishImpl.start(OSGiGlassFishImpl.java:69)
              at 
      com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:117)
              ... 6 more
      Caused by: org.osgi.framework.BundleException: Unresolved constraint in 
      bundle org.glassfish.main.core.logging [212]: Unable to resolve 212.0: 
      missing requirement [212.0] osgi.wiring.package; 
      (&(osgi.wiring.package=com.sun.enterprise.util.cluster.windows.io)(version>=3.1.0))
              at 
      org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
              at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
              at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)
              at 
      org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:169)
              ... 18 more
      
      Command start-domain failed.
      

        Issue Links

          Activity

          Joe Di Pol added a comment -

          I see the same error with the RI bundles from B17, B18, B19 and B20

          The B16 RI bundle seems to work OK

          This looks to be limited to the RI bundles, since I don't see this
          error with the OGS and open source bundles.

          Mahesh Kannan added a comment -

          Looks like the root cause is:

          Caused by: org.osgi.framework.BundleException: Unresolved constraint in
          bundle org.glassfish.main.core.logging [212]: Unable to resolve 212.0:
          missing requirement [212.0] osgi.wiring.package;
          (&(osgi.wiring.package=com.sun.enterprise.util.cluster.windows.io)(version>=3.1.0))
          at
          org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
          at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
          at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)
          at
          org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:169)
          ... 18 more

          Joe Di Pol added a comment -

          That package is in cluster-common.jar. The RI should not require clustering packages. Looks like this dependency was introduced with:

          Project:    glassfish
          Repository: svn
          Revision:   51898
          Author:     naman_mehta
          Date:       2012-01-05 08:12:44 UTC
          Link:       
          
          Log Message:
          ------------
          Fixing issue : http://java.net/jira/browse/GLASSFISH-18055
          Isntannce logs wouldn't able to download from dcom node.
          

          Which has:

          Diffs:
          ------
          Index: branches/3.1.2/core/logging/src/main/java/com/sun/enterprise/server/logging/logviewer/backend/LogFilterForInstance.java
          ===================================================================
          --- branches/3.1.2/core/logging/src/main/java/com/sun/enterprise/server/logging/logviewer/backend/LogFilterForInstance.java	(revision 51897)
          +++ branches/3.1.2/core/logging/src/main/java/com/sun/enterprise/server/logging/logviewer/backend/LogFilterForInstance.java	(revision 51898)
          @@ -45,11 +45,15 @@
           import com.sun.enterprise.config.serverbeans.Nodes;
           import com.sun.enterprise.config.serverbeans.Server;
           import com.sun.enterprise.util.LocalStringManagerImpl;
          +import com.sun.enterprise.util.cluster.windows.io.WindowsRemoteFile;
          +import com.sun.enterprise.util.cluster.windows.io.WindowsRemoteFileSystem;
          +import com.sun.enterprise.util.cluster.windows.process.WindowsException;
           import com.trilead.ssh2.SCPClient;
           import com.trilead.ssh2.SFTPv3DirectoryEntry;
           import com.trilead.ssh2.SFTPv3FileAttributes;
           import org.glassfish.cluster.ssh.launcher.SSHLauncher;
           import org.glassfish.cluster.ssh.sftp.SFTPClient;
          +import org.glassfish.cluster.ssh.util.DcomInfo;
           import org.jvnet.hk2.component.Habitat;
          
          Joe Di Pol added a comment -

          I've confirmed that if I add the following three files to modules then the domain starts. But we don't want to add these to the RI:

          cluster-common.jar
          cluster-ssh.jar
          trilead-ssh2-repackaged.jar

          Assigning bug to Naman to see how we can remove these dependencies.

          naman_mehta added a comment -

          I need those jars to work with dcom node in cluster mode.... As I unbundle RI zip it's not having any cluster jars...

          My question is,
          What is the general approach people are following to split the same? Do I need to split the modules?

          naman_mehta added a comment -

          It's due to dependency on cluster specific jars which are missing in RI bundle.

          • What is the impact on the customer of the bug?
            It's highly impact and visible bug. Server startup is failing on RI.
          • How likely is it that a customer will see the bug and how serious is the bug?
            Every time on server startup. It's not starting the server.
          • Is it a regression? Does it meet other bug fix criteria (security, performance, etc.)?
            Yes.
          • What is the cost/risk of fixing the bug?
            It's not going to impact other functionality as I am just removing dependency of those packages from OSGI.
          • How risky is the fix? How much work is the fix? Is the fix complicated?
            Attached file diff.log for the same.
          • Is there an impact on documentation or message strings?
            No.
          • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
            It's failing to start serve so after the fix server will start smoothly.
          • Which is the targeted build of 3.1.2 for this fix?
            3.1.2 b22
          naman_mehta added a comment -

          Attached file diff for the fix...

          naman_mehta added a comment -

          Project: glassfish
          Repository: svn
          Revision: 52451
          Author: naman_mehta
          Date: 2012-02-06 05:22:40 UTC

          Project: glassfish
          Repository: svn
          Revision: 52450
          Author: naman_mehta
          Date: 2012-02-06 05:15:49 UTC


            People

            • Assignee:
              naman_mehta
              Reporter:
              Joe Di Pol
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: