glassfish
  1. glassfish
  2. GLASSFISH-18298

SDK: Update tool fails to install with b19: downgrade conflict

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1.2_b19
    • Fix Version/s: 3.1.2_b21
    • Component/s: update_center
    • Labels:
      None

      Description

      I'm using Java EE SDK 6 update 4, with GlassFish 3.1.2 b19. This problem happens on both Windows and Solaris.

      I tried to install the update tool today. I had installed without it. This is what happens:

      C:\java_ee_sdk-6u4\bin>updatetool.bat

      The software needed for this command (updatetool) is not installed.

      If you choose to install Update Tool, your system will be automatically
      configured to periodically check for software updates. If you would like
      to configure the tool to not check for updates, you can override the
      default behavior via the tool's Preferences facility.

      When this tool interacts with package repositories, some system information
      such as your system's IP address and operating system type and version
      is sent to the repository server. For more information please see:

      http://wikis.oracle.com/display/updatecenter/UsageMetricsUC2

      Once installation is complete you may re-run this command.

      Would you like to install Update Tool now (y/n): y

      C:\java_ee_sdk-6u4\bin>"C:\jdk1.6.0_29\bin\java" -Dimage.path="C:\java_ee_sdk-6u
      4\bin
      .." -jar "C:\java_ee_sdk-6u4\bin\\..\pkg/lib/pkg-bootstrap.jar" "C:\DOCUM
      E~1\chaase\LOCALS~1\Temp\pkg-bootstrap23124.props"
      Proxy: Using system proxy settings.
      Install image: C:\java_ee_sdk-6u4
      Installing pkg packages.
      Unrecognized exception: Package pkg-toolkit-incorporation contains constraint th
      at requires downgrade of installed pkg pkg://release.javaeesdk.sun.com/pkg-java@
      1.122,0-56.2852:20111207T210529Z: Pkg pkg-java: Optional min_version: 1.122-54 m
      ax_version: 1.122-54 defined by: pkg:/pkg-toolkit-incorporation
      com.sun.pkg.client.Constraint$DowngradeConflict: Package pkg-toolkit-incorporati
      on contains constraint that requires downgrade of installed pkg pkg://release.ja
      vaeesdk.sun.com/pkg-java@1.122,0-56.2852:20111207T210529Z: Pkg pkg-java: Optiona
      l min_version: 1.122-54 max_version: 1.122-54 defined by: pkg:/pkg-toolkit-incor
      poration
      at com.sun.pkg.client.Constraint.checkForWork(Constraint.java:369)
      at com.sun.pkg.client.Image$ImagePlan.evaluateFmri(Image.java:471)
      at com.sun.pkg.client.Image$ImagePlan.evaluate(Image.java:536)
      at com.sun.pkg.client.Image.makeAndEvaluateImagePlan(Image.java:1773)
      at com.sun.pkg.client.Image.makeInstallPlan(Image.java:1751)
      at com.sun.pkg.client.Image.makeInstallPlan(Image.java:1724)
      at com.sun.pkg.client.Image.installPackages(Image.java:1904)
      at com.sun.pkg.bootstrap.Bootstrap._main(Bootstrap.java:244)
      at com.sun.pkg.bootstrap.Bootstrap._main(Bootstrap.java:163)
      at com.sun.pkg.bootstrap.Bootstrap.main(Bootstrap.java:113)

      C:\java_ee_sdk-6u4\bin>

        Activity

        Kim Haase added a comment -

        I don't know if this is relevant, but I notice that although my JAVA_HOME is set to jdk1.7.0_02, and that's what I specified when I installed the SDK, the tool uses my JDK 6 installation.

        Joe Di Pol added a comment - - edited

        This is a problem only with the SDK bundles.

        I'm pretty sure this is caused by missing Update Center packages from the SDK repository.

        If I look in the community stable repository (http://pkg.glassfish.org/v3/stable/catalog/0) it has:

        pkg:/pkg-java@1.122,0-56.2852

        But the SDK release repository does not:

        http://pkg.oracle.com/javaeesdk/6/release/catalog/0

        So I think B56 of UC has not been pushed to the SDK repo.

        Assigning to Jill to take a look at that.

        Jill Sato added a comment -

        Updated sdk repos with latest UC pkgs.


          People

          • Assignee:
            Jill Sato
            Reporter:
            Kim Haase
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: