glassfish
  1. glassfish
  2. GLASSFISH-18301

Error thrown in Console when the clustered instance link is clicked from the configurations page

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 3.1.2_b20
    • Fix Version/s: 3.1.2_b21
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      OS: Solaris 11
      IE9
      GF 3.1.2 b20

      Description

      Create a cluster with 2 instances and start the cluster. From the Configurations Page,In the Configurations Table, click on the clustered instance link in the "Instances" column, The below error is shown in the console:

      Error An error has occurred
      REST Request 'https://localhost:4848/management/domain/clusters/cluster//get-health' failed with response code '404'.

      This is a regression from b10. This error is seen only for clustered instance and not for standalone instances.

      attached screenshots.

        Activity

        Anissa Lam added a comment -

        The cluster instance edit page expects a cluster name to pass it. It should set that if none is passed in, which is the case when getting there from the configuration page.

        Anissa Lam added a comment -

        An easy fix, fixed in trunk.

        Sending clusterInstanceEdit.jsf
        Transmitting file data .
        Committed revision 52391.

        Anissa Lam added a comment -

        Fixed in 3.1.2 branch.
        Revisions:
        ----------
        52404
        Modified Paths:
        ---------------
        branches/3.1.2/admingui/cluster/src/main/resources/cluster/clusterInstanceEdit.jsf

        Remove the regression tag since the page seems come up before, it wasn't working correctly due to missing cluster name.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            shaline
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: