glassfish
  1. glassfish
  2. GLASSFISH-18313

Error when JMS Physical destination Tab is clicked for a remote standalone instance.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.2_b20
    • Fix Version/s: None
    • Component/s: jms
    • Labels:
      None
    • Environment:

      OS: Solaris 11
      IE9
      GF 3.1.2 b20

      Description

      Error is thrown in the console when the JMS Physical destination Tab is clicked for a standalone instance on a remote SSH node. Steps to reproduce:
      --Create a SSH node on a remote machine.
      --Create a std instance on this remote node and start the instance.
      --Select the running instance in the left tree node.
      --In the right window, click on the JMS Physical destination Tab.
      --The below Error is seen in the Console:
      An error has occurred
      Unable to list JMS Destinations. Please ensure that the Message Queue Brokers are running.

      Attached screen shot.

      When we have a cluster with a local instance and a remote instance ( on a remote SSH node), The first time we click on the JMS Physical destinations tab for the running cluster, An Error is thrown in the console as well.
      Steps:
      --create a cluster with 2 instances ( a local instance and a remote instance on a remote SSH node)
      --start the cluster.
      --select the cluster in the left tree,and in the right window click on the JMS physical destination tab.
      The Console launches the popup "A long running process has been detected"..After a while we see the error in the console.

      1. DAS_server.log
        56 kB
        shaline
      2. remote-clu-ins-server.log
        43 kB
        shaline
      3. remote-clustered-ins-imqLog.txt
        3 kB
        shaline
      4. remote-standlone-ins-imqLog.txt
        5 kB
        shaline
      5. remote-std-ins-server.log
        8 kB
        shaline
      1. jms-phy-dest-cluster.png
        69 kB
      2. jms-phy-dest-standalone.png
        63 kB
      3. std-ins-jmsphysical-destinations.jpg
        271 kB

        Activity

        Joe Di Pol added a comment -

        Some feedback from Amy:

        The broker (embedded) failed to start up because unable to create the lock file. "No such file or directory" - possibly the composed directory path (made up from parameters passed to broker) does not exist for the lock file - check parameters passed to broker are correct comparing to the actual location - they are logged at broker startup. The broker lock file should be created at location
        MQ_VARHOME/instances/<broker-name>/lock

        8/Feb/2012:15:38:43 GMT-08:00] ERROR [B3086]: The broker got an exception when trying to acquire the lock file:
        null/instances/cluster1reminsB/lock
        java.io.IOException: No such file or directory
        at java.io.UnixFileSystem.createFileExclusively(Native Method)
        at java.io.File.createNewFile(File.java:883)

        saradak added a comment -

        I am not able to reproduce the issue on my machine. I have created and started the standalone instance on remote node using CLI. JMS destinations listed successfully when I clicked the "JMS Physical Destinations" tab in admin GUI. I used Solaris10 machines and firefox browser.

        saradak added a comment -


        Could you get the broker log files? If you don't see imq directory under <instance> directory, do asadmin jms-ping and collect the broker log files.

        shaline added a comment -

        Attached the broker log files from the remote instances imq dir.

        shaline added a comment -

        I edited the /etc/hosts file of the machine and added the ipaddress to point to the name of the machine and restarted the remote instances. This time the error reported in the bug is not seen when JMS Physical destination Tab is clicked in the Console, and the list jmsdest is working in CLI for the remote instances and lists the jms destinations. So Closing the bug.


          People

          • Assignee:
            David Zhao
            Reporter:
            shaline
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: