glassfish
  1. glassfish
  2. GLASSFISH-18319

validate-local-dcom needs documentation

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1.2_b20, 4.0_b22
    • Fix Version/s: 4.0_b77
    • Component/s: docs
    • Labels:
      None

      Description

      I've added a local asadmin command to the trunk (4.0) that will edit the 2 Windows Registry keys for the user. The idea is to run the command ON THE remote machine itself.

      • It needs a man/help page
      • I print out confirmation text and require the user to type in "yes" before the editing is attempted. Can you help me
        with the text?:

      vld.areyousure=WARNING. This application may need to edit the Windows Registry.\n\
      It is recommended that you backup your registry before running this command.\n\
      \n***** ARE YOU SURE YOU WANT TO EDIT THE REGISTRY? (Type in all three letters of YES)

      =============

      TIME URGENCY - I set it to P2 to make it percolate up your pile. The issue is that this command is going to Update Center so that 3.1.2 users can download and use it.

        Activity

        Paul Davies added a comment -

        For the Update Center add-on component, this issue is fixed:

        $ svn commit -m "Fix for GLASSFISH-18319"
        Adding nucleus/cluster/uc/src/main/resources/org
        Adding nucleus/cluster/uc/src/main/resources/org/glassfish
        Adding nucleus/cluster/uc/src/main/resources/org/glassfish/dcom
        Adding nucleus/cluster/uc/src/main/resources/org/glassfish/dcom/cli
        Adding nucleus/cluster/uc/src/main/resources/org/glassfish/dcom/cli/setup-local-dcom.1
        Transmitting file data .
        Committed revision 52543.

        Still do do: fix for 4.0.

        Mike Fitch added a comment -

        This manpage is present in GlassFish 4.0.


          People

          • Assignee:
            Paul Davies
            Reporter:
            Byron Nevins
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: