glassfish
  1. glassfish
  2. GLASSFISH-18408

mbeanserver module is missing from nucleus.zip

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0
    • Fix Version/s: 4.0_b27
    • Component/s: packaging
    • Labels:
      None

      Description

      The glassfish-mbeanserver.jar file (nucleus/common/mbeanserver module) is missing from the nucleus.zip build that is created from nucleus/distributions/nucleus.

      When I just copy this JAR file into the nucleus module and try to start nucleus, a OSGi load failure is indicated:

      Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.common.glassfish-mbeanserver [90]: Unable to resolve 90.0: missing requirement [90.0] osgi.wiring.package; (osgi.wiring.package=javax.management.remote.jmxmp)

      This indicates some additional dependency problems associated with that JAR file.

      The mbean server should be included in nucleus.

        Activity

        Romain Grécourt added a comment -

        Fixed with revision #52769. This highlighted some issues related to this bug (fixed with rev #52783) .


          People

          • Assignee:
            Romain Grécourt
            Reporter:
            Tom Mueller
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: