glassfish
  1. glassfish
  2. GLASSFISH-18409

cdi interterceptors stop working in ear if there is a lib/jar with a beans.xml

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1, 3.1.1, 3.1.2_b01, 3.1.2_b02, 3.1.2_b03, 3.1.2_b04, 3.1.2_b05, 3.1.2_b06, 3.1.2_b07, 3.1.2_b09, 3.1.2_b10, 3.1.2_b11, 3.1.2_b12, 3.1.2_b13, 3.1.2_b14, 3.1.2_b15, 3.1.2_b16, 3.1.2_b17, 3.1.2_b18, 3.1.2_b19, 3.1.2_b20, 3.1.2_b21, 3.1.2_b22, 3.1.2_b23
    • Fix Version/s: 4.0_b84_RC1
    • Component/s: cdi
    • Labels:
      None
    • Environment:

      all

      Description

      We have an ear project with war and ejb modules. It has a lib directory with all the dependency pojo jars. All in all a very standard setup I think.

      We use CDI Interceptors in our ejb project and everything is fine.

      We have the beans.xml working in our war as well as the ejb project, but as soon as we put a beans.xml in one of our pojo projects (that gets deployed as a jar to the ear's lib directory) the interceptors in the ejb stop working. This should be very easy to reproduce. The beans.xml file in the lib jar does not list any intercptors listed (not even an empty node).

      This is part of the spec right? I should be able to use CDI in the jars in the lib directory, right?

      I tried this on 3.1, 3.1.1, and the latest version of 3.1.2 I have and all have the same behavior.

      I sure hope this can get fixed in time for 3.1.2 – it seems to be a critical issue.

        Activity

        jjsnyder83 added a comment -

        This has been fixed by recent updates of Weld and/or GlassFish.

        TangYong added a comment -

        Although the issue can be re-produced on glassfish 3.1.2.2, on current v4, the issue does not happen.

        -Tang

        tlcksnyder added a comment -

        Please provide a test case, or this will get deferred to a future release.

        Sivakumar Thyagarajan added a comment -

        Transferring to JJ Snyder


          People

          • Assignee:
            jjsnyder83
            Reporter:
            gcruscoe
          • Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: