glassfish
  1. glassfish
  2. GLASSFISH-18485

Chunking not working when using glassfish 3.1.2 with jk-enabled listener

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.1.2
    • Fix Version/s: None
    • Component/s: grizzly-kernel
    • Labels:
      None
    • Environment:

      Debian Squeeze 64Bit
      Apache 2.2.16
      mod_jk 1.2.32 OR mod_proxy_ajp (comes with Apache)

      Description

      I have an issue with a JK-enabled listener which is using the chunking feature. It is related to Bug 18341 where a HTTP downgrade directive disabled the chunking feature on apache side.

      We just upgraded our glassfish server from 3.1.1 to 3.1.2 and the mod_jk configuration stopped working. All requests larger than one chunk are timing out after 15 seconds. The server response is showing a 2000 on the top of the page and a part of the original page.

      workers.properties
      # Glassfish and Java configuration
      workers.tomcat_home=/var/lib/glassfish/glassfish
      workers.java_home=/usr/lib/jvm/java-6-sun/
      ps=/
      worker.list=test,sindb
      # Definition for local worker using AJP 1.3
      worker.test.type=ajp13
      worker.test.host=localhost
      worker.test.port=8010
      worker.sindb.type=ajp13
      worker.sindb.host=localhost
      worker.sindb.port=8009
      
      Apache site config
      [...]
          <IfModule mod_jk.c>
              JkMount / test
              JkMount /* test
          </IfModule>
      [...]
      

      I don't know if it's a real bug or just a misconfiguration, but the fact it worked in 3.1.1 with chunking enabled confused me.

      These scenarios are working:

      • using the 8080 Port of GF without proxy and with chunking
      • using a http proxy (listener has JK disabled) and with chunking
      • using an AJP proxy (mod_proxy_ajp) redirecting to ajp://127.0.0.1:8009 without chunking
      • using the 3.1.1 configuration with mod_jk (see workers.properties) without chunking

      When enabling chunking, the mod_proxy_ajp method just shows an empty page.
      The mod_jk module produces an error indicating that the connection to the enterprise server is broken.

      [Thu Mar 08 12:54:20 2012] [15035:139672345085760] [error] ajp_connection_tcp_get_message::jk_ajp_common.c (1296): wrong message format 0x9293 from 127.0.0.1:8010
      [Thu Mar 08 12:54:20 2012] [15035:139672345085760] [error] ajp_get_reply::jk_ajp_common.c (2148): (test) Tomcat is down or network problems. Part of the response has already been sent to the client
      [Thu Mar 08 12:54:20 2012] [15035:139672345085760] [info] ajp_service::jk_ajp_common.c (2607): (test) sending request to tomcat failed (recoverable), because of protocol error (attempt=1)
      [Thu Mar 08 12:54:21 2012] test test.<DOMAIN> 0.004099
      
      Domain config
      <virtual-server id="test" hosts="#####" network-listeners="http-listener-test"></virtual-server>
      [...]
      <protocol name="http-listener-test">
          <http default-virtual-server="server">
              <file-cache></file-cache>
          </http>
      </protocol>
      [...]
      <network-listener port="8010" protocol="http-listener-test" address="127.0.0.1" transport="tcp" name="http-listener-test" jk-enabled="true" thread-pool="http-thread-pool"></network-listener>
      [...]
      <thread-pool max-thread-pool-size="200" name="http-thread-pool"></thread-pool>
      

      The glassfish log stays empty.

        Activity

        oleksiys added a comment -

        pls. try if patch (2 jar files) from issue
        http://java.net/jira/browse/GLASSFISH-18446

        resolves the problem.
        thx.

        mkinzel added a comment -

        Thanks, the patch fixed the problem.

        oleksiys added a comment -

        duplicate of #18446


          People

          • Assignee:
            oleksiys
            Reporter:
            mkinzel
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: