glassfish
  1. glassfish
  2. GLASSFISH-18538

webservices12 REGRESSIONS IN GFV4.0 NIGHTLY BUILD (29) DATED 03/19/2012

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 4.0_b29
    • Fix Version/s: 4.0_b29
    • Component/s: web_services
    • Labels:
      None

      Description

      The following webservices12 regressions are failing with got exception com.sun.xml.ws.client.ClientTransportException: The server sent HTTP status code 404: Resource Not Found

      These were all PASSING on the nightly build dated 03/16/2012 so these failures just started occurring on Monday 03/19/2012. Below are the list of failures. I will attach the run log and the server log as attachments. The run log contains the stacktraces. Just locate FAIL when editing the file and then scroll up to see the exception.

      FAILED........com/sun/ts/tests/webservices12/deploy/portcomplink/ejb/Client.java#PortCompLinkEjbTest
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/file/shared3/client/Client.java#InvokeMethod_from_wsappclie
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/file/shared3/client/Client.java#InvokeMethod_from_wsejb
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/file/shared3/client/Client.java#InvokeMethod_from_wsservlet
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/file/shared4/client/Client.java#InvokeMethod_from_wsappclie
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/file/shared4/client/Client.java#InvokeMethod_from_wsejb
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/file/shared4/client/Client.java#InvokeMethod_from_wsservlet
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/file/twin3/client/Client.java#InvokeMethod
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/file/twin4/client/Client.java#InvokeMethod
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/http/shared3/client/Client.java#InvokeMethod_from_wsappclie
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/http/shared3/client/Client.java#InvokeMethod_from_wsejb
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/http/shared3/client/Client.java#InvokeMethod_from_wsservlet
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/http/shared4/client/Client.java#InvokeMethod_from_wsappclie
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/http/shared4/client/Client.java#InvokeMethod_from_wsejb
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/http/shared4/client/Client.java#InvokeMethod_from_wsservlet
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/http/twin3/client/Client.java#InvokeMethod
      FAILED........com/sun/ts/tests/webservices12/wsdlImport/http/twin4/client/Client.java#InvokeMethod

      1. runclient_unix.log
        3.13 MB
        alanf760
      2. server.log
        561 kB
        alanf760
      3. server.log_2012-03-20T14-03-53
        1.91 MB
        alanf760

        Issue Links

          Activity

          alanf760 added a comment - - edited

          Most if not all of these failures are related to webservice endpoints the EJB container so I believe it has something to do with changes in the EJB container.

          Lukas Jungmann added a comment -

          the cause is the same as in GF-18534


            People

            • Assignee:
              Lukas Jungmann
              Reporter:
              alanf760
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: