glassfish
  1. glassfish
  2. GLASSFISH-18553

Caught exception: com.sun.xml.messaging.saaj.SOAPExceptionImpl: Unable to read response: Premature EOF

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b30
    • Fix Version/s: 4.0_b30
    • Component/s: web_services
    • Labels:
      None

      Description

      The following SAAJ regression(s) are occuring for the following
      tests due to GlassFish RI issues:

      Test case throws exception: SASendVariousMimeAttachmentsSOAP11Test failed

      • com/sun/ts/tests/saaj/ee/Standalone/Client.java#SASendVariousMimeAttachmentsSOAP11Test_from_servlet : Client_SASendVariousMimeAttachmentsSOAP11Test_from_servlet

      Test case throws exception: SASendVariousMimeAttachmentsSOAP12Test failed

      • com/sun/ts/tests/saaj/ee/Standalone/Client.java#SASendVariousMimeAttachmentsSOAP12Test_from_appclient : Client_SASendVariousMimeAttachmentsSOAP12Test_from_appclient

      Test case throws exception: SendVariousMimeAttachmentsSOAP11Test failed

      • com/sun/ts/tests/saaj/ee/SendVariousMimeAttachments/URLClient.java#SendVariousMimeAttachmentsSOAP11Test : URLClient_SendVariousMimeAttachmentsSOAP11Test

      Test case throws exception: getContent3Test failed

      • com/sun/ts/tests/saaj/api/javax_xml_soap/AttachmentPart/URLClient.java#getContent3Test : URLClient_getContent3Test

      Snippet of client stack trace
      ------------------------------

      [javatest.batch] 03-23-2012 12:44:22: ERROR: Caught exception: com.sun.xml.messaging.saaj.SOAPExceptionImpl: Unable to read respons
      e: Premature EOF
      [javatest.batch] Mar 23, 2012 12:44:22 PM com.sun.xml.messaging.saaj.client.p2p.HttpSOAPConnection post
      [javatest.batch] SEVERE: SAAJ0010: Unable to read response
      [javatest.batch] java.io.IOException: Premature EOF
      [javatest.batch] at sun.net.www.http.ChunkedInputStream.readAheadBlocking(ChunkedInputStream.java:556)
      [javatest.batch] at sun.net.www.http.ChunkedInputStream.readAhead(ChunkedInputStream.java:600)
      [javatest.batch] at sun.net.www.http.ChunkedInputStream.read(ChunkedInputStream.java:687)
      [javatest.batch] at java.io.FilterInputStream.read(FilterInputStream.java:133)
      [javatest.batch] at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:2968)
      [javatest.batch] at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:2962)
      [javatest.batch] at com.sun.xml.messaging.saaj.client.p2p.HttpSOAPConnection.readFully(HttpSOAPConnection.java:559)
      [javatest.batch] at com.sun.xml.messaging.saaj.client.p2p.HttpSOAPConnection.post(HttpSOAPConnection.java:328)
      [javatest.batch] at com.sun.xml.messaging.saaj.client.p2p.HttpSOAPConnection.call(HttpSOAPConnection.java:159)
      [javatest.batch] at com.sun.ts.tests.saaj.ee.Standalone.Client.SASendVariousMimeAttachmentsSOAP11Test(Client.java:253)
      [javatest.batch] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [javatest.batch] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      [javatest.batch] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      [javatest.batch] at java.lang.reflect.Method.invoke(Method.java:601)
      [javatest.batch] at com.sun.ts.lib.harness.EETest.run(EETest.java:495)
      [javatest.batch] at com.sun.ts.lib.harness.ServiceEETest.run(ServiceEETest.java:113)
      [javatest.batch] at com.sun.ts.tests.common.vehicle.EmptyVehicleRunner.run(EmptyVehicleRunner.java:30)
      [javatest.batch] at com.sun.ts.lib.harness.ServiceEETest.run(ServiceEETest.java:102)
      [javatest.batch] at com.sun.ts.lib.harness.EETest.getPropsReady(EETest.java:392)
      .
      .
      .

      Attaching the client and server logs of 1 of the test failures. All the failures seem to be similar in nature. I also attached
      the full runclient log of all the tests failing.

      1. fullrunclient_unix.log
        197 kB
        adf59
      2. runclient_unix.log
        197 kB
        adf59
      3. server.log
        96 kB
        adf59

        Issue Links

          Activity

          adf59 added a comment -

          This issue was first reported happening on GF 4.0 b29. I was using GF 4.0 b30 for testing and logged it against that release.

          Bhakti Mehta added a comment -

          Martin please can you reassign to the right person.

          Martin Grebac added a comment -

          Lukas, is this the grizzly issue you discussed with Alexey lately?

          Lukas Jungmann added a comment -

          no, this is something different. That issue is/was http://java.net/jira/browse/GLASSFISH-18540

          Lukas Jungmann added a comment -

          slightly different issue after checking the fix for GLASSFISH-18540 but the cause is most likely there in Grizzly, so let's wait till it gets fixed in grizzly and re-evaluate after both related issues are fixed

          Lukas Jungmann added a comment -

          fixed in r. 53180 by fix for GLASSFISH-18562


            People

            • Assignee:
              Lukas Jungmann
              Reporter:
              adf59
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: