glassfish
  1. glassfish
  2. GLASSFISH-18554

Exception "This adapter is not 1.5 compliant" when ActiveResourceAdapter is NULL

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Minor Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.1.2
    • Fix Version/s: None
    • Component/s: jca
    • Labels:
      None
    • Environment:

      ubuntu 11.10

      Description

      This error occurs when a resource adapter is still deploying.

      So at line 78 of com.sun.enterprise.connectors.service.ConnectorAdminObjectAdminServiceImpl
      "ActiveResourceAdapter ar = _registry.getActiveResourceAdapter(connectorName)"

      ar is NULL and at line 84 (ar instanceof ActiveOutboundResourceAdapter) is false and throw new ConnectorRuntimeException("This adapter is not 1.5 compliant");

      But this Exception is misleading (I lost a lot of time),it would be better to have something like "No Adapter Found".

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Jagadish
            Reporter:
            sghino
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: