glassfish
  1. glassfish
  2. GLASSFISH-18666

Many warning messages in autodeploy and autoundeploy

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.2, 4.0
    • Fix Version/s: 4.0_b52
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Mac, and likely others os as well

      Description

      in a new install of trunk build, copy hello.war to autodeploy dir, and then rm it. It is deployed and undeployed, but with many warnings.

      [#|2012-04-27T11:31:14.264-0400|INFO|44.0|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=12;_ThreadName=Thread-2;|[AutoDeploy] Selecting file /Users/cf126330/v3/glassfish/domains/domain1/autodeploy/hello.war for autodeployment.|#]

      [#|2012-04-27T11:31:14.553-0400|INFO|44.0|javax.enterprise.system.container.web.com.sun.enterprise.web|_ThreadID=12;_ThreadName=Thread-2;|WEB0671: Loading application [hello] at [/hello]|#]

      [#|2012-04-27T11:31:14.568-0400|INFO|44.0|javax.enterprise.system.tools.admin.org.glassfish.deployment.admin|_ThreadID=12;_ThreadName=Thread-2;|hello was successfully deployed in 275 milliseconds.|#]

      [#|2012-04-27T11:31:14.590-0400|INFO|44.0|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=12;_ThreadName=Thread-2;|[AutoDeploy] Successfully autodeployed : /Users/cf126330/v3/glassfish/domains/domain1/autodeploy/hello.war.|#]

      [#|2012-04-27T11:31:14.591-0400|WARNING|44.0|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=12;_ThreadName=Thread-2;|DPL8033: Attempt to delete file /Users/cf126330/v3/glassfish/domains/domain1/autodeploy/hello.war_deployed failed; no further information.|#]

      [#|2012-04-27T11:31:14.591-0400|WARNING|44.0|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=12;_ThreadName=Thread-2;|DPL8033: Attempt to delete file /Users/cf126330/v3/glassfish/domains/domain1/autodeploy/hello.war_deployFailed failed; no further information.|#]

      [#|2012-04-27T11:31:14.591-0400|WARNING|44.0|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=12;_ThreadName=Thread-2;|DPL8033: Attempt to delete file /Users/cf126330/v3/glassfish/domains/domain1/autodeploy/hello.war_undeployed failed; no further information.|#]

      [#|2012-04-27T11:31:14.591-0400|WARNING|44.0|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=12;_ThreadName=Thread-2;|DPL8033: Attempt to delete file /Users/cf126330/v3/glassfish/domains/domain1/autodeploy/hello.war_undeployFailed failed; no further information.|#]

      [#|2012-04-27T11:31:14.592-0400|WARNING|44.0|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=12;_ThreadName=Thread-2;|DPL8033: Attempt to delete file /Users/cf126330/v3/glassfish/domains/domain1/autodeploy/hello.war_pending failed; no further information.|#]

      [#|2012-04-27T11:40:12.315-0400|INFO|44.0|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=12;_ThreadName=Thread-2;|Autoundeploying application :hello|#]

      [#|2012-04-27T11:40:12.357-0400|INFO|44.0|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=12;_ThreadName=Thread-2;|[AutoDeploy] Successfully autoundeployed : /Users/cf126330/v3/glassfish/domains/domain1/autodeploy/hello.war.|#]

      [#|2012-04-27T11:40:12.358-0400|WARNING|44.0|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=12;_ThreadName=Thread-2;|DPL8033: Attempt to delete file /Users/cf126330/v3/glassfish/domains/domain1/autodeploy/hello.war_deployFailed failed; no further information.|#]

      [#|2012-04-27T11:40:12.358-0400|WARNING|44.0|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=12;_ThreadName=Thread-2;|DPL8033: Attempt to delete file /Users/cf126330/v3/glassfish/domains/domain1/autodeploy/hello.war_undeployed failed; no further information.|#]

      [#|2012-04-27T11:40:12.358-0400|WARNING|44.0|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=12;_ThreadName=Thread-2;|DPL8033: Attempt to delete file /Users/cf126330/v3/glassfish/domains/domain1/autodeploy/hello.war_undeployFailed failed; no further information.|#]

      [#|2012-04-27T11:40:12.358-0400|WARNING|44.0|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=12;_ThreadName=Thread-2;|DPL8033: Attempt to delete file /Users/cf126330/v3/glassfish/domains/domain1/autodeploy/hello.war_pending failed; no further information.|#]

        Activity

        Jeremy_Lv added a comment -

        I have reproduced this phenomenon and I'll look into it in the few days.

        Jeremy_Lv added a comment -

        the related codes are as follows:

        protected void deleteAllMarks(File f) {
                try {
                    for (String suffix : autoDeployFileSuffixes) {
                        final File suffixedFile = getSuffixedFile(f, suffix);
                        if ( ! suffixedFile.delete()) {
                            sLogger.log(Level.WARNING, "enterprise.deployment.deleteFailed",
                                    suffixedFile.getAbsolutePath());
                        }
                    }
                } catch (Exception e) { 
                    //ignore 
                }
            }
        

        The warning messages comes out because of the suffixedFile doesn't exists and the value of suffixedFile.delete() is false.
        Need I change the logical statement about it to prevent the messages print out to the log file?

        Jeremy_Lv added a comment -

        If it is necessary, I think I can check whether the file is exists before the statement "if ( ! suffixedFile.delete())" and then the warning message couldn't print out.

        Jeremy_Lv added a comment -

        Hong,Cheng Fang:
        I have uploaded my fixed source to the JIRA, please review it and give me some advices.
        Thanks.

        Hong Zhang added a comment -

        Jeremy, thanks for looking into this issue, the changes look good to me.

        Jeremy_Lv added a comment -

        fine, I'll run the QL tests and dev tests, if all of them are pass, I'll commit it.

        Jeremy_Lv added a comment -

        All QL tests and dev tests have passed.

        Sending main\nucleus\deployment\autodeploy\src\main\java\org\glassfish\deployment\autodeploy\AutoOperation.java
        Transmitting file data .
        Committed revision 55810.

        Jeremy_Lv added a comment -

        it has been resolved in the version of GF4.0_B52


          People

          • Assignee:
            Hong Zhang
            Reporter:
            Cheng Fang
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: