glassfish
  1. glassfish
  2. GLASSFISH-18670

Not a v4.0.0 POM. for project net.java:jvnet-parent

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Works as designed
    • Affects Version/s: 3.1.2
    • Fix Version/s: None
    • Component/s: build_system
    • Labels:
      None

      Description

      svn co https://svn.java.net/svn/glassfish~svn/tags/3.1.2/
      gfbuild.sh

      [INFO] Scanning for projects...
      [INFO] ------------------------------------------------------------------------
      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Error building POM (may not be this project's POM).

      Project ID: org.glassfish.main:glassfish-parent:pom:3.1.2

      Reason: Cannot find parent: net.java:jvnet-parent for project: org.glassfish.main:glassfish-parent:pom:3.1.2 for project org.glassfish.main:glassfish-parent:pom:3.1.2

      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      org.apache.maven.reactor.MavenExecutionException: Cannot find parent: net.java:jvnet-parent for project: org.glassfish.main:glassfish-parent:pom:3.1.2 for project org.glassfish.main:glassfish-parent:pom:3.1.2
      at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:404)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:272)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
      at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.maven.project.ProjectBuildingException: Cannot find parent: net.java:jvnet-parent for project: org.glassfish.main:glassfish-parent:pom:3.1.2 for project org.glassfish.main:glassfish-parent:pom:3.1.2
      at org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1396)
      at org.apache.maven.project.DefaultMavenProjectBuilder.buildInternal(DefaultMavenProjectBuilder.java:823)
      at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFileInternal(DefaultMavenProjectBuilder.java:508)
      at org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMavenProjectBuilder.java:200)
      at org.apache.maven.DefaultMaven.getProject(DefaultMaven.java:604)
      at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:487)
      at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:391)
      ... 12 more
      Caused by: org.apache.maven.project.InvalidProjectModelException: Not a v4.0.0 POM. for project net.java:jvnet-parent at /home/un/.m2/repository/net/java/jvnet-parent/1/jvnet-parent-1.pom
      at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1599)
      at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1571)
      at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:562)
      at org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1392)
      ... 18 more
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: < 1 second
      [INFO] Finished at: Tue May 01 13:08:12 CEST 2012
      [INFO] Final Memory: 1M/59M
      [INFO] ------------------------------------------------------------------------
      [INFO] Scanning for projects...
      [INFO] ------------------------------------------------------------------------
      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------

      [INFO] Error building POM (may not be this project's POM).

      cat /home/un/.m2/repository/net/java/jvnet-parent/1/jvnet-parent-1.pom
      <html>
      <head><title>301 Moved Permanently</title></head>
      <body bgcolor="white">
      <center><h1>301 Moved Permanently</h1></center>
      <hr><center>nginx/0.6.39</center>
      </body>
      </html>

        Activity

        wbrana added a comment -

        Error was resolved by adding
        <settings>
        <mirrors>
        <mirror>
        <id>maven-central</id>
        <url>http://repo1.maven.org/maven2/</url>
        <mirrorOf>*,!eclipselink.repository</mirrorOf>
        </mirror>
        </mirrors>
        </settings>


          People

          • Assignee:
            Unassigned
            Reporter:
            wbrana
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: