glassfish
  1. glassfish
  2. GLASSFISH-18680

[devtest] request-dispatcher-forward-send-error-commit-response failure

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0_b35
    • Component/s: web_container
    • Labels:
      None

      Description

      [java] GET /web-request-dispatcher-forward-send-error-commit-response/From HTTP/1.0
      [java]
      [java] HTTP/1.1 444 CUSTOM
      [java] Content-Type: text/plain;charset=ISO-8859-1
      [java] X-Powered-By: Servlet/3.0 JSP/2.2 (GlassFish Server Open Source Edition 4.0 Java/Sun Microsystems Inc./1.6)
      [java] Cache-Control: must-revalidate
      [java] Cache-Control: no-store
      [java] Server: GlassFish Server Open Source Edition 4.0
      [java] Accept-Ranges: bytes
      [java] ETag: W/"14-1335915365000"
      [java] Last-Modified: Tue, 01 May 2012 23:36:05 GMT
      [java] Date: Tue, 01 May 2012 23:36:15 GMT
      [java] Connection: close
      [java] Content-Length: 14
      [java]
      [java] MY ERROR PAGE
      [java] java.lang.Exception: Response was delayed by 10 seconds or more, which is how long the origin servlet of the RD.forward() has been sleeping for. The response should have been committed immediately.
      [java] at WebTest.doTest(Unknown Source)
      [java] at WebTest.main(Unknown Source)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [java] at java.lang.reflect.Method.invoke(Method.java:597)
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.run(ExecuteJava.java:217)

      The tests fails due to the fact that the response is not committed immediately.

        Issue Links

          Activity

          Shing Wai Chan added a comment -

          The issue is that Request and RequestFacade are linked together and stored in the pool.
          When the Request#recycle is called, then the reference of RequestFacade in Request is not cleared, but the request attributes are removed. That explains the occasional failure.
          This is a regression due to the fix in GLASSFISH-18637.

          Shing Wai Chan added a comment -

          Sending src/main/java/org/apache/catalina/connector/Request.java
          Transmitting file data .
          Committed revision 53779.


            People

            • Assignee:
              Shing Wai Chan
              Reporter:
              Shing Wai Chan
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: