glassfish
  1. glassfish
  2. GLASSFISH-18683

Failed to start a cluster with injection failed on org.glassfish.virtualization.commands.SupplementalStartInstance.vmLifecycle

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0_b36
    • Component/s: admin
    • Labels:
      None
    • Environment:

      ogs-4.0-b35.zip, REL5, JDK1.6.0_30

      Description

      ogs-4.0-b35.zip, REL5, JDK1.6.0_30
      Failed to start a cluster of 3 local instances.

      start-cluster-common:
      [exec] asadmin --host localhost --port 4848 --user admin --passwordfile /export/hudson/workspace/sherry-lc-dbg/appserver-sqe/build-config/adminpasswordfile.txt --interactive=false --echo=true --terse=false start-cluster --verbose=false sqe-cluster
      [exec] remote failure: clustered_instance_1: injection failed on org.glassfish.virtualization.commands.SupplementalStartInstance.vmLifecycle with org.glassfish.hk2.Factory<org.glassfish.virtualization.runtime.VirtualMachineLifecycle>
      [exec] Command start-cluster failed.
      [exec] clustered_instance_2: injection failed on org.glassfish.virtualization.commands.SupplementalStartInstance.vmLifecycle with org.glassfish.hk2.Factory<org.glassfish.virtualization.runtime.VirtualMachineLifecycle>
      [exec] clustered_instance_3: injection failed on org.glassfish.virtualization.commands.SupplementalStartInstance.vmLifecycle with org.glassfish.hk2.Factory<org.glassfish.virtualization.runtime.VirtualMachineLifecycle>
      [exec]
      [exec] The command start-instance failed for: clustered_instance_1 clustered_instance_2 clustered_instance_3
      [exec] Result: 1

      This setup in sqe core cluster tests worked on b34.

      1. cli.log
        3 kB
        sherryshen
      2. server.log
        31 kB
        sherryshen

        Activity

        sherryshen added a comment -

        cli.log file to create cluster

        sherryshen added a comment -

        das server.log with exception

        Tom Mueller added a comment -

        Joe, isn't this a duplicate of the one you fixed yesterday?

        Joe Di Pol added a comment -

        This was caused by the conversion to JSR-330 injection annotation. Fixed in r53778

        Project:    glassfish
        Repository: svn
        Revision:   53778
        Author:     jfdipol
        Date:       2012-05-02 19:09:20 UTC
        Link:       
        
        Log Message:
        ------------
        Change Factory to Provider for GLASSFISH-18673: Use JSR 330 annotations
        in GlassFish Cloud. Thanks to Mahesh for the tip!
        
        This was causing start-instance and stop-instance to fail after the 
        JSR 330 conversion.
        
        sherryshen added a comment -

        Verified the fix on build35b. Thanks for the fix.


          People

          • Assignee:
            Joe Di Pol
            Reporter:
            sherryshen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: