Issue Details (XML | Word | Printable)

Key: GLASSFISH-18716
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Jason Lee
Reporter: Alex Pineda
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

[Regression] Unable to login to Admin Console

Created: 10/May/12 10:22 PM   Updated: 22/Jun/12 11:07 PM   Resolved: 22/Jun/12 11:07 PM
Component/s: admin_gui
Affects Version/s: 4.0_b36
Fix Version/s: None

Time Tracking:
Not Specified

File Attachments: 1. Text File server.log (50 kB) 10/May/12 10:22 PM - Alex Pineda

Environment:

Oracle Enterprise Linux 5, Firefox browser 11.0, JDK 1.6.0_31, distribution ogs-4.0-b36-unix.sh*, typical default installation, no admin password.


Tags: 40-regression
Participants: Alex Pineda and Jason Lee


 Description  « Hide

After installing GF 4.0 build 36, unable to access the Admin Console on the default port (localhost:4848). In the server.log, the following exception is reported:

[#|2012-05-10T15:16:55.180-0700|SEVERE|44.0|org.glassfish.admin.rest.adapter.RestManagementAdapter|_ThreadID=16;_ThreadName=Thread-2;|java.lang.ClassNotFoundException: org.glassfish.admin.rest.resources.generatedASM.DomainResource not found by org.glassfish.main.admin.rest-service [139]
at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1460)
at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:72)
at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1843)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:169)
at org.glassfish.admin.rest.adapter.RestManagementAdapter.getResourceClasses(RestManagementAdapter.java:84)
at org.glassfish.admin.rest.adapter.RestAdapter.service(RestAdapter.java:175)
at com.sun.enterprise.v3.server.HK2Dispatcher.dispatch(HK2Dispatcher.java:113)
at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:236)
at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:164)
at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:170)
at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:265)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:200)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:134)
at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:112)
at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:78)
at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:815)
at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:112)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:567)
at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:547)
at java.lang.Thread.run(Thread.java:662)

#]

Attaching the whole server.log



Alex Pineda added a comment - 16/May/12 04:12 PM

Adding tag for QA tracking purposes.


Alex Pineda added a comment - 16/May/12 04:28 PM

Just installed GF 4.0 build 37 and I don't see the problem with this build. I'm able to login into the Admin Console without a password. Did something get fixed in the code?


Jason Lee added a comment - 16/May/12 04:34 PM

I had not yet done nothing explicitly to address this issue, so I can't really say for sure. It looks like the root cause was java.lang.ClassNotFoundException: com.oracle.glassfish.virtualization.ovm.commands.CreateOvmVirtualization not found by com.oracle.glassfish.virtualization.ovm. Perhaps something was fixed in that module recently.


Jason Lee added a comment - 21/Jun/12 06:22 PM

I have not been able to reproduce this. Are you still seeing this? If not, I'd like to close the issue.


Alex Pineda added a comment - 22/Jun/12 11:07 PM

The problem is not seen in build 41. It would be great to know what got fixed that caused this problem to go away. Issue is resolved.