glassfish
  1. glassfish
  2. GLASSFISH-18741

3.1.2 Cannot deploy app with Connector(MDB resource adapter) and @Resource annotation

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.2
    • Fix Version/s: 4.0_b39
    • Component/s: deployment
    • Labels:
      None

      Description

      We are experiencing a problem migrating a system with a connector(used as mdb resource adapter) and @Resource annotation from Glassfish 3.0.1 to 3.1.2. While deploying the app we get IllegalStateException caused by NPE. I've included a log of the problem and simple application to replicate the problem.

      1. log.txt
        22 kB
        Boyan Gramatikov
      2. source.tar.gz
        7 kB
        Boyan Gramatikov

        Issue Links

          Activity

          Boyan Gramatikov created issue -
          kumara made changes -
          Field Original Value New Value
          Assignee shreedhar_ganapathy [ shreedhar_ganapathy ] Hong Zhang [ hzhang_jn ]
          Component/s deployment [ 10594 ]
          Hong Zhang made changes -
          Link This issue is related to GLASSFISH-18733 [ GLASSFISH-18733 ]
          Hong Zhang added a comment -

          Thanks for attaching the test application for this! This seems to relate to another recent issue 18733. Will look into this.

          Hong Zhang added a comment -

          I was able to reproduce using the test case and the cause was identified. I have a fix in my local workspace and will check in soon after code review.

          Hong Zhang added a comment -

          Fix checked in (svn 54314).

          Hong Zhang made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 4.0_b39 [ 15628 ]
          Resolution Fixed [ 1 ]
          Boyan Gramatikov added a comment -

          I'm glad you identified and fixed the bug but may we get some kind of patch for gf312 or is there any workaround to use until gf4 is stable?

          alex_yingjun added a comment -

          I have the issue issue as well. Is it possible to back port the fix to 3.1.2?

          Hong Zhang added a comment -

          (Boyan, sorry I missed your earlier comment).

          Boyan/Alex: The 3.1.2 is no longer under active development. I can provide a 3.1.2 patch jar for this and attach to the issue if it helps. One workaround is to use deployment descriptor instead of annotation, but that is probably not desirable.

          Boyan Gramatikov added a comment -

          We would much appreciate a patch jar to solve the issue.

          Hong Zhang added a comment -

          patch jar

          Hong Zhang made changes -
          Attachment dol.jar [ 50448 ]
          Hong Zhang added a comment -

          I have just attached a patch jar (dol.jar) for 3.1.2. You could copy this jar to your $GF_INSTALL/modules, to replace the dol.jar as part of your installation.

          When I tried to provide patch jar in the past for 3.1.2, I was told the version I have does not exactly match their versions, so the safer way to do this would be:
          1. extract the dol.jar patch I attached to the issue.
          2. use the extracted com/sun/enterprise/deployment/ConnectorDescriptor.class to update the dol.jar in your GlassFish installation (this class is the only class that's changed to fix the issue).

          Hong Zhang made changes -
          Link This issue is duplicated by GLASSFISH-18877 [ GLASSFISH-18877 ]

            People

            • Assignee:
              Hong Zhang
              Reporter:
              Boyan Gramatikov
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: