glassfish
  1. glassfish
  2. GLASSFISH-18743

Webservice deploy error message when <port-component-name> is incorrect

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 4.0_b36
    • Fix Version/s: 4.0_b75
    • Component/s: web_services
    • Labels:
      None
    • Environment:

      Windows 7

      Description

      If webservices.xml <port-component-name> and the actual classname are different, the following error message is displayed on deployment. It is difficult for a user to find the cause.

      C:\temp>asadmin deploy wsdltojava-web.war
      remote failure: Error occurred during deployment: Exception while preparing the app : Servlet HelloI
      mpl implements 2 web service endpoints but must only implement 1. Please see server.log for more de
      tails.
      Command deploy failed.

      In this example, port-component-name is Hello, but it should be HelloImpl.
      <port-component-name>Hello</port-component-name>
      If you deploy the attached war file, you will get this error. Then, if you change the port-component-name to HelloPort, deployment will succeed.

        Issue Links

          Activity

          Lukas Jungmann added a comment -

            People

            • Assignee:
              Lukas Jungmann
              Reporter:
              tak09
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: