glassfish
  1. glassfish
  2. GLASSFISH-18770

[regression] DTX5016:Error in XA recovery with NPE in loadXAResourcesAndItsConnections

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0_b39
    • Fix Version/s: 4.0_b40
    • Component/s: configuration
    • Labels:
      None
    • Environment:

      RHL5, JDK1.6.0_30

      Description

      ogs-4.0-b39.zip
      DTX5016:Error in XA recovery was observed on b39.
      Automatic Delegated Recovery w.r.t. an AS instance crash
      tx log in database
      appserver-sqe/pe/transaction/recovery/cliweb5/
      The same test passed on b38.

      In b39, exceptions are shown in instance server log before inserting data to db.
      These exceptions in b39 are not shown in b38.
      server.log files are attached,
      e.g. server_in2_gf4.0_b39.log.
      DTX5016:Error in XA recovery. See logs for more details
      java.lang.NullPointerException
      at com.sun.enterprise.resource.recovery.JdbcRecoveryResourceHandler.loadXAResourcesAndItsConnections(JdbcRecoveryResourceHandler.java:212)

      After tx failures on b39, db lock is not released so that
      other tx tests failed even if they passed at the suite level run.

      1. server_in1_gf4.0_b39.log
        45 kB
        sherryshen
      2. server_in2_gf4.0_b38.log
        52 kB
        sherryshen
      3. server_in2_gf4.0_b39.log
        54 kB
        sherryshen
      4. server_in3_gf4.0_b39.log
        33 kB
        sherryshen

        Activity

        sherryshen created issue -
        sherryshen made changes -
        Field Original Value New Value
        Attachment server_in2_gf4.0_b38.log [ 50243 ]
        sherryshen made changes -
        Attachment server_in2_gf4.0_b39.log [ 50244 ]
        sherryshen made changes -
        Description ogs-4.0-b39.zip
        DTX5016:Error in XA recovery was observed on b39.
        Automatic Delegated Recovery w.r.t. an AS instance crash
        tx log in database
        appserver-sqe/pe/transaction/recovery/cliweb5/
        The same test passed on b38.

        In b39, exceptions are shown in instance server log before inserting data to db.
        These exceptions in b39 are not shown in b38.
        server.log files will be attached.

        After tx failures on b39, db lock is not released so that
        other tx tests failed even if they passed at the suite level run.
        ogs-4.0-b39.zip
        DTX5016:Error in XA recovery was observed on b39.
        Automatic Delegated Recovery w.r.t. an AS instance crash
        tx log in database
        appserver-sqe/pe/transaction/recovery/cliweb5/
        The same test passed on b38.

        In b39, exceptions are shown in instance server log before inserting data to db.
        These exceptions in b39 are not shown in b38.
        server.log files are attached, e.g.
        server_in2_gf4.0_b38.log, server_in2_gf4.0_b39.log.

        After tx failures on b39, db lock is not released so that
        other tx tests failed even if they passed at the suite level run.
        sherryshen made changes -
        Tags 40-regression
        sherryshen made changes -
        Summary DTX5016:Error in XA recovery [regression] DTX5016:Error in XA recovery in tx recovery test
        sherryshen made changes -
        Summary [regression] DTX5016:Error in XA recovery in tx recovery test [regression] DTX5016:Error in XA recovery
        sherryshen made changes -
        Attachment server_in1_gf4.0_b39.log [ 50245 ]
        Attachment server_in3_gf4.0_b39.log [ 50246 ]
        marina vatkina added a comment -

        It looks like the error was introduced by rev 54337 (I don't see the author of the change in the assignees list)

        marina vatkina made changes -
        Assignee marina vatkina [ mvatkina ] Tom Mueller [ tmueller ]
        Component/s configuration [ 10593 ]
        Component/s jts [ 10605 ]
        marina vatkina added a comment -

        The previous rev (54321) will cause the same NPE

        Tom Mueller made changes -
        Assignee Tom Mueller [ tmueller ] Masoud Kalali [ kalali ]
        Masoud Kalali added a comment -

        I am investigating the cause. I am not sure why it didn't show up in the devtests.

        marina vatkina added a comment -

        It is reproducible by devtests/transaction/ee/dblogs/base

        sherryshen added a comment -

        Not sure if other jms failure is related to this zero configuration
        change in rev (54321)
        http://java.net/jira/browse/GLASSFISH-18778
        Both 18770 and 18778 stopped sqe cluster test execution.

        marina vatkina added a comment -

        This issue should be marked as fixed. The fix was checked in yesterday and tx/ee devtests are back to normal.

        sherryshen added a comment -

        Thank Marina for identifying the cause and Masoud Kalali for fixing the issue promptly.
        I verified the fix, i.e. cliweb5 test passed on ogs-4.0-b40-06_01_2012.zip
        #11306 (May 31, 2012 3:09:19 PM)
        54374. Fixing GLASSFISH-18770 — kalali / detail

        sherryshen made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 4.0_b39 [ 15628 ]
        Resolution Fixed [ 1 ]
        sherryshen made changes -
        Fix Version/s 4.0_b40 [ 15629 ]
        Fix Version/s 4.0_b39 [ 15628 ]
        Masoud Kalali added a comment -

        Thank you for closing it. Was too busy and didn't get the chance to update the status after pushing the fix in.

        sb110099 made changes -
        Tags 40-regression 40-regression 3x_regression
        sherryshen made changes -
        Summary [regression] DTX5016:Error in XA recovery [regression] DTX5016:Error in XA recovery with NPE in loadXAResourcesAndItsConnections
        Description ogs-4.0-b39.zip
        DTX5016:Error in XA recovery was observed on b39.
        Automatic Delegated Recovery w.r.t. an AS instance crash
        tx log in database
        appserver-sqe/pe/transaction/recovery/cliweb5/
        The same test passed on b38.

        In b39, exceptions are shown in instance server log before inserting data to db.
        These exceptions in b39 are not shown in b38.
        server.log files are attached, e.g.
        server_in2_gf4.0_b38.log, server_in2_gf4.0_b39.log.

        After tx failures on b39, db lock is not released so that
        other tx tests failed even if they passed at the suite level run.
        ogs-4.0-b39.zip
        DTX5016:Error in XA recovery was observed on b39.
        Automatic Delegated Recovery w.r.t. an AS instance crash
        tx log in database
        appserver-sqe/pe/transaction/recovery/cliweb5/
        The same test passed on b38.

        In b39, exceptions are shown in instance server log before inserting data to db.
        These exceptions in b39 are not shown in b38.
        server.log files are attached,
        e.g. server_in2_gf4.0_b39.log.
        DTX5016:Error in XA recovery. See logs for more details
        java.lang.NullPointerException
        at com.sun.enterprise.resource.recovery.JdbcRecoveryResourceHandler.loadXAResourcesAndItsConnections(JdbcRecoveryResourceHandler.java:212)


        After tx failures on b39, db lock is not released so that
        other tx tests failed even if they passed at the suite level run.

          People

          • Assignee:
            Masoud Kalali
            Reporter:
            sherryshen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: