glassfish
  1. glassfish
  2. GLASSFISH-18827

Exception on app deployment if javassist bundled

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1.2
    • Fix Version/s: 4.1
    • Component/s: cdi
    • Labels:
      None
    • Environment:

      OpenSuse 12.1
      Glassfish 3.1.2 local installation

      Description

      I try to deploy an application, which has a maven dependency to javassist 3.14.0-GA. If I bundle the lib with the application I will get
      Exception while loading the app : org.jboss.weldx.transaction.UserTransaction$1279195191$Proxy$_$$_Weld$Proxy$ cannot be cast to javassist.util.proxy.ProxyObject

      If I set the maven scope to "provided", I will get
      java.lang.NoClassDefFoundError: javassist/bytecode/CodeAttribute$RuntimeCopyException

      The application uses CDI and EclipseLink as persistence provider.
      I have seen, that javassist is already part of the weld-osgi-bundle, but the jar isn't used by the application.

        Activity

        arothe created issue -
        shreedhar_ganapathy made changes -
        Field Original Value New Value
        Assignee shreedhar_ganapathy [ shreedhar_ganapathy ] jjsnyder83 [ jjsnyder83 ]
        Component/s cdi [ 10637 ]
        tlcksnyder made changes -
        Fix Version/s 4.0.1 [ 16061 ]
        arjavdesai added a comment -

        Can you please provide a test app to re-produce the issue? Have tried with latest glass fish? If not, can you please try with one built on 13-apr-13 or later from http://dlc.sun.com.edgesuite.net/glassfish/4.0/nightly/.

        jjsnyder83 made changes -
        Assignee jjsnyder83 [ jjsnyder83 ] phil.zampino [ phil.zampino ]
        arothe added a comment -

        I have checked the old project on SVN. In the sun-web.xml I had an entry

        <class-loader delegate="false"/>

        The error didn't longer occur after removing that line. I'm not sure which influence the line has...

        phil.zampino made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Cannot Reproduce [ 5 ]
        Romain Grécourt made changes -
        Fix Version/s 4.1 [ 16387 ]
        Fix Version/s 4.0.1 [ 16061 ]

          People

          • Assignee:
            phil.zampino
            Reporter:
            arothe
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: