Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0_b42
    • Fix Version/s: None
    • Component/s: admin
    • Labels:
      None

      Description

      I saw this on a build checked out from trunk on svn rev #54820:

      [#|2012-06-27T16:31:37.210+0530|SEVERE|44.0|javax.enterprise.system.std.com.sun.enterprise.server.logging|_ThreadID=10;_ThreadName=main;|java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97)
      at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55)
      Caused by: java.lang.AssertionError
      at org.jvnet.hk2.config.Dom.<init>(Dom.java:253)
      at org.jvnet.hk2.config.ConfigBean.<init>(ConfigBean.java:87)
      at org.glassfish.config.support.GlassFishConfigBean.<init>(GlassFishConfigBean.java:86)
      at com.sun.enterprise.config.util.zeroconfig.SnippetParser$1.make(SnippetParser.java:84)
      at com.sun.enterprise.config.util.zeroconfig.SnippetParser$1.make(SnippetParser.java:81)
      at org.jvnet.hk2.config.ConfigParser.handleElement(ConfigParser.java:192)
      at org.jvnet.hk2.config.ConfigParser.handleElement(ConfigParser.java:167)
      at org.jvnet.hk2.config.ConfigParser.parse(ConfigParser.java:98)
      at com.sun.enterprise.config.util.zeroconfig.SnippetPopulator.run(SnippetPopulator.java:79)
      at com.sun.enterprise.config.util.zeroconfig.SnippetParser.parsConfigBean(SnippetParser.java:91)
      at com.sun.enterprise.config.util.zeroconfig.SnippetLoader.addConfigBeanFor(SnippetLoader.java:88)
      at com.sun.enterprise.config.serverbeans.ConfigSnippetLoader.createConfigBeanForType(ConfigSnippetLoader.java:71)
      at com.sun.enterprise.config.serverbeans.Config$Duck.getExtensionByType(Config.java:479)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.jvnet.hk2.config.Dom.invokeDuckMethod(Dom.java:964)
      at org.jvnet.hk2.config.Dom.invoke(Dom.java:914)
      at org.glassfish.config.support.TranslatedConfigView.invoke(TranslatedConfigView.java:131)
      at $Proxy31.getExtensionByType(Unknown Source)
      at com.sun.enterprise.connectors.jms.system.JmsProviderLifecycle.postConstruct(JmsProviderLifecycle.java:102)
      at com.sun.hk2.component.AbstractCreatorImpl.inject(AbstractCreatorImpl.java:132)
      at com.sun.hk2.component.ConstructorCreator.initialize(ConstructorCreator.java:117)
      at com.sun.hk2.component.AbstractCreatorImpl.get(AbstractCreatorImpl.java:84)
      at com.sun.hk2.component.SingletonInhabitant.get(SingletonInhabitant.java:67)
      at com.sun.hk2.component.EventPublishingInhabitant.get(EventPublishingInhabitant.java:141)
      at com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:135)
      at com.sun.enterprise.v3.server.RunLevelBridge.activate(RunLevelBridge.java:170)
      at com.sun.enterprise.v3.server.RunLevelBridge.postConstruct(RunLevelBridge.java:110)
      at com.sun.enterprise.v3.server.PostStartupRunLevelBridge.postConstruct(PostStartupRunLevelBridge.java:57)
      at com.sun.hk2.component.AbstractCreatorImpl.inject(AbstractCreatorImpl.java:132)
      at com.sun.hk2.component.ConstructorCreator.initialize(ConstructorCreator.java:117)
      at com.sun.hk2.component.AbstractCreatorImpl.get(AbstractCreatorImpl.java:84)
      at com.sun.hk2.component.SingletonInhabitant.get(SingletonInhabitant.java:67)
      at com.sun.hk2.component.EventPublishingInhabitant.get(EventPublishingInhabitant.java:141)
      at com.sun.hk2.component.EventPublishingInhabitant.get(EventPublishingInhabitant.java:141)
      at com.sun.hk2.component.RunLevelInhabitant.get(RunLevelInhabitant.java:110)
      at com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:135)
      at com.sun.enterprise.v3.server.AppServerStartup$AppServerInhabitantActivator.activate(AppServerStartup.java:398)
      at org.jvnet.hk2.component.internal.runlevel.DefaultRunLevelService$Worker.activateRunLevel(DefaultRunLevelService.java:1106)
      at org.jvnet.hk2.component.internal.runlevel.DefaultRunLevelService$Worker.upActiveRecorder(DefaultRunLevelService.java:1060)
      at org.jvnet.hk2.component.internal.runlevel.DefaultRunLevelService$Worker.run(DefaultRunLevelService.java:1026)
      at org.jvnet.hk2.component.internal.runlevel.DefaultRunLevelService$SyncProceedToOp.proceedTo(DefaultRunLevelService.java:1256)
      at org.jvnet.hk2.component.internal.runlevel.DefaultRunLevelService.proceedTo(DefaultRunLevelService.java:797)
      at org.jvnet.hk2.component.internal.runlevel.DefaultRunLevelService.proceedTo(DefaultRunLevelService.java:759)
      at com.sun.enterprise.v3.server.AppServerStartup.proceedTo(AppServerStartup.java:360)
      at com.sun.enterprise.v3.server.AppServerStartup.run(AppServerStartup.java:255)
      at com.sun.enterprise.v3.server.AppServerStartup.doStart(AppServerStartup.java:172)
      at com.sun.enterprise.v3.server.AppServerStartup.start(AppServerStartup.java:163)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishImpl.start(GlassFishImpl.java:79)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishDecorator.start(GlassFishDecorator.java:63)
      at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishImpl.start(OSGiGlassFishImpl.java:71)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:117)
      ... 6 more

      #]

      I have not been able to reproduce it.

        Activity

        Tom Mueller added a comment -

        Since this issue was filed, there have been many changes to HK2 (line 253 in Dom.java isn't even an executable line anymore).

        Resolving this as cannot reproduce since this problem is not showing up anymore.


          People

          • Assignee:
            Tom Mueller
            Reporter:
            Sanjeeb Sahoo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: