glassfish
  1. glassfish
  2. GLASSFISH-18877

java.lang.NullPointerException at com.sun.enterprise.deployment.ConnectorDescriptor.getConnectionDefinitionByCFType(ConnectorDescriptor.java:647)

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: 3.1.2_b23
    • Fix Version/s: None
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Win7 Pro SP1 64 Bit JDK 1.6.0_26

      Description

      After uninstalling GFv3.1.1 and then installing GFv3.1.2 I am no more able to deploy my EAR. "asadmin deploy" of GFv3.1.2 tells me this:

      Caused by: java.lang.NullPointerException
      at com.sun.enterprise.deployment.ConnectorDescriptor.getConnectionDefinitionByCFType(ConnectorDescriptor.java:647)
      at com.sun.enterprise.deployment.ConnectorDescriptor.getConnectionDefinitionByCFType(ConnectorDescriptor.java:634)
      at com.sun.enterprise.deployment.util.DOLUtils.isRAConnectionFactory(DOLUtils.java:170)
      at com.sun.enterprise.deployment.util.DOLUtils.isRAConnectionFactory(DOLUtils.java:145)
      at com.sun.enterprise.deployment.annotation.handlers.ResourceHandler.getDescriptors(ResourceHandler.java:315)
      at com.sun.enterprise.deployment.annotation.handlers.ResourceHandler.processResource(ResourceHandler.java:229)
      at com.sun.enterprise.deployment.annotation.handlers.ResourceHandler.processAnnotation(ResourceHandler.java:148)
      at com.sun.enterprise.deployment.annotation.handlers.AbstractResourceHandler.processAnnotation(AbstractResourceHandler.java:142)
      at org.glassfish.apf.impl.AnnotationProcessorImpl.process(AnnotationProcessorImpl.java:344)
      ... 48 more

      As the same EAR works very well on GFv.3.1.1 on the same machine, I doubt that it is related to the EAR.

        Issue Links

          Activity

          Hong Zhang added a comment -

          This seems to the same issue as 18741. Can you try the 3.1.2 patch jar attached there and see if it resolves your issue?

          mkarg added a comment -

          I replaced the dol.jar by the one attached to #18741, restartet GF and tried to deploy. The message has changed now to:

          remote failure: Error occurred during deployment: injection failed on org.glassfish.javaee.core.deployment.DolProvider.archivistFactory with class com.sun.enter
          prise.deployment.archivist.ArchivistFactory. Please see server.log for more details.

          In the server log now there is the following:

          [#|2012-07-09T16:50:39.593+0200|SEVERE|glassfish3.1.2|javax.enterprise.system.tools.admin.org.glassfish.deployment.admin|_ThreadID=21;_ThreadName=Thread-2;|injection failed on org.glassfish.javaee.core.deployment.DolProvider.archivistFactory with class com.sun.enterprise.deployment.archivist.ArchivistFactory
          org.jvnet.hk2.component.ComponentException: injection failed on com.sun.enterprise.deployment.archivist.ArchivistFactory.archivists with class [Lcom.sun.enterprise.deployment.archivist.Archivist;
          at org.jvnet.hk2.component.InjectionManager.error_injectionException(InjectionManager.java:284)
          at org.jvnet.hk2.component.InjectionManager.inject(InjectionManager.java:161)
          at org.jvnet.hk2.component.InjectionManager.inject(InjectionManager.java:93)
          at com.sun.hk2.component.AbstractCreatorImpl.inject(AbstractCreatorImpl.java:126)
          at com.sun.hk2.component.ConstructorCreator.initialize(ConstructorCreator.java:91)
          at com.sun.hk2.component.AbstractCreatorImpl.get(AbstractCreatorImpl.java:82)
          at com.sun.hk2.component.SingletonInhabitant.get(SingletonInhabitant.java:67)
          at com.sun.hk2.component.EventPublishingInhabitant.get(EventPublishingInhabitant.java:139)
          at com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:78)
          at org.jvnet.hk2.component.Habitat.getBy(Habitat.java:1056)
          at org.jvnet.hk2.component.Habitat.getByType(Habitat.java:1037)
          at com.sun.hk2.component.InjectInjectionResolver.getComponentInjectValue(InjectInjectionResolver.java:159)
          at com.sun.hk2.component.InjectInjectionResolver.getValue(InjectInjectionResolver.java:90)
          at org.jvnet.hk2.component.InjectionManager.inject(InjectionManager.java:143)
          at org.jvnet.hk2.component.InjectionManager.inject(InjectionManager.java:93)
          at com.sun.hk2.component.AbstractCreatorImpl.inject(AbstractCreatorImpl.java:126)
          at com.sun.hk2.component.ConstructorCreator.initialize(ConstructorCreator.java:91)
          at com.sun.hk2.component.AbstractCreatorImpl.get(AbstractCreatorImpl.java:82)
          at com.sun.hk2.component.SingletonInhabitant.get(SingletonInhabitant.java:67)
          at com.sun.hk2.component.EventPublishingInhabitant.get(EventPublishingInhabitant.java:139)
          at com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:78)
          at org.jvnet.hk2.component.Habitat.getByContract(Habitat.java:1050)
          at org.jvnet.hk2.component.Habitat.getComponent(Habitat.java:779)
          at org.glassfish.internal.deployment.GenericHandler.getDefaultApplicationName(GenericHandler.java:128)
          at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:229)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:348)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:363)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1085)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1200(CommandRunnerImpl.java:95)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1291)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1259)
          at com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:461)
          at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:212)
          at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:179)
          at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:117)
          at com.sun.enterprise.v3.services.impl.ContainerMapper$Hk2DispatcherCallable.call(ContainerMapper.java:354)
          at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:195)
          at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:849)
          at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:746)
          at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1045)
          at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:228)
          at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
          at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
          at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
          at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
          at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
          at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
          at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
          at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
          at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
          at java.lang.Thread.run(Thread.java:662)
          Caused by: org.jvnet.hk2.component.ComponentException: injection failed on com.sun.enterprise.deployment.archivist.Archivist.annotationFactory with class com.sun.enterprise.deployment.annotation.factory.SJSASFactory
          at org.jvnet.hk2.component.InjectionManager.error_injectionException(InjectionManager.java:284)
          at org.jvnet.hk2.component.InjectionManager.inject(InjectionManager.java:165)
          at org.jvnet.hk2.component.InjectionManager.inject(InjectionManager.java:93)
          at com.sun.hk2.component.AbstractCreatorImpl.inject(AbstractCreatorImpl.java:126)
          at com.sun.hk2.component.ConstructorCreator.initialize(ConstructorCreator.java:91)
          at com.sun.hk2.component.AbstractCreatorImpl.get(AbstractCreatorImpl.java:82)
          at com.sun.hk2.component.EventPublishingInhabitant.get(EventPublishingInhabitant.java:139)
          at com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:78)
          at org.jvnet.hk2.component.Habitat$5.get(Habitat.java:703)
          at java.util.AbstractList$Itr.next(AbstractList.java:345)
          at java.util.AbstractCollection.toArray(AbstractCollection.java:171)
          at com.sun.hk2.component.InjectInjectionResolver.getArrayInjectValue(InjectInjectionResolver.java:113)
          at com.sun.hk2.component.InjectInjectionResolver.getValue(InjectInjectionResolver.java:81)
          at org.jvnet.hk2.component.InjectionManager.inject(InjectionManager.java:143)
          ... 49 more
          Caused by: java.lang.IllegalArgumentException: Can not set com.sun.enterprise.deployment.annotation.factory.SJSASFactory field com.sun.enterprise.deployment.archivist.Archivist.annotationFactory to com.sun.enterprise.deployment.annotation.factory.SJSASFactory
          at sun.reflect.UnsafeFieldAccessorImpl.throwSetIllegalArgumentException(UnsafeFieldAccessorImpl.java:146)
          at sun.reflect.UnsafeFieldAccessorImpl.throwSetIllegalArgumentException(UnsafeFieldAccessorImpl.java:150)
          at sun.reflect.UnsafeObjectFieldAccessorImpl.set(UnsafeObjectFieldAccessorImpl.java:63)
          at java.lang.reflect.Field.set(Field.java:657)
          at org.jvnet.hk2.component.InjectionManager.inject(InjectionManager.java:146)
          ... 61 more

          #]
          Hong Zhang added a comment -

          This might indicate we have different version of 3.1.2 builds. Can you extract that single class that was changed to apply to the dol.jar that's part of your GlassFish 3.1.2 installation? Thanks.

          mkarg added a comment -

          Which class exactly shall I extract / apply from / to dol.jar?

          Hong Zhang added a comment -

          Sorry, I thought you noticed the relevant comment in the other issue, let me just copy/paste here:
          ==================
          When I tried to provide patch jar in the past for 3.1.2, I was told the version I have does not exactly match their versions, so the safer way to do this would be:
          1. extract the dol.jar patch I attached to the issue.
          2. use the extracted com/sun/enterprise/deployment/ConnectorDescriptor.class to update the dol.jar in your GlassFish installation (this class is the only class that's changed to fix the issue).
          ===================

          mkarg added a comment -

          I replaced ConnectorDescriptor.class and the problem is gone.

          Great! Thank you so much! I hope there soon will be a GFv3.1.3 containing this fix!

          Please close this JIRA issue, as the bug is fixed in 3.1.3.

          Regards
          Markus

          Hong Zhang added a comment -

          Good to know the patch worked for you. I will close this issue as the duplicate of 18741. We will fix this in the next version of 3.1.* release.

          mkarg added a comment -

          Is this fixed contained in the latest GF 3.1.2.2 ?

          Hong Zhang added a comment -

          No, it did not make it. I will watch out for the next patch or dot release of 3.1.* and try to get the fix in there.

          TaranSingh added a comment - - edited

          Hi,
          Has this been fixed?
          I tried using the fix you provided by copying the dolo.jar to GF 3.1.2/module directory and also the 2nd options of extracting and copying the class file in the old jar file, but neither worked for. I'm deploying a EAR file using admin console and get this error as below,

          I'm using Java 1.7

          #|2012-08-01T16:38:29.809+0100|SEVERE|glassfish3.1.2|javax.enterprise.system.tools.admin.org.glassfish.deployment.admin|_ThreadID=67;_ThreadName=Thread-2;|Exception while deploying the app [ABC] : nullat org.glassfish.apf.AnnotationInfo@529ec927
          nullat org.glassfish.apf.AnnotationInfo@529ec927
          .....
          Caused by: java.lang.NullPointerException
          at com.sun.enterprise.deployment.util.DOLUtils.isRAConnectionFactory(DOLUtils.java:157)
          at com.sun.enterprise.deployment.annotation.handlers.ResourceHandler.getDescriptors(ResourceHandler.java:315)

          Hong Zhang added a comment -

          As previous comments indicated, the fix has gone in GlassFish v4 (trunk) but not in 3.1.*. The patch had worked for Markus and another person (I think both of them extracted the ConnectorDescriptor.class and applied it to the dol.jar in their installation). Maybe you could give it another try, if it still does not work for you, maybe the issue you encountered is different than theirs (though the stack trace looks pretty similar), and you could attach your test case and we can take a further look.

          TaranSingh added a comment - - edited

          Many thanks for your prompt response.
          Below is the stack trace which seems to bit different from what other have reported especially after line at org.glassfish.admin.rest.ResourceUtil.runCommand(ResourceUtil.java:214). I have attached the jar merged after I copy the class file that I'm using. Unfortunately it will take a while for me to provide a test case as I'm deploying the actual EAR which is quite huge. can you verify the jar I have provided, if it works for you?

          stacktrace
          ============

          [#|2012-08-02T15:14:11.076+0100|SEVERE|glassfish3.1.2|javax.enterprise.system.core.com.sun.enterprise.v3.server|_ThreadID=102;_ThreadName=Thread-2;|nullat org.glassfish.apf.AnnotationInfo@29190ac3
          java.lang.IllegalStateException: nullat org.glassfish.apf.AnnotationInfo@29190ac3
          at com.sun.enterprise.deployment.archivist.Archivist.readAnnotations(Archivist.java:487)
          at com.sun.enterprise.deployment.archivist.WebArchivist.postAnnotationProcess(WebArchivist.java:365)
          at com.sun.enterprise.deployment.archivist.WebArchivist.postAnnotationProcess(WebArchivist.java:89)
          at com.sun.enterprise.deployment.archivist.Archivist.readRestDeploymentDescriptors(Archivist.java:406)
          at com.sun.enterprise.deployment.archivist.Archivist.readDeploymentDescriptors(Archivist.java:380)
          at com.sun.enterprise.deployment.archivist.Archivist.open(Archivist.java:243)
          at com.sun.enterprise.deployment.archivist.Archivist.open(Archivist.java:252)
          at com.sun.enterprise.deployment.archivist.ApplicationArchivist.readModulesDescriptors(ApplicationArchivist.java:657)
          at com.sun.enterprise.deployment.archivist.ApplicationArchivist.openWith(ApplicationArchivist.java:258)
          at com.sun.enterprise.deployment.archivist.ApplicationFactory.openWith(ApplicationFactory.java:240)
          at org.glassfish.javaee.core.deployment.DolProvider.load(DolProvider.java:175)
          at org.glassfish.javaee.core.deployment.DolProvider.load(DolProvider.java:94)
          at com.sun.enterprise.v3.server.ApplicationLifecycle.loadDeployer(ApplicationLifecycle.java:827)
          at com.sun.enterprise.v3.server.ApplicationLifecycle.setupContainerInfos(ApplicationLifecycle.java:769)
          at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:368)
          at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:240)
          at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:389)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:348)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:363)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1085)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1200(CommandRunnerImpl.java:95)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1291)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1259)
          at org.glassfish.admin.rest.ResourceUtil.runCommand(ResourceUtil.java:214)
          at org.glassfish.admin.rest.ResourceUtil.runCommand(ResourceUtil.java:207)
          at org.glassfish.admin.rest.resources.TemplateListOfResource.createResource(TemplateListOfResource.java:148)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke(Method.java:601)
          at com.sun.jersey.spi.container.JavaMethodInvokerFactory$1.invoke(JavaMethodInvokerFactory.java:60)
          at com.sun.jersey.server.impl.model.method.dispatch.AbstractResourceMethodDispatchProvider$ResponseOutInvoker._dispatch(AbstractResourceMethodDispatchProvider.java:205)
          at com.sun.jersey.server.impl.model.method.dispatch.ResourceJavaMethodDispatcher.dispatch(ResourceJavaMethodDispatcher.java:75)
          at com.sun.jersey.server.impl.uri.rules.HttpMethodRule.accept(HttpMethodRule.java:288)
          at com.sun.jersey.server.impl.uri.rules.SubLocatorRule.accept(SubLocatorRule.java:134)
          at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:147)
          at com.sun.jersey.server.impl.uri.rules.SubLocatorRule.accept(SubLocatorRule.java:134)
          at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:147)
          at com.sun.jersey.server.impl.uri.rules.ResourceClassRule.accept(ResourceClassRule.java:108)
          at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:147)
          at com.sun.jersey.server.impl.uri.rules.RootResourceClassesRule.accept(RootResourceClassesRule.java:84)
          at com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest(WebApplicationImpl.java:1469)
          at com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest(WebApplicationImpl.java:1400)
          at com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest(WebApplicationImpl.java:1349)
          at com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest(WebApplicationImpl.java:1339)
          at com.sun.jersey.server.impl.container.grizzly.GrizzlyContainer._service(GrizzlyContainer.java:182)
          at com.sun.jersey.server.impl.container.grizzly.GrizzlyContainer.service(GrizzlyContainer.java:147)
          at org.glassfish.admin.rest.adapter.RestAdapter.service(RestAdapter.java:148)
          at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:179)
          at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:117)
          at com.sun.enterprise.v3.services.impl.ContainerMapper$Hk2DispatcherCallable.call(ContainerMapper.java:354)
          at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:195)
          at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:849)
          at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:746)
          at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1045)
          at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:228)
          at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
          at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
          at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
          at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
          at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
          at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
          at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
          at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
          at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
          at java.lang.Thread.run(Thread.java:722)
          Caused by: nullat org.glassfish.apf.AnnotationInfo@29190ac3
          at org.glassfish.apf.impl.AnnotationProcessorImpl.process(AnnotationProcessorImpl.java:367)
          at org.glassfish.apf.impl.AnnotationProcessorImpl.process(AnnotationProcessorImpl.java:375)
          at org.glassfish.apf.impl.AnnotationProcessorImpl.processAnnotations(AnnotationProcessorImpl.java:289)
          at org.glassfish.apf.impl.AnnotationProcessorImpl.processAnnotations(AnnotationProcessorImpl.java:271)
          at org.glassfish.apf.impl.AnnotationProcessorImpl.process(AnnotationProcessorImpl.java:199)
          at org.glassfish.apf.impl.AnnotationProcessorImpl.process(AnnotationProcessorImpl.java:134)
          at com.sun.enterprise.deployment.archivist.Archivist.processAnnotations(Archivist.java:598)
          at com.sun.enterprise.deployment.archivist.Archivist.readAnnotations(Archivist.java:442)
          ... 65 more
          Caused by: java.lang.NullPointerException
          at com.sun.enterprise.deployment.util.DOLUtils.isRAConnectionFactory(DOLUtils.java:157)
          at com.sun.enterprise.deployment.annotation.handlers.ResourceHandler.getDescriptors(ResourceHandler.java:315)
          at com.sun.enterprise.deployment.annotation.handlers.ResourceHandler.processResource(ResourceHandler.java:229)
          at com.sun.enterprise.deployment.annotation.handlers.ResourceHandler.processAnnotation(ResourceHandler.java:148)
          at com.sun.enterprise.deployment.annotation.handlers.AbstractResourceHandler.processAnnotation(AbstractResourceHandler.java:142)
          at org.glassfish.apf.impl.AnnotationProcessorImpl.process(AnnotationProcessorImpl.java:344)
          ... 72 more

          #]

          ****************
          Further to this, I tried to deploy the DummyMDBTestEAR.ear using the both once the merged jar and secondly the patched dol.jar, but it still throws same NPE
          ****************
          [#|2012-08-02T15:06:22.767+0100|INFO|glassfish3.1.2|javax.enterprise.system.core.security|_ThreadID=101;_ThreadName=Thread-2;|JACC Policy Provider:Failed Permission Check: context (" __admingui/__admingui ") , permission (" ("java.security.SecurityPermission" "putProviderProperty.SunEC") ") |#]

          [#|2012-08-02T15:06:22.949+0100|INFO|glassfish3.1.2|javax.enterprise.system.container.ejb.com.sun.ejb.containers|_ThreadID=106;_ThreadName=Thread-2;|Created EjbThreadPoolExecutor with thread-core-pool-size 16 thread-max-pool-size 32 thread-keep-alive-seconds 60 thread-queue-capacity 2147483647 allow-core-thread-timeout false |#]

          [#|2012-08-02T15:06:23.546+0100|INFO|glassfish3.1.2|com.sun.jersey.server.impl.application.WebApplicationImpl|_ThreadID=106;_ThreadName=Thread-2;|Initiating Jersey application, version 'Jersey: 1.11 12/09/2011 10:27 AM'|#]

          [#|2012-08-02T15:06:23.991+0100|INFO|glassfish3.1.2|javax.enterprise.system.tools.admin.org.glassfish.admin.rest.adapter|_ThreadID=106;_ThreadName=Thread-2;|REST00001: Listening to REST requests at context: /management/domain|#]

          [#|2012-08-02T15:06:24.008+0100|INFO|glassfish3.1.2|org.glassfish.admingui|_ThreadID=101;_ThreadName=Thread-2;|Redirecting to /index.jsf|#]

          [#|2012-08-02T15:06:25.597+0100|INFO|glassfish3.1.2|org.glassfish.admingui|_ThreadID=100;_ThreadName=Thread-2;|Admin Console: Initializing Session Attributes...|#]

          [#|2012-08-02T15:06:58.574+0100|WARNING|glassfish3.1.2|org.apache.catalina.connector.Request|_ThreadID=101;_ThreadName=Thread-2;|PWC4011: Unable to set request character encoding to UTF-8 from context , because request parameters have already been read, or ServletRequest.getReader() has already been called|#]

          [#|2012-08-02T15:06:58.846+0100|INFO|glassfish3.1.2|org.glassfish.admingui|_ThreadID=101;_ThreadName=Thread-2;|GUI deployment: uploadToTempfile|#]

          [#|2012-08-02T15:06:58.856+0100|INFO|glassfish3.1.2|org.glassfish.admingui|_ThreadID=101;_ThreadName=Thread-2;|uploadFileName=dummymdbtestear.ear|#]

          [#|2012-08-02T15:06:59.349+0100|SEVERE|glassfish3.1.2|javax.enterprise.system.tools.deployment.org.glassfish.deployment.common|_ThreadID=109;_ThreadName=Thread-2;|The log message is empty or null. Please log an issue against the component in the logger field.|#]

          [#|2012-08-02T15:06:59.349+0100|SEVERE|glassfish3.1.2|javax.enterprise.system.core.com.sun.enterprise.v3.server|_ThreadID=109;_ThreadName=Thread-2;|Exception while deploying the app [DummyMDBTestEAR]|#]

          [#|2012-08-02T15:06:59.349+0100|SEVERE|glassfish3.1.2|javax.enterprise.system.core.com.sun.enterprise.v3.server|_ThreadID=109;_ThreadName=Thread-2;|nullat org.glassfish.apf.AnnotationInfo@3b6367f4
          java.lang.IllegalStateException: nullat org.glassfish.apf.AnnotationInfo@3b6367f4
          at com.sun.enterprise.deployment.archivist.Archivist.readAnnotations(Archivist.java:487)
          at com.sun.enterprise.deployment.archivist.Archivist.readAnnotations(Archivist.java:429)

          Hong Zhang added a comment -

          I was able to deploy the DummyMDBTestEAR.ear with your attached dol.jar successfully (and with no NPEs).

          Did you place the dol.jar under $GF_INSTALL/modules directory and restart server after placing the jar there?

          TaranSingh added a comment -

          Yes, I copied it under GF_INSTALL/modules directory and restarted server.
          You are right, I tried to deploy the test EAR into default domain1 and did go through smoothly. However, I tried it the default GF 3.1.2 dol.jar as well and even that one went through without any complaints as well.

          Hong Zhang added a comment -

          That's strange. Did you restart server after you copy the default dol.jar back? When I tried earlier today, I tried with the default installation first also and I had a NPE and only with the updated dol.jar the NPE went away.

          TaranSingh added a comment -

          Many Thanks Hong Zhang for your continued support.
          I was able to deploy the test MDB project into GF 3.1.2 even without using the updated dol.jar. My problem was bit weird. It turned out to be an issue with osgi-cache module. In my case the osgi-cache was generated using asadmin, and since we are migrating from GF 2.1.1, I guess the module generated was getting some wrong keys. I then replaced the osgi-cache with one that that come as part of std. installation from domain1 and it went like a tooty frooty.
          Cheers mate

          Hong Zhang added a comment -

          Glad to know that you solved the mystery!

          mkarg added a comment -

          Please publish GF 3.1.2.3 including this fix!


            People

            • Assignee:
              Hong Zhang
              Reporter:
              mkarg
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: