glassfish
  1. glassfish
  2. GLASSFISH-18905

Glassfish fails to start with new HK2 2.0 with Ondemand flag enabled

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0_b49
    • Component/s: hk2
    • Labels:
      None
    • Environment:

      cp glassfish3/glassfish/config/osgi.properties glassfish3/glassfish/domains/domain1/config
      set glassfish.osgi.ondemand=true
      Start Glassfish server (./asadmin start-domain -v

      Description

      There is also an existing bug filed against a corba component which is causing regression; so please manually remove a JAR file named exception-annotation-processor.jar from the modules directory before starting the server.

      Our jobs are showing regression after the HK2 2.0 has been checked into the Glassfish trunk.

      I will attach the script and error log for your reference to reproduce the error.

      1. Error.txt
        16 kB
        vijay_oracle
      2. Script.txt
        0.4 kB
        vijay_oracle

        Activity

        tbeerbower added a comment -

        Committed revision 55140.

        Added hk2 bundles in osgi properties file ...

        hk2.bundles=\
        $

        {com.sun.aas.installRootURI}modules/core.jar \
        ${com.sun.aas.installRootURI}

        modules/hk2-api.jar \
        + $

        {com.sun.aas.installRootURI}modules/hk2-utils.jar \
        + ${com.sun.aas.installRootURI}

        modules/cglib.jar \
        $

        {com.sun.aas.installRootURI}modules/javax.inject.jar \
        ${com.sun.aas.installRootURI}

        modules/osgi-resource-locator.jar \
        $

        {com.sun.aas.installRootURI}

        modules/hk2-locator.jar \

        This gets past the error in the given Error.txt file but I'm having another issue starting Glassfish. I'm not sure yet if it is related to the ondemand flag.

        tlcksnyder added a comment -

        reassign due to Tom leaving Oracle.

        Sanjeeb Sahoo added a comment -

        This is primarily fixed with svn rev #55314. There was a little bit of issue with JAXB bundles, but that got resolved in svn rev #55318 as part of GLASSFISH-18976.


          People

          • Assignee:
            Sanjeeb Sahoo
            Reporter:
            vijay_oracle
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: