Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 3.1.2.2
    • Fix Version/s: None
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Linux

      Description

      When i create JDBC Connection Pool then JDBC Resource i can't see it in Server -> Resources and when i try to lookup
      JDBC Resource:
      InitialContext ic = new InitialContext();
      DataSource dataSource = (DataSource) ic.lookup("jdbc/MyPool");
      Connection connection = dataSource.getConnection();

      i get exception

      javax.naming.NamingException: Lookup failed for 'jdbc/MyPool' in SerialContext[myEnv=

      {java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming}

      [Root exception is javax.naming.NameNotFoundException: MyPool not found

        Activity

        Vitaliy Kalayda added a comment -

        But when i add <resource-ref ref="jdbc/MyPool"></resource-ref> into domain config servers->server section all gone OK

        Vitaliy Kalayda added a comment -

        Looks like web administration panel is broken.
        When i create JDBC Connection Pool from "asadmin" console all going fine.

        Shalini added a comment -

        Transferring to admin console team for investigation as per the reporter's comments.

        Anissa Lam added a comment -

        Is there any cluster created ? Can you give the steps on how to reproduce this in console ? thanks

        Vitaliy Kalayda added a comment -

        Without cluster.

        Just create JDBC Connection Pool and JDBC Resource.

        Vitaliy Kalayda added a comment -

        I am sorry, looks like something is wrong with new postgresql jdbc driver
        Because with old driver all working fine.

        Thank You.

        Anissa Lam added a comment -

        Based on the reporter's comment, I am closing this bug invalid.
        If this isn't the case, please reopen the bug and gives exact step to reproduce.
        thanks.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            Vitaliy Kalayda
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: