glassfish
  1. glassfish
  2. GLASSFISH-18922

Excessive number of sockets open in TIME_WAIT status in admin console

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1.2_b23
    • Fix Version/s: 4.0_b79, 4.0
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Debian Linux 5
      Maximum number of open files per process (ulimit) set to: 1024

      Description

      Go to the admin console and click on Applications. Immediately, in server.log several exceptions appear saying too many open files. If you run

      netstat -a|grep TIME_WAIT
      

      at the same time a large number of open connections - between localhost:xxxxx and localhost:4848, not between localhost and the remote web browser! - are shown.

      Two bug reports, http://java.net/jira/browse/GLASSFISH-18117 and http://java.net/jira/browse/GLASSFISH-16672 have already been closed with the comment that this issue is fixed in 3.1.2. But it is not!

      VERY IMPORTANT: This occurs with TWO domains. One is the domain created by the installer, which I do not intend to use. The other is the domain converted over from Glassfish 3.1 using the upgrade tool (doing a side-by-side upgrade), which is the domain that I started.

        Activity

        robin.green added a comment -

        OK, the other domain is not relevant. I deleted it and I still have the same problem.

        robin.green added a comment -

        I had 9 web applications deployed. I undeployed 8 of them, restarted Glassfish and now I am no longer seeing too many open file exceptions from the remaining web application, although there are still a large number of sockets in a TIME_WAIT state.

        Anissa Lam added a comment -

        Request Siraj to look at this again.

        Anissa Lam added a comment -

        robin.green, can you provide the following information:

        1. Can you reproduce this on the latest promoted 4.0 build ?
        2. Are you saying that the problem exists (large number of sockets in TIME_WAIT state) is reproduced if you deploy/undeploy using the admin console only ? Do you see the same issue if you use CLI to deploy ?

        thanks

        Anissa Lam added a comment -

        Issues need to be addressed before 4.0 HCF (3/25)

        Anissa Lam added a comment -

        robin.green,
        I am waiting for the above information. I cannot reproduce the problem on Linux as you reported.
        The info is requested on 2/11/2013. If no info is provided by 2/28/2013, I will close the issue as 'not reproducible'. thanks.

        Anissa Lam added a comment -

        I have requested additional info from the reporter without hearing anything. The last update from the reporter is almost 9 months ago. I am closing this as 'Cannot Reproduce'.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            robin.green
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: